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1 Important Safety Instructions 

1) Read these instructions. 

2) Keep these instructions. 

3) Heed all warnings. 

4) Follow all instructions. 

5) Do not use this apparatus near water. 

6) Clean only with dry cloth. 

7) Do not block any ventilation openings. Install in accordance with the 

manufacturer’s instructions. 

8) Do not install near any heat sources such as radiators, heat registers, stoves, 

or other apparatus (including amplifiers) that produce heat. 

9) Do not defeat the safety purpose of the polarized or grounding-type plug. A 

polarized plug has two blades and a third grounding prong. The wide blade or 

the third prong are provided for your safety. If the provided plug does not fit 

into your outlet, consult an electrician for replacement of the obsolete outlet. 

10) Protect the power cord from being walked on or pinched particularly at plugs, 

convenience receptacles, and the point where they exit from the apparatus. 

11) Only use attachments/accessories specified by the manufacturer. 

12) Use only with the cart, stand, tripod, bracket, or table specified by the 

manufacturer, or sold with the apparatus. When a cart is used, use caution 

when moving the cart/apparatus combination to avoid injury from tip-over. 

13) Unplug this apparatus during lightning storms or when unused for long periods 

of time. 

14) Refer all servicing to qualified service personnel. Servicing is required when 

the apparatus has been damaged in any way, such as power-cord supply or 

plug is damaged, liquid has been spilled or objects have fallen into the 

apparatus, the apparatus has been exposed to rain or moisture, does not 

operate normally, or has been dropped. 

15) Warning: To reduce the risk of fire or electric shock, do not expose this 

product to rain or moisture. 
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Safety symbols 

Familiarize yourself with the safety symbols in Figure 1 below. These symbols are displayed on 

the apparatus and warn you of the potential danger of electric shock if the system is 

used improperly. They also refer you to important operating and maintenance 

instructions in the product user manual.  

 

 
Figure 1-1: Safety symbols 

Mains power cord 

Eclipse HX matrices are powered by an internal power supply. The cord to connect the 

internal power supply to the mains supply must conform to the following: 

 

• The mains power cord shall have an IEC C13 connector at one end and a 

mains power plug at the other end. 

• An IEC C13 plug has three pins, the center pin carrying the earth / ground. 

The other two pins carry neutral and live circuits. 

• The conductors of the mains cords shall have adequate cross-sectional area for 

rated current consumption of the equipment. 
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• The mains plug that connects to the mains supply must be approved for use in 

the country where the equipment is to be used. 

• The mains power cord must be an IEC mains power cord complying with 

standard IEC60320; IEC320/C13. 

• Mains power cords used in the U.S. must also comply with standard UL817. 



Eclipse | Upgrade Guide 

 

Page 10 of 315 

 

2 Introduction 

This guide describes how to upgrade to Eclipse HX v14, a software release for the 

Clear-Com Eclipse HX™ digital matrix system (standalone or networked).  This guide 

additionally identifies the simpler upgrade from v7.x/v8.x/v9.x/v10.x/11.x/12.x/13.x 

to v14. 

The system components covered by the guide include (but are not limited to): 

• Matrices (Eclipse HX-PiCo, Eclipse HX-Delta, Eclipse HX-Median and Eclipse 

HX-Omega) 

• Interface cards (E-IPA, E-FIB, E-QUE, MVX-A16, E-MADI64, LMC-64, and 

others) 

• Interface modules (AES-6, TEL-14 and others) 

• User panels (V-Series, V-Series Iris, V-Series IrisX and i-Station panels) 

Important note:  

Eclipse HX upgrades must be performed by a technically qualified engineer. 

2.1 Planning the upgrade to Eclipse HX 
Before you start upgrading your Eclipse (ECS v5.2.5 or EHX 

v7x/v8.x/v9.x/10.x/11.x/12.x/13.x) system components to Eclipse HX v14 ensure that 

you have: 

• Sufficient spare (replacement) cards, interfaces or panels for the upgrade. 

 

• Scheduled enough time to complete the upgrade, or if required, roll back the 

upgrade to the version that was running before the upgrade.  

 

• A suitable backup system is in place to maintain service, if your intercom 

system is part of a mission critical or sensitive application.  

You should also be aware that: 

• The order in which you carry out the upgrade is important. The chapters of 

this guide are laid out in the order that your system components should be 

upgraded. 

 

Tip:  For a quick reference to the upgrade procedures you require, and the 

order in which they should be carried out, see chapter 3 Quick reference: 

Upgrading to Eclipse HX. 

 

• If you are upgrading V-Series panels, you may have to upgrade each V-

Series panel individually by connecting it directly to a PC. 
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o If you are upgrading Iris/IrisX panels you may have to upgrade each 

panel individually (connect it directly to a PC, via EHX panel upgrade, 

USB connection or CCM connection via a web browser).  

Note: Upgrading Iris/IrisX panels (v.3 / v.5, upgrading to v5.43 or v. 6.15) - check the FPGA 

status first  

When upgrading Iris/IrisX panels please observe the following steps:  

o Before attempting an upgrade, pin reset or power cycle the panel(s) 

and wait to make sure the FGPA/QSPI are both available. 

o Use the EHX firmware report (or CCM) to check the FPGA/QSPI are 

both available.  

If the FPGA / QSPI is unavailable – do not upgrade the panel  

 

• Upgrading the matrices in a networked (linked) system should take place at the 

same time, because the data sent between networked matrices can change.  

When upgrading networked (linked) matrices or a single matrix, Clear-Com 

recommends that you: 

• Remove one CPU card from each matrix, put it in a safe place, then upgrade 

the other CPU card and the rest of the system upgrade. 

• Upgrade the remaining CPU cards in the matrices only when the upgrade has 

been completed and tested across the full system. Leaving the remaining CPU 

cards until last gives you the capability of quickly rolling back to the previously 

running version, if any mission critical issues are encountered. NOTE – When 

the second card is upgraded retrospectively as described it needs to be placed 

in the frame without the other CPU card in place. This is because CPU cards 

only exchange data as a master/slave pair when both cards are already 

running the same firmware. Once both cards are upgraded insert both cards 

and re-download the frame configuration. 

 

• Great care must be taken when opening the lid of the Eclipse HX-PiCo matrix 

to upgrade components. This may invalidate UL status. 

 

 

Remove power from the device first, to avoid working with the 

system while it is live. Observe all electrical shock hazard 

warning and precautions for handling electrostatic sensitive 

devices  

 

2.1.1 Client / Server installations  

When upgrading Client / Server installations from ECS v5.2.5 or EHX 

v7.x/v8.x/v9.x/v10.x/v11.x/12.x/13.x to Eclipse HX v14, you must: 
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• Use the EHX v14 Server Installer only on the PC that is to be the EHX Server. 

The EHX v14 server installer will automatically update your IIS and configure 

it to work with Eclipse HX v14. 

• Use the standard combined EHX/Dynam-EC 14.0 Client Installer on all the 

Client PCs. The Server PC can also act as a client. 

You should check that you have the appropriate IIS and .Net Windows components 

installed prior to installing the EHX Server. Please refer to the Initial Setup section of 

the Client/Server chapter in the EHX User Guide for a complete list of the components 

required for each version of Windows. 

Note: Installing an EHX Server is an advanced workflow - please contact Clear-Com 

Support for advice before attempting to install an EHX Server. 

Before upgrading your EHX Server installation, Clear-Com strongly recommends that 

you export any existing projects (using File->Export from an EHX Client) and backup 

your users list (using the Export command in the User Management screen). It is 

recommended that you uninstall your existing EHX Server before installing the newer 

version. 

2.1.2 Roll back strategy  

You should not encounter any mission critical issues when upgrading to Eclipse HX 

v14. However, if you decide to roll back the system to the previously running version, 

then you must: 

• Allow adequate time for the roll back operation. 

• Roll back all system components to the same baseline version. 

Temporary roll back strategy 

If you want to roll back to the previously running version for a temporary period only, 

before making another attempt to upgrade to Eclipse HX v14, then you may implement 

the following temporary roll back strategy: 

1) Leave all cards and panels at Eclipse HX v14 

2) Roll back the matrix CPU card to run at the previously running version. 

3) Re-install the previous running version of ECS/EHX and import your old 

configurations. 

Caution: 

The above strategy is a temporary solution only. Eclipse HX v14 configurations will not 

import or work with a CPU card at ECS v5.2.5 or EHX 

v7.x/v8.x/v9.x/v10.x/v11.x/12.x/13.x. If you want to run the previously running 
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system software for an extended period, Clear-Com recommends rolling back all 

system components to the same baseline version.  

2.1.3 Supplied Upgrade Media 

Different upgrade media are supplied to the customer, according to the type of Eclipse 

HX product that has been purchased: 

 

Product Firmware Documentation 

USB 

System 

Drivers 

USB 

Documentation 

USB 

Matrix  - - 

 
 

ECS / EHX / 

Dynam-EC 

 

 
 

- - 

Upgrade kit  

 

 - 

Table 2-1: Supplied USBs 

System Drivers Upgrade Media 

The System Drivers upgrade media contains the latest firmware for your Eclipse HX 

devices, including Boot PROM and FPGA / CPLD code files for Eclipse HX matrices, 

interface cards, interface modules and supported panels (i-Station and V-Series 

panels). You must upgrade to the latest firmware when upgrading to Eclipse HX v14. 

The System Drivers USB also includes the third party software that may be used 

during upgrades. 

Firmware USB 

The Firmware USB contains:  

• The EHX configuration software, which is used to manage and configure your 

Eclipse HX devices. 

• Dynam-EC, which provides fast, intuitive audio routing control for your Eclipse 

HX system. 

• A full set of Eclipse HX documentation, including release notes and user 

guides. 

• The application code files for your Eclipse HX matrices. 

The Firmware USB also includes the third party software that may be used during 

upgrades. 
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You must upgrade to the latest application code files when upgrading to Eclipse HX 

v14. You require both sets of upgrade media to complete a full upgrade to Eclipse HX 

v14. 

Tip:  You can find user documentation, brochures and summary information for all 

Clear-Com’s products (including the Eclipse and Eclipse HX systems), on the Clear-

Com website at: http://www.clearcom.com/support/user-manuals. 

A number of upgrade procedures, require the use of a TFTP Server. One is supplied on 

the USB, but you can use any compatible TFTP Server. 

2.1.4 Fitting the Eclipse HX door panel 

To enable you to change the branding of Eclipse Median and Eclipse Omega matrices 

that have been upgraded to Eclipse HX, Clear-Com provides an Eclipse HX door panel 

kit. 

The figures that illustrate the procedure below feature an Eclipse Median matrix. 

However, the procedure is also applicable to Eclipse Omega matrices.  

Tip: For more information about fitting the Eclipse HX door panel to your upgraded 

Eclipse Median and Eclipse Omega matrices, see the Eclipse Matrix Door 

Replacement Instructions, included with your kit. 

 

To replace the Eclipse branded door with the Eclipse HX door: 

1) Remove the two screws securing the Eclipse door (and hinge) unit to the 

Eclipse matrix. Retain the screws. 

 

Figure 2-1: Screws securing the Eclipse door (and hinge) 

unit 

1 

http://www.clearcom.com/support/user-manuals
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2) Remove the four screws securing the hinge to the existing door unit. Retain 

the screws. 

 

 Figure 2-2: Removing the screws securing the hinge to 

the Eclipse door 

3) Use the four screws retained in Step 2 to secure the hinge to the new Eclipse 

HX door unit.  

 

 

 

 

 

 

 

 

 

Figure 2-3: Securing the hinge to the Eclipse HX door 

4) Use alcohol to clean the latch-mount surface (located to the bottom right on 

the inside of the Eclipse HX door). 

2 

3 
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Figure 2-4: Latch-mount surface, inside the Eclipse HX 

door 

5) To attach the Eclipse HX door to the matrix, secure the hinge to the matrix 

using the two screws retained from Step 1. 

 

 

 

 

Figure 2-5: Attaching the Eclipse HX door to the matrix 

4 

Latch-mount 

surface 

5 
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6) Open the door. Insert the latch (a separate item from the door unit) into the 

latch receptacle on the chassis. 

The latch receptacle is located to the bottom left of the area enclosed by the 

door. 

 
Note: 
Leave the white plastic protector on the latch when you insert the latch into the receptacle. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2-6: Inserting the latch into the latch receptacle 

7) To expose the adhesive surface of the latch, remove the green film from the 

back of the latch.  

 

Latch 

receptacle 

Latch 

6 
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8) Close the door. Press down firmly on the bottom left of the door, so that the 

latch adheres firmly to the latch-mount surface inside the door. 

9) Open the door again and remove the white plastic protector from the latch. 

 
The Eclipse HX door has now been fitted to the matrix. 

 

 

 

 

 

 

 

 

 

 

Figure 2-7: Removing the white plastic protector from the 

latch 

2.1.5  Help with upgrading 

If you require more help with either a particular upgrade procedure or the 

implementation of a whole system upgrade, contact either: 

• Clear-Com Technical Support (http://www.clearcom.com/contact/support-

contacts). 

• Your Clear-Com sales representative, to arrange for an engineer to visit your 

site and assist you with the upgrade. 

 

See page 2 of this guide for contact email addresses, or go to 

http://www.clearcom.com/contact/sales-contacts. 

 

9 

White 

http://www.clearcom.com/contact/support-contacts
http://www.clearcom.com/contact/support-contacts
http://www.clearcom.com/contact/sales-contacts
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3 Quick reference: Upgrading to Eclipse HX v14 

The upgrade kit includes a Drivers USB, containing the latest firmware files (including Boot and FPGA / CPLD code files) for 

your Eclipse HX devices. It also includes a software USB, containing the application code files for your Eclipse HX feature 

applications. It includes the EHX configuration software, Dynam-EC audio routing software, and Eclipse HX v14 documentation. 

You require both upgrade media to complete a full system upgrade. For more information, see 2.1.3 Supplied . 

3.1 Upgrading from 5.2.5 

The following table lists the procedures that you will require to upgrade from ECS v5.2.5 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) via serial cable and 

third-party TFTP tools 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is required 
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Order System component 

 

Upgrade procedure(s) Notes 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 

3 E-FIB card No upgrade required. 

 

 

4 V-

Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required  

6 CellCom® / FreeSpeak® 

Beltpack / Transceiver / 

Splitter 

No longer supported  
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Order System component 

 

Upgrade procedure(s) Notes 

7 MVX-A16 card 7.2.2 Upgrading the MVX-A16 boot and app code using the Renesas 

FDT 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 

8 Eclipse HX-PiCo  6.1 Changing the Eclipse HX-PiCo PROM 

6.2 Changing the Eclipse HX-PiCo RAM 

6.3 Changing the Eclipse HX-PiCo DIP switches 

6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

6.5.2 Upgrading the Eclipse HX-PiCo MVX boot and/or app code 

using the Renesas FDT 

6.7 Upgrading the Eclipse HX-PiCo CPLD and FPGA code with Xilinx 

tools 

If you are upgrading the PiCo to 

an HX-PiCo please contact your 

Clear-Com representative to 

establish if your hardware is HX 

ready. If your PiCo hardware is 

not HX ready then this is a 

factory only upgrade. 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software  

4.1 Backing up your ECS v5.2.5 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

11 CPU card 5.1 Changing the CPU card PROM  
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Order System component 

 

Upgrade procedure(s) Notes 

5.2 Changing the CPU card RAM 

5.3 Changing the CPU card DIP switches 

5.4 Upgrading the CPU card secondary bootloader and application 

code 

5.8 Upgrading CPU Card U1 CPLD 

5.11 Downloading a test configuration to the CPU card using EHX 

5.7 Upgrading CPU Card U53 CPLD 

5.9 Upgrading the CPU card U53 CPLD code with Xilinx tools 

5.10 Upgrading the CPU card U1 CPLD code with Xilinx tools 

12 Dynam-EC (without EHX 

on the same PC) 

4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

Table 3-1: Procedures for upgrading from ECS v5.2.5 to Eclipse HX v14 
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3.2 Upgrading from 7.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v7.0 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) via serial cable and 

third-party TFTP tools 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is required 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 
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Order System component 

 

Upgrade procedure(s) Notes 

3 E-FIB card No upgrade required. 

 

 

4 V-

Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required  

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported  

7 MVX-A16 card 7.2.2 Upgrading the MVX-A16 boot and app code using the Renesas 

FDT 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 

MK II (Blue) card only 
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Order System component 

 

Upgrade procedure(s) Notes 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required.  

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

Table 3-2: Procedures for upgrading from Eclipse HX v7.0 to Eclipse HX v14 
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3.3 Upgrading from 7.1 

The following table lists the procedures that you will require to upgrade from Eclipse HX v7.1 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is required 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 

3 E-FIB card No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

4 V-

Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required   

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported  

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 

MK II (Blue) card only 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 
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Order System component 

 

Upgrade procedure(s) Notes 

9 AES-6 No upgrade required 

 

 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

Table 3-3: Procedures for upgrading from Eclipse HX v7.1 to Eclipse HX v14 
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3.4 Upgrading from 7.5 

The following table lists the procedures that you will require to upgrade from Eclipse HX v7.5 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is required 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 
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Order System component 

 

Upgrade procedure(s) Notes 

3 E-FIB card No upgrade required. 

 

 

4 

 

 

 

V-

Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required   

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

Error! Reference source not found. Error! Reference source not found.. Transceiver application only. 

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 

 

MK II (Blue) card only 
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Order System component 

 

Upgrade procedure(s) Notes 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required  

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

Table 3-4: Procedures for upgrading from Eclipse HX v7.5 to Eclipse HX v14 
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3.5 Upgrading from 7.6 

The following table lists the procedures that you will require to upgrade from Eclipse HX v7.6 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is required 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 

3 E-FIB card No upgrade required.  
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Order System component 

 

Upgrade procedure(s) Notes 

4 V-

Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required  

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported  

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 

MK II (Blue) card only 
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Order System component 

 

Upgrade procedure(s) Notes 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required.  

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

Table 3-5: Procedures for upgrading from Eclipse HX v7.6 to Eclipse HX v14 

 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A  

Page 35 of 315 

 

 

 

 

3.6 Upgrading from 8.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.0 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is 

required. 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 

3 E-FIB card No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

4 V-

Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station Upgrade required. 

  

 

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported  

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

MK II (Blue) card only 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 
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Order System component 

 

Upgrade procedure(s) Notes 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

Table 3-6: Procedures for upgrading from Eclipse HX v8.0 to Eclipse HX v14 
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3.7 Upgrading from 8.5 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.5 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is 

required. 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

MADI FPGA upgrade only. 

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 
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Order System component 

 

Upgrade procedure(s) Notes 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported.  

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

MK II (Blue) card only 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

Table 3-7: Procedures for upgrading from Eclipse HX v8.5 to Eclipse HX v14 
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3.8 Upgrading from 8.5.1 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.5.1 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is 

required. 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

MADI FPGA upgrade only 

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A  

Page 42 of 315 

 

 

 

 

Order System component 

 

Upgrade procedure(s) Notes 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported.  

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

MK II (Blue) card only 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

Table 3-8: Procedures for upgrading from Eclipse HX v8.5.1 to Eclipse HX v14 
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3.9 Upgrading from 8.5.2 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.5.2 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is 

required. 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

MADI FPGA upgrade only 

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 
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Order System component 

 

Upgrade procedure(s) Notes 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

MK II (Blue) card only 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

Table 3-9: Procedures for upgrading from Eclipse HX v8.5.2 to Eclipse HX v14 
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3.10 Upgrading from 8.7 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.7 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

FPGA upgrade only. 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

MADI FPGA upgrade only 

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 
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Order System component 

 

Upgrade procedure(s) Notes 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX  

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

 

Application code only 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 
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Order System component 

 

Upgrade procedure(s) Notes 

4.4 Importing your configurations into EHX 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

Table 3-10: Procedures for upgrading from Eclipse HX v8.7 to Eclipse HX v14 
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3.11 Upgrading from 8.8 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.8 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

FPGA upgrade only. 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

MADI FPGA upgrade only 

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.4 Manually upgrading V-Series Panels  

Kernel 
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Order System component 

 

Upgrade procedure(s) Notes 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

 

Application code only. 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 
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Order System component 

 

Upgrade procedure(s) Notes 

4.4 Importing your configurations into EHX 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

13 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

14 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards FPGA and Module upgrade only. 

Table 3-11: Procedures for upgrading from Eclipse HX v8.8 to Eclipse HX v14 
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3.12 Upgrading from 9.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v9.0 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

FPGA upgrade only. 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

MADI FPGA upgrade only 

3 E-FIB card No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

4 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
No upgrade required. 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

 

Application code only. 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

14 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards FPGA and Module upgrade only. 

Table 3-11: Procedures for upgrading from Eclipse HX v8.8 to Eclipse HX v14 
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3.13 Upgrading from 9.1 

The following table lists the procedures that you will require to upgrade from Eclipse HX v9.1 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v14 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

MADI FPGA upgrade only 

3 E-FIB card No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

4 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
No upgrade required. 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

 

Application code only 

8 Eclipse HX-PiCo  6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

9 AES-6 No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

12 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

14 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards FPGA and Module upgrade only. 
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3.14 Upgrading from 10.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v10.0 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Additionally, it is important that the E-IPA card is upgraded before upgrading the CPU App card software. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

 

 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

 

E-MADI application only. 
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Order System component 

 

Upgrade procedure(s) Notes 

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
No upgrade required. 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

7 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

 

Application code only 

8 E-IPA card 13 Upgrading E-IPA-HX cards 
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Order System component 

 

Upgrade procedure(s) Notes 

9 Eclipse HX-PiCo  6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

10 AES-6 No upgrade required. 

 

 

11 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

12 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

Both secondary bootloader and 

application code. 

13 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

14 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

15 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards  
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Order System component 

 

Upgrade procedure(s) Notes 

 

 

3.15 Upgrading from 11.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v11.0 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Additionally, it is important that the E-IPA card is upgraded before upgrading the CPU App card software. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

E-MADI application only. 
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Order System component 

 

Upgrade procedure(s) Notes 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

3 E-FIB card No upgrade required. 

 

 

4 V-Series Iris/IrisX 

panels 

14.1 Upgrading panels using EHX 

14.2 Upgrading V-Series Iris/IrisX panels by USB  

 

 

5 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
No upgrade required. 

 

 

6 i-Station No upgrade required. 

 

 

7 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

8 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code Application code only 
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Order System component 

 

Upgrade procedure(s) Notes 

 

9 E-IPA card 13 Upgrading E-IPA-HX cards 

 

 

10 Eclipse HX-PiCo  6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

11 AES-6 No upgrade required. 

 

 

12 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

13 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

Both secondary bootloader and 

application code. 

13 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 
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Order System component 

 

Upgrade procedure(s) Notes 

14 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems FreeSpeak II IPT (IP transceiver) 

only 

15 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards 

 

 

 

 

3.16 Upgrading from 11.1 

The following table lists the procedures that you will require to upgrade from Eclipse HX v11.1 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Additionally, it is important that the E-IPA card is upgraded before upgrading the CPU App card software. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 
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Order System component 

 

Upgrade procedure(s) Notes 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

E-MADI application only. 

3 E-FIB card No upgrade required. 

 

 

4 V-Series Iris/IrisX 

panels 

14.1 Upgrading panels using EHX 

14.2 Upgrading V-Series Iris/IrisX panels by USB  

 

 

5 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
14.4 Manually upgrading V-Series Panels 

 

 

Display 

module  
No upgrade required. 

 

 

6 i-Station No upgrade required.  
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Order System component 

 

Upgrade procedure(s) Notes 

 

7 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

8 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

 

Application code only 

9 E-IPA card 13 Upgrading E-IPA-HX cards 

 

 

10 Eclipse HX-PiCo  6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

11 AES-6 No upgrade required. 

 

 

12 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

13 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

Both secondary bootloader and 

application code. 

13 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 
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Order System component 

 

Upgrade procedure(s) Notes 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

14 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems FreeSpeak II IPT (IP transceiver) 

only 

15 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards 
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3.17 Upgrading from 12.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v12.0 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Important note:  

If you are upgrading to Eclipse HX 14 and are using an E-IPA-HX card, see the FreeSpeak II IP Transceiver Quick Start Guide 

for information about IP setup and configuration. 

Additionally, it is important that the E-IPA card is upgraded before upgrading the CPU App card software. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

 

 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

 

E-MADI application only. 
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Order System component 

 

Upgrade procedure(s) Notes 

3 E-FIB card No upgrade required. 

 

 

4 V-Series Iris/IrisX 

panels 

14.1 Upgrading panels using EHX 

14.2 Upgrading V-Series Iris/IrisX panels by USB  

 

 

5 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
No upgrade required.  

Display 

module  
No upgrade required. 

 

 

6 i-Station No upgrade required. 

 

 

7 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

8 MVX-A16 card 7.2 Upgrading the MVX-A16 MK I or MK II boot and/or app code 

 

Application code only. 

9 E-IPA card 13 Upgrading E-IPA-HX cards 
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Order System component 

 

Upgrade procedure(s) Notes 

10 Eclipse HX-PiCo  6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

11 AES-6 No upgrade required. 

 

 

12 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

13 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

Both secondary bootloader and 

application code. 

13 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 
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Order System component 

 

Upgrade procedure(s) Notes 

14 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

15 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards 

 

 

16 FreeSpeak Edge 

Beltpack, Transceiver 

18.1 Upgrading FreeSpeak Edge transceivers 

18.2 Upgrading FreeSpeak Edge beltpacks 
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3.18 Upgrading from 12.1 

The following table lists the procedures that you will require to upgrade from Eclipse HX v12.1 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

 

 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

E-MADI application only. 

3 E-FIB card No upgrade required. 

 

 

4 V-Series Iris/IrisX 

panels 

14.1 Upgrading panels using EHX 

14.2 Upgrading V-Series Iris/IrisX panels by USB  
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Order System component 

 

Upgrade procedure(s) Notes 

5 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
No upgrade required.  

Display 

module  
No upgrade required. 

 

 

6 i-Station No upgrade required. 

 

 

7 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

8 MVX-A16 card No upgrade required. 

 

 

9 E-IPA card 13 Upgrading E-IPA-HX cards 

 

 

10 Eclipse HX-PiCo  6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

11 AES-6 No upgrade required.  
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Order System component 

 

Upgrade procedure(s) Notes 

 

12 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

13 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

Both secondary bootloader and 

application code. 

13 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

14 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

15 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards 

 

Brooklyn module only 

16 FreeSpeak Edge 

Beltpack, Transceiver 

18.1 Upgrading FreeSpeak Edge transceivers  
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Order System component 

 

Upgrade procedure(s) Notes 

18.2 Upgrading FreeSpeak Edge beltpacks 

 

 

3.19 Upgrading from 12.2 

The following table lists the procedures that you will require to upgrade from Eclipse HX v12.2 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

 

 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

E-MADI application only 
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Order System component 

 

Upgrade procedure(s) Notes 

3 E-FIB card No upgrade required. 

 

 

4 V-Series Iris/IrisX 

panels 

14.1 Upgrading panels using EHX 

14.2 Upgrading V-Series Iris/IrisX panels by USB  

 

 

5 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
No upgrade required.  

Display 

module  
No upgrade required. 

 

 

6 i-Station No upgrade required. 

 

 

7 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

8 MVX-A16 card No upgrade required. 

 

 

9 E-IPA card 13 Upgrading E-IPA-HX cards 
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Order System component 

 

Upgrade procedure(s) Notes 

10 Eclipse HX-PiCo  6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

 

11 AES-6 No upgrade required. 

 

 

12 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

13 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

Both secondary bootloader and 

application code. 

13 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 
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Order System component 

 

Upgrade procedure(s) Notes 

14 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

15 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards 

 

Brooklyn module only 

16 FreeSpeak Edge 

Beltpack, Transceiver 

18.1 Upgrading FreeSpeak Edge transceivers 

18.2 Upgrading FreeSpeak Edge beltpacks 
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3.20 Upgrading from 13.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v13.0 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

 

 

2 E-MADI64 card No upgrade required. 

 

 

3 E-FIB card No upgrade required. 

 

 

4 V-Series Iris/IrisX 

panels 

14.1 Upgrading panels using EHX 

14.2 Upgrading V-Series Iris/IrisX panels by USB  

 

 

5 
Uboot 

No upgrade required.  
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Order System component 

 

Upgrade procedure(s) Notes 

V-Series 

panels 

Kernel 

Root file 

system 

App code 
No upgrade required.  

Display 

module  
No upgrade required. 

 

 

6 i-Station No upgrade required. 

 

 

7 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

8 MVX-A16 card No upgrade required. 

 

 

9 E-IPA card 13 Upgrading E-IPA-HX cards 

 

 

10 Eclipse HX-PiCo  6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

11 AES-6 No upgrade required. 

 

 

12 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 
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Order System component 

 

Upgrade procedure(s) Notes 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

13 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

Both secondary bootloader and 

application code. 

13 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

14 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

15 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards 

 

Brooklyn module only. 

16 FreeSpeak Edge 

Beltpack, Transceiver 

18.1 Upgrading FreeSpeak Edge transceivers 

18.2 Upgrading FreeSpeak Edge beltpacks 
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3.21 Upgrading from 13.1 

The following table lists the procedures that you will require to upgrade from Eclipse HX v13.1 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

9.3 Upgrading the E-QUE card (MK1) via serial cable and third-

party TFTP tools 

9.4 Upgrading the E-QUE card (MK2)9.4 Upgrading the E-QUE card 

(MK2) 

 

Application upgrade only.  

2 E-MADI64 card No upgrade required. 

 

 

3 E-FIB card No upgrade required. 

 

 

4 V-Series Iris/IrisX 

panels 

14.1 Upgrading panels using EHX 

14.2 Upgrading V-Series Iris/IrisX panels by USB  
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Order System component 

 

Upgrade procedure(s) Notes 

5 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
No upgrade required.  

Display 

module  
No upgrade required. 

 

 

6 i-Station No upgrade required. 

 

 

7 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

 

8 MVX-A16 card No upgrade required. 

 

 

9 E-IPA card 13 Upgrading E-IPA-HX cards 

 

 

10 Eclipse HX-PiCo  6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

11 AES-6 No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

12 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

13 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

Both secondary bootloader and 

application code. 

13 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

14 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems FS II 1.9 Beltpack Application, FS 

II 2.4 Beltpack Application and 

FS II 1.9 Transceiver Application. 

15 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards 

 

Application only. 

16 FreeSpeak Edge 

Beltpack, Transceiver 

No upgrade required. 

 

 

17 2X10 Panel 19 Upgrading 2X10 Touch 20-Key Panel  
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3.22 Upgrading from 13.2 

The following table lists the procedures that you will require to upgrade from Eclipse HX v13.2 to Eclipse HX v14. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / 

link. 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

No upgrade required. 

 

 

2 E-MADI64 card No upgrade required. 

 

 

3 E-FIB card No upgrade required. 

 

 

4 V-Series Iris/IrisX 

panels 

14.1 Upgrading panels using EHX 

14.2 Upgrading V-Series Iris/IrisX panels by USB  

 

 

5 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
No upgrade required.  
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Order System component 

 

Upgrade procedure(s) Notes 

Display 

module  
No upgrade required. 

 

 

6 i-Station No upgrade required. 

 

 

7 CellCom / FreeSpeak 

Beltpack / Transceiver 

/ Splitter 

No longer supported. 

 

FS II 2.4 Beltpack Application 

and FS II 1.9 Transceiver 

Application. 

8 MVX-A16 card No upgrade required. 

 

 

9 E-IPA card 13 Upgrading E-IPA-HX cards 

 

 

10 Eclipse HX-PiCo  6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

 

11 AES-6 No upgrade required. 

 

 

12 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x 

configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 
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Order System component 

 

Upgrade procedure(s) Notes 

13 CPU card 5.4 Upgrading the CPU card secondary bootloader and application 

code 

 

Both secondary bootloader and 

application code. 

13 Dynam-EC 4.5 Updating Dynam-EC Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

14 FreeSpeak II Beltpack, 

Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

15 E-DANTE64-HX Card 12 Upgrading E-DANTE64-HX cards 

 

Application only. 

16 FreeSpeak Edge 

Beltpack, Transceiver 

No upgrade required. 

 

 

17 2X10 Panel 19 Upgrading 2X10 Touch 20-Key Panel  
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4 Upgrading to Eclipse HX v14 

This chapter describes the files you require to install Eclipse HX v14. It also describes how 

to back up your ECS 5.2.5 configurations and import them into Eclipse HX v14.  

Important notes: 

This guide is laid out in the order in which you must upgrade your Eclipse software and 

hardware devices to Eclipse 11.x. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

4.1 Backing up your ECS v5.2.5 configurations 

Back up your ECS v5.2.5 configurations by exporting them from ECS v5.2.5 to a hard disk 

location. In ECS: 

1) Open the configuration you wish to save. 

2) Select File > Export Project. 

3) Save the configuration to a location on your hard drive. The configuration will be 

saved as a *.ccn file, which you can import later into EHX (the configuration 

software for Eclipse HX v14). 

Note: EHX can open *.ccn format files as well as its own *.hxn format configuration files. 

Repeat the above procedure for all the configurations you want to save. 

4.2 Backing up your EHX 

7.x/8.x/9.x/10.x/11.x/12.x/13.x configurations 

Back up your EHX 7.x/8.x/9.x/10.x/11.x/12.x/13.x configurations by saving them to a 

secure location on your hard drive. 

1) Open the configuration you wish to save. 

2) Select File > Save Project. 

4.3 Installing EHX and Dynam-EC Clients  

EHX is the configuration software for Eclipse HX v14. Dynam-EC is the application used for 

online monitoring and dynamic audio routing. 

The Eclipse HX v14 software USB contains a number of executable (*.exe) files for 

installing EHX and Dynam-EC: 
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Installation (*.exe) file Description and comments 

EHXDynam-ECSetup.exe The installer for the client version of EHX (both 32 and 

64 bit machines) and Dynam-EC (both 32 and 64 bit 

machines).  

You can use the EHX Client version to connect: 

• Directly to a matrix in Client-only mode. 
 

• To an EHX Server in Client-Server mode. 
 

Note: you may need to take steps to allow the App through 

the local PC firewall.  

EHXServerSetup.exe The installer for the server version of EHX (both 32 and 

64 bit machines). 

 

The EHX Server enables multiple EHX clients to work 

together when configuring an Eclipse HX system. 

Table 4-1: Installing EHX 

Note: If you are required to uninstall and re-install EHX for any reason, ensure to save your 

configurations for re-importing into EHX (see section below). You can uninstall EHX from 

your Windows All Programs menu. 

EHX uninstall will stop and restart IIS during the uninstall process to remove any files that 

are currently in use. 

Additionally, if a PC only requires the installation of Dynam-EC then the standalone installer 

for Dynam-EC should be used. See the section below.  

4.4 Importing your configurations into EHX 

The procedure below is only applicable if you are running EHX in Client-Server mode. 

Tip: Remember to import any control macros which may be associated with a configuration. 

Note: v14 of EHX only supports the import of project files from versions v11.0 onwards. If the 

original project file was exported from an EHX version earlier than this, then the steps below 

will need to be carried out on the project file after it has been imported into and exported 

from an EHX version between v11.0 and v13.x (inclusive).   

To import a saved configuration into EHX: 

1) Open EHX. From the top menu bar, select File > Import Project. 
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2) Navigate to the EHX configuration file (.ccn or .hxn) saved to your hard drive. To 

import the file, click Open. 

Note: EHX can open *.ccn format files as well as its own *.hxn format configuration files. 

Note: v14 of EHX only supports the import of project files from versions v11.0 onwards. If the 

original project file was exported from an EHX version earlier than this, then the steps below 

will need to be carried out on the project file after it has been imported into and exported 

from an EHX version between v11.0 and v13.x (inclusive).   

To import a saved project from an earlier version of EHX or ECS into EHX in Client-only 

mode: 

3) Open EHX. Select File > Open Project. 

4) Navigate to the project file (*.hxn or *.ccn format) saved to your hard drive. Click 

Open. 

Note: If you import a .ccn file, remember to save your imported project as an *.hxn format file. 

Repeat the above procedure for all the configurations you want to import. 

4.5 Updating Dynam-EC 

If you are installing Dynam-EC as an update to an existing Dynam-EC installation, you must 

first uninstall your existing version of Dynam-EC. Ensure that you save your Dynam-EC 

layouts project files (*.ccr files) and all relevant EHX system configurations (*.hxn files) 

To update Dynam-EC to your PC: 

1) Insert the USB into the PC. Navigate to the USB and click the relevant *.exe file for 

your machine. 

2) When the Setup wizard has loaded, the License Agreement dialog is displayed. 

Use the internal scroll bar to review the agreement. To continue with the 

installation, click I Agree. 

3) The Choose Install Location dialog is displayed. The default location is Program 

Files > ClearCom on the C Drive. To select a different location, click Browse. To 

continue, click Next. 

4) The Choose Start Menu Folder dialog is displayed. The default Start Menu folder 

is Clear-Com\Dynam-EC. To select an alternative folder either: 

• Select from the list of existing Start Menu folders. Use the dialog scroll bar to 

navigate the list. 

• Enter a name into the selection field to create a new folder. 

To prevent the creation of shortcuts, select Do not create shortcuts. Click Install. 
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5) Dynam-EC starts to install. During installation, an installation progress bar is 

displayed. For more detailed information about the progress of the installation, click 

Show Details.  

When the installation is complete, click Close. 

Note: On installing Dynam-EC, a firewall dialog may be displayed asking if Windows should Block 

or Unblock Dynam-EC. Select Unblock Dynam-EC.
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5 Upgrading the CPU cards 

This chapter describes how to upgrade the Boot PROM, CPLD, secondary bootloader and 

application code for the CPU cards, two of which are fitted to the Eclipse HX-Median, Eclipse 

HX-Omega and Eclipse HX-Delta matrices.  

Note: This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 

 3Quick reference: Upgrading to Eclipse HX. 

Note: At v10 the CPU card has changed to use a new firmware scheme.  

@ v9.1 there was a Boot PROM and main application firmware 

@ v10 we now have Boot PROM, secondary bootloader firmware and main application 

firmware 

 

 

Eclipse HX devices are powered by mains voltage. Unless 

specifically advised to the contrary, disconnect mains supply before 

carrying out any maintenance or repair tasks. Observe precautions 

for handling electrostatic sensitive devices. 

 

Changing the CPU card PROM, RAM and DIP switch settings 

The CPU card PROM and RAM should be changed at the same time. The CPU card DIP switch 

settings must also be upgraded. 

5.1 Changing the CPU card PROM (only applicable if 

upgrading from v5) 

Note: When you change the CPU card PROM, you must also change the CPU card RAM (from 

128Mb RAM to 256Mb RAM). See 5.2 Changing the CPU card RAM below. 

To change the CPU card PROM: 

1) Ensure that you have the following equipment: 

 

• 2MBit PROM device (ST M27W201 or equivalent). 

• PROM Programming Unit (with the appropriate programming software for that unit). 

• The *.s record file for the CPU card boot PROM. To find the file, go to: 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx – Config Boot 
PROM  
 
Where xxxxxx represents the product number. 
. 
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The folder contains the *.s record file and a Read Me file (*.txt), with version information. 

2) Program the PROM device with the *.s record file. Follow the instructions for the 

PROM Programming Unit you are using. 

Note: Ensure that the PROM device is empty before you begin programming. 

3) Ensure that the checksum of the programmed device matches the checksum in the 

Eclipse HX Release Notes. 

4) Remove the existing PROM device from the CPU card. 

5) Insert the newly programmed PROM device, taking care to ensure the correct 

polarity of the device. 

5.2 Changing the CPU card RAM (only applicable if 

upgrading from v5) 

Note: When you change the CPU card RAM (from 128Mb RAM to 256Mb RAM), you must also 

change the CPU card PROM. See 5.1 Changing the CPU card PROM above. 

To change the CPU card RAM (from 128Mb to 256Mb): 

1) Ensure that you have the replacement 256Mb CPU card RAM to hand. 

 

2) Remove the CPU card from the Eclipse HX-Median, Eclipse HX-Omega or Eclipse 

HX-Delta matrix. 

 

3) The cassette that holds the CPU card RAM daughter board is located towards the 

center of the main board:  
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Figure 5-1: CPU card 128Mb RAM daughter board 

To release the 128Mb RAM daughter board, push back the levers to either side of the 

cassette. Remove the board. 

4) Fit the replacement 256Mb CPU card RAM daughter board to the cassette. The 

daughter board is fitted chip-side up. Ensure that the daughter board is securely 

fitted (only the top edge of the connectors along the lower edge of the board should 

be visible). 

 

 

Figure 5-2: CPU card 256Mb RAM daughter board 

5) Secure the RAM daughter board by closing the levers to either side of the cassette. 
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6) Return the CPU card to the Eclipse HX-Median, Eclipse HX-Omega or Eclipse HX-

Delta matrix. 

5.3 Changing the CPU card DIP switches 

To change the CPU card DIP switches to the appropriate Eclipse HX v14 settings, see: 

• Appendix A: CPU card layout 

• Appendix B: CPU card DIP switches 

• 5.4.3 Upgrading the CPU Card secondary bootloader code using Tera Term 

5.4 Upgrading the CPU card secondary bootloader and 

application code 

Note: A MK II CPU card was released in 2024. This is functionally the same the MK I CPU card, 

however the MK II card is only supported from v14 onwards. The firmware running on the 

MK II CPU Card will not accept a firmware file from a system release that does not support 

the MK II hardware. If this occurs, then the firmware incompatibility will be stated in the 

EHX event log. 

The CPU card hardware version can be identified by examining the information on the 

microprocessor: 

8260 signifies a MK I processor 

8280 signifies a MK II processor 
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In the EHX matrix overview the CPU card hardware revision is also reported. Below, a MK I 

card is being reported. The card will be classed as Processor MK 2 when it is MK II CPU 

Card. 

 

5.4.1 Upgrading the CPU card secondary bootloader code 

Upgrading the CPU card secondary bootloader code using EHX with 

Ethernet connection 

Before you upgrade the CPU card secondary bootloader code, check that: 

• The PC can successfully connect to the matrix with an Ethernet connection by 

viewing the Event Log (Diagnostics > Event Log) in EHX. 

• There is a valid configuration in the matrix. A valid configuration enables the matrix 

to identify its IP address and run its TCP / IP stack. 

Note: Both CPU cards may remain in place (inserted) for this procedure. 

To upgrade the CPU card secondary bootloader code, using EHX with an Ethernet 

connection: 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

PC with an Ethernet 

connector 

- 

LAN cable for the PC-to-

matrix connection 

For direct connections you may need to use an 

Ethernet crossover cable (modern PCs will 

switch pinouts as required automatically). If the 

connection passes through an Ethernet switch 

on its way to the PC / matrix, use straight CAT5 

cable. 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn format) 

The configuration file must have an appropriate 

IP address set. 

The appropriate *.fwr data 

file for the CPU card 

application 

You can find the *.fwr data file on the software 

USB: 
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Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-

Omega-Median-Delta > xxxxxx – Config 

Card Secondary Bootloader (where xxxxxx 

represents the product number). 

Example secondary bootloader version number 

- x.y.71.z 
Table 5-1: Required equipment 

2) Start EHX. Select Tools > Matrix connection. 

3) In the Matrix connection dialog, select the Ethernet communications option. 

4) Connect the PC to the Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta 

matrix, using the LAN#1 port on the rear of the matrix. 

5) In EHX, select File > Import project. Navigate to the configuration file (*.ccn or 

*.hxn format) and click Open to import the file. 

6) Select System > Layout. In the work area, right click the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix. 

7) From the menu, select Firmware > Update Firmware. 

 

 
Figure 5-3: Upgrading app code: Matrix firmware update 

8) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again.  
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9) In the next dialog, click Browse and navigate to the required *.fwr file for the 

Eclipse HX-Omega / Eclipse HX-Median / Eclipse HX-Delta CPU card application: 

a. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - EHX.xxx > 

Eclipse HX-Omega-Median-Delta > xxxxxx – Config Card Secondary 

Bootloader (where xxxxxx represents the product number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information. (Example secondary bootloader version number - x.y.71.z) 

b. Select the*.fwr file and click Open. Ensure that the correct file name is 

displayed in the dialog. 

10) Click Next. Confirm that the correct file has been selected, and click Next again to 

start the firmware update. The update will take approximately 2 minutes. 

Tip: While the update is in progress, check that the S1 LED on the front of the CPU 

card(s) is flashing rapidly. Rapid flashes indicate communication with the PC.  

The Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix reboots. The 

CPU card(s) is reset.  

11) When the update is complete the matrix will be reachable via ethernet, however the 

matrix may remain grey in the layout screen and the apply firmware dialog may 

remain at the verifying stage. If this happens, check that the matrix can be 

contacted by closing the apply firmware verifying dialog box and opening the 

Diagnostics >> Event Log window. Check that the event log is connected to the 

matrix. See section  5.6 

If so, it simply means that this is the first time that this CPU card is running the 

new secondary bootloader and main application image scheme and that the 

application has not yet been loaded or that the application is of an older major 

version than the secondary bootloader.  In either case Download the CPU card main 

application using EHX. See 5.4.4 

5.4.2 Upgrading the CPU card secondary bootloader code with 

EHX using a serial link 

You can upgrade the CPU card secondary bootloader with EHX using a serial link, whether or 

not there is a valid configuration (map) on the Eclipse HX-Median / Eclipse HX-Omega 

matrix / Eclipse HX-Delta. Both CPU cards may remain inserted during the upgrade. You 

may choose to perform the initial upgrade with EHX using a serial connection, then move to 

an Ethernet connection for future configuration downloads and upgrades, once an IP 

address has been configured. 

Note: Before you use this procedure, check that the matrix event log can connect serially to a CPU 

card with a configuration. Both CPU cards may remain inserted during the upgrade. 

To upgrade the application code with EHX, using a serial link: 
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1) Ensure that you have the following: 

 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, 

you must connect the cable before starting 

EHX to enable EHX to detect the USB port as 

a COM port. 

Standard RS232 serial cable  

(9-pin D-Type to 9-pin D-

Type) 

- 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn format) 

The configuration file must have the 

appropriate IP addresses set (not required 

when upgrading via serial). 

The appropriate *.fwr data 

file for the CPU card 

application 

You can find the *.fwr data file on the 

software USB: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-

Omega-Median-Delta > xxxxxx – Config 

Card Secondary Bootloader  

Example secondary bootloader version 

number - x.y.71.z 
Table 5-2: Required equipment 

2) Start EHX. Select Tools > Matrix connection. 

3) In the Matrix connection dialog, select the serial communications option. 

4) Select the correct COM port then click OK. 

5) Use the RS232 cable to connect the PC with the serial port on the rear of the 

Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix. 

6) Do one of the following: 

• If you are running EHX in Client-Server mode, select File > Import 

project. Navigate to the configuration (*.ccn) file and click Open to import 

the file. 

• If you are running EHX in Client-Only mode, select File > Open. Navigate 

to the configuration (*.ccn) and open the file. 

Note: EHX can open *.ccn format files as well as its own *.hxn format configuration files. 
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7) Select System > Layout. In the work area, right click the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix. 

8) From the menu, select Firmware > Update Firmware. 

 

 
Figure 5-4: Upgrading app code: Matrix firmware update 

9) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again.  

10) In the next dialog, click Browse and navigate to the required *.fwr file for the  

Eclipse HX-Omega / Eclipse HX-Median / Eclipse HX-Delta CPU card application:  

a. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - EHX.xxx > 

Eclipse HX-Omega-Median-Delta > xxxxxx – Config Card Secondary 

Bootloader (where xxxxxx represents the product number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information.( Example secondary bootloader version number - x.y.71.z) 

b. Select the*.fwr file and click Open. Ensure that the correct file name is 

displayed in the dialog. 

11) Click Next. Confirm that the correct file has been selected and then click Next 

again to start the firmware update. The update will take approximately 2 minutes. 

Tip: While the update is in progress, check that the S1 LED on the front of the CPU 

card(s) is flashing rapidly. Rapid flashes indicate communication with the PC.  

The Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix reboots. The 

CPU card(s) is reset.  

12) When the update is completed the matrix will be reachable via the serial 

connection, however the matrix may remain grey in the layout screen and the apply 
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firmware dialog may remain at the verifying. If this happens, check that the matrix 

can be contacted by closing the apply firmware verifying dialog box and opening 

the Diagnostics > Event Log window. Check that the event log is connected to the 

matrix.  If so it simply means that this is the first time that this CPU card is running 

new secondary bootloader and application image scheme and that the application 

has not yet been loaded. See section 5.6 Checking the CPU card application 

code version. 

Download a configuration file (apply changes), using EHX. 

 

If the upgrade fails 

If the upgrade of both CPU cards fails, repeat the procedure (with only one CPU card in the 

matrix) for each card. When the procedure is complete, insert both the CPU cards into the 

Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix. 

If there was no previous configuration loaded in the matrix, download a basic configuration 

file (apply changes) to the CPU cards using EHX. Make any further configuration changes 

over the Ethernet LAN. 

Tip: For more information about setting up a configuration, see the EHX User Guide.  
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5.4.3 Upgrading the CPU Card secondary bootloader code using 

Tera Term 

To upgrade the CPU card application code using Tera Term: 

1) Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, you 

must connect the cable before starting Tera 

Term to detect the USB port as a COM port.   

 

Standard RS232 serial cable 

(9-pin D-Type to 9-pin D-

Type) 

- 

Tera Term installation Tera Term must be configured and operational. 

You can find the Tera Term application on both 

of the Eclipse HX upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 

An EHX configuration file 

(*.hxn or *.ccn format) 

- 

The appropriate *.fwr data 

file for the CPU card 

application 

You can find the *.fwr data file on the software 

USB: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-

Omega-Median-Delta > xxxxxx – Config 

Card Secondary Bootloader  

(where xxxxxx represents the part number). 
Table 5-3: Required equipment 

2) Install the Tera Term application. Accept all default settings. 

Tip:  To find out how to install Tera Term, see Appendix G:Tera Term. 

3) Start Tera Term. In the New Connection dialog, select Serial (connection) and 

the COM port to use. Click OK. 
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Figure 5-5: Tera Term: selecting serial connection 

 

 
Figure 5-6: Tera Term: selecting Serial port 

4) From the Setup menu, select the Serial port… entry.  

5) The Serial port configuration dialog is displayed. Configure the serial port as 

follows: 

Field Data (to enter / select) 

Port Com1 

Note: 

Change as required to match a COM port on the PC. 

Baud Rate 115200 

Parity Even 
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Stop One (bits) 

Data 8 (bits) 

Table 5-4: Tera Term: Serial port configuration 

Tip:  You can use the Tera Term application for many of the Eclipse HX system 

upgrade processes. To save and recall the relevant com port settings in Tera Term, 

select the Setup / Save or Restore settings options. 

6) Connect the PC serial port to the RS232 port on the rear of the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix, using the RS232 cable. 

7) Remove both CPU cards from the matrix. Power on the Eclipse HX-Median / Eclipse 

HX-Omega / Eclipse HX-Delta matrix. 

8) Erase the old application code from the CPU cards. 

a. Place the CPU card in Test mode. 

 

b. Set the DIP switches on the CPU card as follows: 

 
Figure 5-7: DIP switch settings, Test mode 

c. Insert the CPU card into the Eclipse HX-Median / Eclipse HX-Omega / Eclipse 

HX-Delta matrix. You can place the card in either the P1 or P2 slot. 

 

d. Confirm that the CPU card has entered test mode. If the card is in test mode, 

data similar to the following is displayed on the PC: 

 

 

 

Figure 5-8: Tera Term: CPU card test mode. 
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Note: If you do not see the data above, press Enter on the PC. 

 

Tip: To see all the available options in test mode, press ? on your keyboard. 

To see all the current applications loaded onto the CPU, press i. 

 

e. On your PC keyboard, press number 1. To start the erasure of Flash 

memory, press Enter (or Return). Select y and Enter to confirm. 

Note:  

It takes approximately 1 minute to erase Flash. 

f. When the Flash has been erased, press number 2 on your keyboard. To start 

the erasure of NVRAM, press Enter (or Return). When the NVRAM erase is 

complete, remove the CPU card. 

9) Download the new secondary bootloader code (firmware) to the CPU card(s), using 

Tera Term.  

a. Place the erased CPU card in serial download mode. Set the DIP switches on 

the CPU card as follows: 

 

 
Figure 5-9: Tera Term: DIP switches, serial download mode 

b. Insert the CPU card into the Eclipse HX-Median / Eclipse HX-Omega / Eclipse 

HX-Delta matrix. The LED on the front of the matrix should flash LD AP. 

c. In Tera Term, open File and select Send file…  Ensure that the BINARY 

option box is selected. 

 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 107 of 315   

 

 

 

 

 
Figure 5-10: Tera Term: Send file… 

d. In the Send file dialog > Select the file to download, navigate to the CPU 

card application code (firmware) *.fwr file: 

i. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - 

EHX.xxx > Eclipse HX-Omega-Median-Delta > xxxxxx – Config 

Card Secondary Bootloader (where xxxxxx represents the product 

number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with 

version information. 

ii.Select the*.fwr file and click OK / Open. Ensure that the correct file 

name is displayed in the dialog. 

e. The file starts to download. Confirm that the CPU card LED matrix display 

shows numbers counting up. 

 

Important note: 

The count-up display indicates that packets are being received by the CPU 

card. The numbers do not represent a percentage complete figure. 

 

If the download fails, the CPU card display shows LD Err. This type of failure 

is usually caused by the user continuing to use the PC for other tasks while 

the download is occurring. The Tera Term screen will not indicate a failure 

and will continue to show a download. If this occurs: 

i. Abort the Tera Term download (press Cancel in the Tera Term 

screen). 

ii. Reset the CPU card (by removing the card from the matrix and 

reinserting it again). 

iii. Check the cable connections, then restart the Send file download 

process again. 
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f. When the download is complete, the CPU card reboots. The CPU card(s) is 

reset and the OK LED produces a 1Hz narrow flash.  

Note:  

The zero ( 0 ) displayed indicates that although valid application code is 

present, the CPU cards do not contain a configuration. 
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g. Remove the upgraded CPU card and set the DIP switches to normal running 

(watchdog) mode: 

 

 

 

 

 

 

 

 

 
Figure 5-11: Tera Term: DIP switches in normal running 

(watchdog) mode 

h. Repeat the above procedure for the second CPU card, if present. Reinsert 

both of the upgraded CPU cards into the matrix. 

i. The OK LED shows a 1Hz narrow flash, which indicates that the secondary 

bootloader is present, and that it is waiting to receive the CPU card 

application image from EHX via either ethernet (recommended) or serial 

connection. 

j. Download the CPU card application. 

k. Download a configuration file (apply changes), using EHX. 

 

Additional setups need to add the CPU application image upgrading via the EHX : 

Open EHX > New Project > Right click in the working area > Manually add Matrices by right 

click > Select the matrix type and add the IP address for the frame > Apply the CPU 

application firmware to matrix 

5.4.4 Upgrading the CPU card main application code 

Upgrading the CPU card main application code using EHX with 

Ethernet connection 

Before you upgrade the CPU card main application code, check that: 

• The PC can successfully connect to the matrix with an Ethernet connection by 

viewing the Event Log (Diagnostics > Event Log) in EHX. 

Note: Both CPU cards may remain in place (inserted) for this procedure. 
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To upgrade the CPU card main application code, using EHX with an Ethernet connection: 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

PC with an Ethernet 

connector 

- 

LAN cable for the PC-to-

matrix connection 

For direct connections, you may need to use an 

Ethernet crossover cable (modern PC switch 

pinout as required automatically). If the 

connection passes through an Ethernet switch 

on its way to the PC / matrix, use straight CAT5 

cable. 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn format) 

The configuration file must have an appropriate 

IP address set. 

The appropriate *.fwr data 

file for the CPU card main 

application 

You can find the *.fwr data file on the software 

USB: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-

Omega-Median-Delta > xxxxxx – Config 

Card Application (where xxxxxx represents 

the product number). 

Example version number – x.y.2.0 
Table 5-5: Required equipment 

2) Start EHX. Select Tools > Matrix connection. 

3) In the Matrix connection dialog, select the Ethernet communications option. 

4) Connect the PC to the Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta 

matrix, using the LAN#1 port on the rear of the matrix. 

5) In EHX, select File > Import project. Navigate to the configuration file (*.ccn or 

*.hxn format) and click Open to import the file. 

6) Select System > Layout. In the work area, right click the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix. 

7) From the menu, select Firmware > Update Firmware. 
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Figure 5-12: Upgrading app code: Matrix firmware update 

8) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again.  

9) In the next dialog, click Browse and navigate to the required *.fwr file for the 

Eclipse HX-Omega / Eclipse HX-Median / Eclipse HX-Delta CPU card application: 

a. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - EHX.xxx > 

Eclipse HX-Omega-Median-Delta > xxxxxx – Config Card Application 

(where xxxxxx represents the product number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information.( Example version number – x.y.2.0). 

b. Select the*.fwr file and click Open. Ensure that the correct file name is 

displayed in the dialog. 

10) Click Next. Confirm that the correct file has been selected, and click Next again to 

start the firmware update. The update will take approximately 2 minutes. 

Tip: While the update is in progress, check that the S1 LED on the front of the CPU 

card(s) is flashing rapidly. Rapid flashes indicate communication with the PC.  

11) When the update is completed, click Finish in the Firmware Update wizard. 

The Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix reboots. The CPU 

card(s) is reset.  

Download a configuration file (apply changes), using EHX. 

Note: The CPU card uses a default configuration that is embedded in the download application 

(even though the CPU DOT matrix display shows zero (0)). The default configuration helps 

with the initial hardware configuration and testing of the Eclipse HX-Median / Eclipse HX-
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Omega / Eclipse HX-Delta matrix by providing usable functionality to each of the MVX-A16 

cards fitted to the matrix. 

5.4.5 Upgrading the CPU card application code with EHX using a 

serial link 

You can upgrade the CPU card with EHX using a serial link, whether or not there is a valid 

configuration (map) on the Eclipse HX-Median / Eclipse HX-Omega matrix / Eclipse HX-

Delta. Both CPU cards may remain inserted during the upgrade. You may choose to 

perform the initial upgrade with EHX using a serial connection, then move to an Ethernet 

connection for future configuration downloads and upgrades, once an IP address has been 

configured. 

Note: Before you use this procedure, check that the matrix event log can connect serially to a CPU 

card with a configuration. Both CPU cards may remain inserted during the upgrade. 

To upgrade the application code with EHX, using a serial link: 

1) Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, 

you must connect the cable before starting 

EHX to enable EHX to detect the USB port as 

a COM port. 

Standard RS232 serial cable  

(9-pin D-Type to 9-pin D-

Type) 

- 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn format) 

The configuration file must have the 

appropriate IP addresses set (not required 

when upgrading using serial). 

The appropriate *.fwr data 

file for the CPU card 

application 

You can find the *.fwr data file on the 

software USB: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-

Omega-Median-Delta > xxxxxx – Config 

Card Application  

(where xxxxxx represents the product 

number). Example version number – x.y.2.0 
Table 5-6: Required equipment 
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2) Start EHX. Select Tools > Matrix connection. 

3) In the Matrix connection dialog, select the serial communications option. 

4) Select the correct COM port then click OK. 

5) Use the RS232 cable to connect the PC with the serial port on the rear of the 

Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix. 

6) Do one of the following: 

• If you are running EHX in Client-Server mode, select File > Import 

project. Navigate to the configuration (*.ccn) file and click Open to import 

the file. 

• If you are running EHX in Client-Only mode, select File > Open. Navigate 

to the configuration (*.ccn) and open the file. 

Note: EHX can open *.ccn format files as well as its own *.hxn format configuration files. 

7) Select System > Layout. In the work area, right click the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix. 

8) From the menu, select Firmware > Update Firmware. 

 

 
Figure 5-13: Upgrading app code: Matrix firmware update 

9) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again.  

10) In the next dialog, click Browse and navigate to the required *.fwr file for the  

Eclipse HX-Omega / Eclipse HX-Median / Eclipse HX-Delta CPU card application:  
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a. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - EHX.xxx > 

Eclipse HX-Omega-Median-Delta > xxxxxx – Config Card Application 

(where xxxxxx represents the product number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information.( Example version number – x.y.2.0) 

b. Select the*.fwr file and click Open. Ensure that the correct file name is 

displayed in the dialog. 

 

11) Click Next. Confirm that the correct file has been selected and then click Next 

again to start the firmware update. The update will take approximately 2 minutes. 

Tip: While the update is in progress, check that the S1 LED on the front of the CPU 

card(s) is flashing rapidly. Rapid flashes indicate communication with the PC.  

Note: If you are upgrading from v5.2.5 to Eclipse HX v14, the download dialog does not 

automatically finish. This is due to a messaging change between the two system 

architectures. Instead, close the dialog (which will continue to indicate Verifying) when the 

matrix reboots (see Step 11). 

12) When the update is completed, click Finish in the Firmware Update wizard. 

The Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta (matrix) matrix 

reboots. The CPU card(s) is reset.  

Download a configuration file (apply changes), using EHX. 

 

Note: The CPU card uses a default configuration that is embedded in the download application 

(even though the CPU DOT matrix display shows zero (0)). The default configuration helps 

with the initial hardware configuration and testing of the Eclipse HX-Median / Eclipse HX-

Omega / Eclipse HX-Delta matrix by providing usable functionality to each of the MVX-A16 

cards fitted to the matrix. 

If the upgrade fails 

If the upgrade of both CPU cards fails, repeat the procedure (with only one CPU card in the 

matrix) for each card. When the procedure is complete, insert both the CPU cards into the 

Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix. 

If there was no previous configuration loaded in the matrix, download a basic configuration 

file (apply changes) to the CPU cards using EHX. Make any further configuration changes 

over the Ethernet LAN. 

Tip: For more information about setting up a configuration, see the EHX User Guide.  
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5.5 Setting the matrix type 

The Eclipse HX-Median, Eclipse HX-Omega and Eclipse HX-Delta matrices run common 

software, which means that when you upgrade the application code for the CPU card, the 

CPU card cannot automatically distinguish between the two matrix types. You must 

therefore set the matrix type in EHX. 

Note: The Eclipse HX-PiCo runs its own matrix-specific software, and will always identify itself as 

an Eclipse HX-PiCo on hardware discovery. There is therefore no requirement to set the 

matrix type for the Eclipse HX-PiCo. 

To set the matrix type: 

1) In EHX, select Diagnostics > Event Log. 

2) In the Matrix Event Log tab, Click the Play icon [        ]. 

3) Click Request info. In the dialog (see Figure 5-14: Setting the matrix type), enter 

the following custom command: 

Custom 145.1.12096. <2 == Eclipse HX-Median, 3 == Eclipse HX-Omega,  4 

== Eclipse HX-Delta> 

 

Click Send. 
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Figure 5-14: Setting the matrix type 

Note: If the Event Log does not display, stop and restart the EHX software. 
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5.6 Checking the CPU card application code version 

To check the CPU card application code version: 

1) In EHX, select Diagnostics > Event Log. 

2) In the Matrix Event Log tab, Click the Play icon [        ]. 

3) Click Request info. In the dialog, select Matrix Overview and click Send. 

4) Look for the line that displays the application code (firmware) version. In the 

following example, the application code (version) number is 4.28.2.0: 

 

 

 

 

 
 

Figure 5-15: Application code (firmware) version 

5.7 Upgrading CPU Card U53 CPLD 

The U53 image is embedded in the CPU card main application firmware image (for upgrade 

purposes).  

If the CPU card supports the embedded (DIP switch based) upgrade (see below) and U53 

needs upgrading, then follow the steps below. 

The CPU card U53 upgrade can be performed any time after the v14 CPU main application 

has been loaded into the card. 

The U53 firmware image is embedded in CPU card main application firmware image and 

therefore no additional download from EHX is required. 

Note: Upgrade one CPU card at a time and verify correct functionality of the card after the 

upgrade before upgrading the second card. 

Note  Some older h/w revisions of CPU card do not support this centralized upgrade 

process. To establish if a CPU card supports the following upgrade method request a 

firmware report from EHX. If the U53 and U1 versions for a CPU card are reported as 

UNKNOWN then this method of CPLD upgrade is not supported and the Xilinx tools method 

of upgrade detailed in this section will need to be used. 
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Note: Power must not be lost to the CPU card during the upgrade of the U1 CPLD. The 

duration of the device load is approximately 5 seconds, but this will only commence a 

number of seconds after the card has been booted. If power is lost during the U1 CPLD 

upgrade the Xilinx tools method of upgrade will be required to recover the card. Until this is 

done the card will not be usable. It is therefore also especially important to upgrade the U1 

CPLD on one CPU card at a time.  

 

To upgrade a CPU card U53 CPLD device firmware image: 

1) Set the CPU card DIP switches as follows. This enables CPLD firmware upgrades. 

 
 

2) Re-insert the CPU card into the matrix. If the CPLD image requires upgrading this 

will be performed and the CPU card will reset on completion to action the image in 

the CPLD device. 

3) When the CPU card initializes (or re-initializes as a result of step 2.) and determines 

that the CPLD image is up to date it will output the following message via the LED 

front panel “CPLD Upgrades Enabled”.  

4) When the CPU card is running the CPLD upgrader application it will appear red in 

the layout screen indicating that this is not valid image to be configured using the 

EHX. However, the EHX firmware report can still be used. Use the EHX firmware 

report to verify that the correct version of the U53 CPLD is now loaded. 

5) If the upgrade has been completed disable the CPLD upgrade functionality by 

setting the DIP switches to the following settings. 
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5.8 Upgrading CPU Card U1 CPLD 

The U1 image is embedded in the CPU card firmware image (for upgrade purposes).  

The U1 upgrade can be performed any time after the v12 CPU card main application 

firmware image has been loaded into the card. 

The U1 firmware image is embedded in the CPLD upgrader CPU card main application 

firmware image and therefore no additional download from EHX is required. 

Note: Upgrade one CPU card at a time and verify correct functionality of the card after the 

upgrade before upgrading the second card. 

Note: Power must not be lost to the CPU card during the upgrade of the U1 CPLD. The 

duration of the device load is approximately 5 seconds, but this will only commence a 

number of seconds after the card has been booted. If power is lost during the U1 CPLD 

upgrade the Xilinx tools method of upgrade will be required to recover the card. Until this is 

done the card will not be usable. It is therefore also especially important to upgrade the U1 

CPLD on one CPU card at a time. 

Note: Some older h/w revisions of CPU card do not support this following centralized upgrade. To 

establish if a CPU card supports the following upgrade method request a firmware report 

from EHX. If the U53 and U1 versions for a CPU card are reported as UNKNOWN then this 

method of CPLD upgrade is not supported and the Xilinx tools method of upgrade detailed in 

this section will need to be used. 

To upgrade a CPU card U1 CPLD device firmware image 

1) Set the CPU card DIP switches as follows. This enables CPLD firmware upgrades. 
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2) Re-insert the CPU card into the matrix. 

3) Press and hold the ‘Config’ button on the front of the CPU card.  

4) Pin reset the CPU card and wait for 5 seconds. 

5) Release the ‘Config’ button. . If the CPLD image requires upgrading this will be 

performed and the CPU card will reset on completion to action the image in the 

CPLD device. 

6) When the CPU card initializes (or re-initializes as a result of step 2.) and determines 

that the CPLD image is up to date it will output the following message via the LED 

front panel “CPLD Upgrades Enabled”.  

7) Use the EHX firmware report to verify that the correct version of the U1 CPLD is 

now loaded. 

8) If the upgrade has been completed disable the CPLD upgrade functionality by 

setting the DIP switches to the following settings. 
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5.9 Upgrading the CPU card U53 CPLD code with Xilinx 

tools 

Use the following procedure to upgrade the U53 CPLD code for the CPU card.  

To upgrade the CPU U53 CPLD code with Xilinx tools: 

1) Check that you have the correct version of Xilinx ISE tools installed.  

Tip: Upgrading the CPU card(s) CPLD code using Xilinx tools requires specialized 

equipment. For more information about installing Xilinx programming tools, see 

 Appendix J:Xilinx tools.  

2) Connect the USB connector of the download cable (Platform cable Xilinx HW-USB-II-G 

or Digilent 6003-410-011) to the USB port of the PC. 

3) Connect the 14way IDC header to CON11. See CPU card layout. 

4) Power up the CPU card and start the iMPACT programming tool. 

5) In Load Project, select Cancel. 

6) Hold the CPU card in reset by inserting a suitable tool into the Reset pin at the top 

of the card. You must press and hold the reset pin during the whole upgrade 

process. 

7) In Flows, double click Boundary Scan. Right click the main window and select 

 Initialise Chain / Ctrl+ I: 
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Figure 5-16: Example iMPACT Boundary Scan 

8) If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given. 

The full chain shows two devices, as shown below. If more devices are seen, the 

connector may be loose, in the wrong position, or the CPU card may not have been 

held in reset properly. 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 124 of 315   

 

 

 

 

 
Figure 5-17: Example Xilinx chip chain 

9) The Assign New Configuration File dialog asks you to select the CPLD code for 

the first device in the chain or to bypass that device.  

Select the first device in the chain. 

For this (first) device, select the U53 CPLD code. The U53 CPLD code for the CPU 

card is available from the Drivers USB: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx - 

Config Card U53 CPLD code. 

Note: xxxxxx represents the part number. 

The folder contains a CPLD code file (*.jed) and a Read Me file (*.txt), which 

contains version information. 

10) Right click the first device (U53) and select Programming.  

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the main 

window. 

11) Power down the CPU card. 

5.10 Upgrading the CPU card U1 CPLD code with Xilinx 

tools 

Use the following procedure to upgrade the U1 CPLD code for the CPU card.  
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To upgrade the CPU U1 CPLD code with Xilinx tools: 

1) Check that you have the latest version of Xilinx tools installed.  

 

Tip: Upgrading the CPU card(s) CPLD code using Xilinx tools requires specialized 

equipment. For more information about installing Xilinx programming tools, see 

Appendix J:Xilinx tools.  

2) Connect the USB connector of the download cable (Xilinx HW-USB-II-G or Digilent 6003-

410-011) to the USB port of the PC. 

3) Connect the 14way IDC header to CON11. . See CPU card layout. 

4) Power up the CPU card and start the iMPACT programming tool. 

5) In Load Project, select Cancel. 

6) Hold the CPU card in reset by inserting a suitable tool into the Reset pin at the top 

of the card. You must press and hold the reset pin during the whole upgrade 

process. 

7) In Flows, double click Boundary Scan. Right click the main window and select 

 Initialise Chain / Ctrl+ I: 

 
Figure 5-18: Example iMPACT Boundary Scan 
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8) If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given. 

The full chain shows two devices, as shown below. If more devices are seen, the 

connector may be loose, in the wrong position, or the CPU card may not have been 

held in reset properly. 

 
Figure 5-19: Example Xilinx chip chain 

9) The Assign New Configuration File dialog asks you to select the CPLD code for 

the first device in the chain or to bypass that device.  

Bypass the first device. 

For the second device, select the U1 CPLD code. The U1 CPLD code for the CPU card 

is available from the Drivers USB: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx - 

Config Card U1 CPLD code. 

Note: xxxxxx represents the part number. 

The folder contains a CPLD code file (*.jed) and a Read Me file (*.txt), which 

contains version information. 

10) A summary dialog is presented. For all devices, ensure that the Erase Before 

Programming and Verify flags are set. Click OK. 
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Figure 5-20: Example Xilinx device programming properties 

11) Right click the second device and select Programming.  

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the main 

window. 

12) Power down the CPU card. 

5.11 Downloading a test configuration to the CPU card 

using EHX 

After you have upgraded your Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta 

matrix CPU cards, Clear-Com recommends downloading a test configuration from EHX to 

the CPU cards.  

Downloading a configuration will enable you to make any further configuration changes to 

the cards using either a serial or Ethernet connection. 

For more information, see your EHX User Manual. 

5.12 Forcing the CPU card to the factory default IP 

address 

In rare situations, the CPU card may not be able to find a valid IP address for the Ethernet 

port. To address this issue, you can force the matrix to the factory default IP address 

(169.254.0.100): 

1) Set your PC Ethernet IP address to DCHP mode. 
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2) Directly connect the PC to the matrix.  You may need to use an Ethernet crossover 

cable (modern PCs will switch pinout as required automatically). 

3) Force the system to use the default IP address, by performing the 3-finger reset. 

Press and hold both the ENG and FULL RESET front panel buttons simultaneously, 

then press the top RESET button. 

1. When the CPU card OK LED starts to flash, release both the ENG and FULL RESET 

buttons. 

Tip: For help with selecting the other procedures you require for upgrading to EHX, see the 

quick reference procedures tables in 3 Quick reference: Upgrading to Eclipse HX 
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6 Upgrading the Eclipse HX-PiCo 

This chapter describes how to upgrade the Eclipse HX-PiCo matrix, including the PROM, 

FPGA and application code. 

The Eclipse HX-PiCo PROM is different from the PROM used with the CPU cards, which are 

fitted to the Eclipse HX-Median, Eclipse HX-Omega and Eclipse HX-Delta matrices. Care 

should be taken to ensure that the correct PROM is fitted. 

Note: If you are upgrading your PiCo to an HX-PiCo please contact your Clear-Com representative 

to establish if your hardware is HX ready. If your PiCo hardware is not HX ready then this is 

a factory only upgrade. 

Note: This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 

 3Quick reference: Upgrading to Eclipse HX. 

Note: The HX-PiCo mainboard needs a factory hardware modification. 

 

Eclipse HX devices are powered by mains voltage. Unless 

specifically advised to the contrary, disconnect mains supply before 

carrying out any maintenance or repair tasks. Observe precautions 

for handling electrostatic sensitive devices. 

6.1 Changing the Eclipse HX-PiCo PROM 

Note: When you change the Eclipse HX-PiCo PROM, you must also change the Eclipse HX-PiCo 

RAM (from 128Mb RAM to 256Mb RAM). See 6.2 Changing the Eclipse HX-PiCo RAM 

below. 

To upgrade the Eclipse HX-PiCo PROM: 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

2MBit PROM device (ST 

M27W201 or equivalent). 

 

- 

PROM Programming Unit  You will also require the appropriate 

programming software for the unit. 

 

The appropriate S record 

file for the Eclipse HX-PiCo 

boot PROM.  

You can find the S record file on the Drivers 

USB: 
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Drivers USB > ECLIPSE DRIVERS > PiCo-

HX_PiCo_E-32 > xxxxxx – Boot PROM 

(where xxxxxx represents the part number). 
Table 6-1: Required equipment 

2) Ensure that the Eclipse HX-PiCo is powered off. Remove the lid of the device. 

  

 

Remove power from the device first, to avoid working with the 

system while it is live. Observe all electrical shock hazard warning 

and precautions for handling electrostatic sensitive devices  

3) Ensure that the PROM device to be programmed / upgraded is empty. 

4) Program the PROM device with the appropriate file, in accordance with the 

instructions for the PROM device. 

5) Confirm that the checksum of the programmed device matches that given in the 

Eclipse HX Release Notes (for this documentation, see the Eclipse HX v14 

software USB). 

6) Remove the existing PROM device from the main board.  

 

Figure 6-1: Eclipse HX-PiCo main board 
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7) Insert the newly programmed PROM device, taking care to ensure the correct 

polarity of the device. 

8) Replace the lid of the Eclipse HX-PiCo device. 

  



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 132 of 315   

 

 

 

 

6.2 Changing the Eclipse HX-PiCo RAM 

Note: When you change the Eclipse HX-PiCo RAM (from 128Mb RAM to 256Mb RAM), you must 

also change the Eclipse HX-PiCo PROM. See 6.1 Changing the Eclipse HX-PiCo PROM 

above. 

To change the Eclipse HX-PiCo RAM (from 128Mb to 256Mb): 

1) Ensure that: 

2) The Eclipse HX-PiCo is powered off.  

3) You have the replacement 256Mb CPU card RAM daughter board to hand. 

4) Remove the lid of the Eclipse HX-PiCo. 

5) The cassette that holds the Eclipse HX-PiCo RAM daughter board is left of center on 

the main board: 

 

Figure 6-2: Eclipse HX-PiCo 128Mb RAM daughter board 

To release the 128Mb RAM daughter board, push back the levers to either side of the 

cassette. Remove the board. 

6) Fit the replacement 256Mb CPU card RAM daughter board to the cassette. The 

daughter board is fitted chip-side up. Ensure that the daughter board is securely 

fitted (only the top edge of the connectors along the lower edge of the board should 
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be visible). 

 

Figure 6-3: Eclipse HX-PiCo 256Mb RAM daughter board 

7) Secure the RAM daughter board by closing the levers to either side of the cassette. 

6.3 Changing the Eclipse HX-PiCo DIP switches 

To change the Eclipse HX-PiCo DIP switches to the appropriate Eclipse HX v14 settings, see 

either: 

• Appendix D:Eclipse HX-PiCo CPU DIP switches 

 

• 6.4.3 Upgrading the Eclipse HX-PiCo secondary bootloader code using Tera Term 

Upgrading the Eclipse HX-PiCo secondary bootloader code 

6.4 Upgrading the Eclipse HX-PiCo Secondary 

Bootloader and Application 

6.4.1 Upgrading the Eclipse HX-PiCo secondary bootloader code 

using EHX with Ethernet 

Before you upgrade the Eclipse HX-PiCo card secondary bootloader code, check that: 

• The PC can successfully connect to the matrix with an Ethernet connection by 

viewing the Event Log (Diagnostics > Event Log) in EHX. 

• There is a valid configuration in the matrix. A valid configuration enables the matrix 

to identify its IP address and run its TCP / IP stack. 
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To upgrade Eclipse HX-PiCo secondary bootloader code using EHX with an Ethernet 

connection: 

1) Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet 

connector 

- 

LAN cable for the PC-to-

Eclipse HX PiCo connection 

For direct connections, use Ethernet crossover 

cable. If the connection passes through an 

Ethernet switch on its way to the PC / matrix, 

use straight CAT5 cable. 

 

EHX installation EHX must be configured and operational. 

 

An EHX configuration file 

(*.ccn or *.hxn file format) 

The configuration file must have an appropriate 

IP address set. 

 

The appropriate *.fwr data 

file for the Eclipse HX-PiCo 

You can find the *.fwr data file on the software 

USB at: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-PiCo > 

xxxxxx – Secondary Bootloader (where 

xxxxxx represents the product number). 

 

Example secondary bootloader version number 

- x.y.72.z 
Table 6-2: Required equipment 

2) Start EHX. Select Tools > Matrix Connection. 

3) In the Matrix Connection dialog, select the Ethernet communications option. 

4) Connect the PC with the Eclipse HX-PiCo, using the LAN port on the rear of the 

matrix. 

5) Do one of the following: 

• If you are running EHX in Client-Server mode, select File > Import project. 

Navigate to the configuration (*.ccn) file and click Open to import the file. 
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• If you are running EHX in Client-Only mode, select File > Open. Navigate to the 

configuration (*.ccn) and open the file. 

Note: EHX can open *.ccn format files as well as its own *.hxn format 

configuration files. 

6) In EHX, select System > Layout. In the work area, right click the Eclipse HX-PiCo. 

7) From the menu, select Firmware > Update Firmware. 

 
Figure 6-4: Upgrading app code: Matrix firmware update 

8) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again. 

9) In the next dialog, click Browse and navigate to the required *.fwr file for the 

Eclipse HX-PiCo secondary bootloader: 

a. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - EHX.xxx > 

Eclipse HX-PiCo > xxxxxx – Secondary Bootloader (where xxxxxx 

represents the part number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information. (Example secondary bootloader version number - x.y.72.z) 

b. Select the*.fwr file and click OK / Open. Ensure that the correct file name is 

displayed in the dialog. 

10) When the update is completed, click Finish in the Firmware Update wizard. The 

Eclipse HX-PiCo reboots. The CPU is reset. 

11) When the update is complete the HX Pico will be reachable via ethernet, however 

the matrix may remain grey in the layout screen and the apply firmware dialog may 

remain at the verifying stage. If this happens, check that the HX Pico can be 
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contacted by closing the apply firmware verifying dialog box and opening the 

Diagnostics >> Event Log window. Check that the event log is connected to the 

matrix. See section  5.6 

12) If so it simply means that this is the first time that this HX Pico is running the new 

secondary bootloader and main application image scheme and that the application 

has not yet been loaded. If the unit is in this state the OK LED will flash with a 

narrow pulse at a rate of 1Hz. 

13) Download the HX Pico main application using EHX. See section 6.4.4 Upgrading the 

Eclipse HX-PiCo main application code using EHX with Ethernet. 

Tip: While the update is in progress, check that the LED on the front of the Eclipse 

HX-PiCo is flashing rapidly. Rapid flashes indicate communication with the PC. 

6.4.2 Upgrading the Eclipse HX-PiCo app code using EHX with 

serial link 

You can upgrade the Eclipse HX-PiCo secondary bootloader code using EHX with a serial 

link, whether or not there is a valid configuration (map) on the matrix. With EHX, it is 

possible to perform the initial upgrade using a serial connection, then move to an Ethernet 

connection for future configuration downloads and upgrades, once an IP address has been 

configured. 

Note: Before you use this procedure, check that the matrix event log can connect serially to an  

Eclipse HX-PiCo with a configuration. 

To upgrade the secondary bootloader code with EHX, using a serial link: 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, you 

must connect the cable before starting EHX to 

enable EHX to detect the USB port as a COM 

port.   

RS232 serial cable  Use an RS232 cable with DB9 to 3.5mm jack 

connectors (a CellCom / FreeSpeak / FreeSpeak 

II (FSBP) registration cable (PD4007Z)). 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn) 

The configuration file must have the 

appropriate IP address set (not necessary for 

serial connection). 
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The appropriate *.fwr data 

file for the Eclipse HX-PiCo 

secondary bootloader 

You can find the *.fwr data file on the software 

USB at: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-PiCo > 

xxxxxx – Secondary Bootloader (where 

xxxxxx represents the part number). 

 

Example secondary bootloader version number 

- x.y.72.z 
Table 6-3: Required equipment 

2) Start EHX. Select Tools > Matrix connection. 

3) In the Matrix connection dialog, select the serial communications option. 

4) Select the correct COM port then click OK. 

5) Connect the PC to the serial port on the front of the device, using an RS232 cable 

with DB9 to 3.5mm jack connectors (CellCom / FreeSpeak / FreeSpeak II (FSBP) 

registration cable (PD4007Z)). 

5. Do one of the following: 

• If you are running EHX in Client-Server mode, select File > Import 

project. Navigate to the configuration (*.ccn) file and click Open to import 

the file. 

• If you are running EHX in Client-Only mode, select File > Open. Navigate 

to the configuration (*.ccn) and open the file. 

Note: EHX can open *.ccn format files as well as its own *.hxn format 

configuration files. 

6) In EHX, select System > Layout. In the work area, right click the matrix. 

7) From the menu, select Firmware > Update Firmware. 
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Figure 6-5: Upgrading app code: Matrix firmware update 

8) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again. 

9) In the next dialog, click Browse and navigate to the required *.fwr file for the 

Eclipse HX-PiCo secondary bootloader: 

a. Go to Software USB > SOFTWARE - EHX.xxx > Eclipse HX-PiCo > 

xxxxxx – Secondary Bootloader (where xxxxxx represents the part 

number).  

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information. (Example secondary bootloader version number - x.y.72.z) 

b. Select the*.fwr file and click OK / Open. Ensure that the correct file name is 

displayed in the dialog. 

c. When the update is completed, click Finish in the Firmware Update wizard. 

The Eclipse HX-PiCo reboots. 

d. When the update is complete the HX Pico will be reachable via ethernet, 

however the matrix will may remain grey in the layout screen and the apply 

firmware dialog may remain at the verifying stage. If this happens, check that 

the HX Pico can be contacted by closing the apply firmware verifying dialog 

box and opening the Diagnostics >> Event Log window. Check that the event 

log is connected to the matrix. See section  5.6 

e. If so it simply means that this is the first time that this HX Pico is running the 

new secondary bootloader and main application image scheme and that the 

application has not yet been loaded. If the unit is in this state the OK LED will 

flash with a narrow pulse at a rate of 1Hz. 
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Download the HX Pico main application using EHX. See Section 6.4.5 Upgrading the Eclipse 

HX-PiCo main application code using EHX with serial link. 

If the upgrade fails 

If the upgrade fails, check the cabling and repeat the procedure. If the procedure still fails, 

use Tera Term to upgrade the Eclipse HX-PiCo firmware (see below). 

If there was no previous configuration loaded in the matrix, download a basic configuration 

file to the Eclipse HX-PiCo matrix using EHX. Make any further configuration changes over 

the Ethernet LAN. 

6.4.3 Upgrading the Eclipse HX-PiCo secondary bootloader code 

using Tera Term 

To upgrade the Eclipse HX-PiCo secondary bootloader code using Tera Term: 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, you 

must connect the cable before starting Tera 

Term to detect the USB port as a COM port.   

 

RS232 serial cable Use a RS232 cable with DB-9 to 3.5mm jack 

connectors (a CellCom / FreeSpeak / FreeSpeak 

II (FSBP) registration cable (PD4007Z)). 

 

Tera Term installation Tera Term must be configured and operational. 

You can find the Tera Term application on both 

of the Eclipse HX 14 upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

ECLIPSE DRIVERS > 3rd_Party_Software > 

Teraterm 

 

The appropriate *.fwr data 

file for the Eclipse HX-PiCo 

secondary bootloader 

You can find the *.fwr data file on the software 

USB at: 

Software USB > SOFTWARE - EHX.xxx > 

Eclipse HX-PiCo > xxxxxx – Secondary 

Bootloader (where xxxxxx represents the 
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Required equipment Description / comments 

part number). 

Example secondary bootloader version number 

- x.y.72.z 
Table 6-4: Required equipment 

2) Install the Tera Term application. Accept all default settings. 

3) Start Tera Term. In the New Connection dialog, select Serial (connection) and 

the COM port to use. Click OK. 

 
Figure 6-6: Tera Term: selecting serial connection 

  



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 141 of 315   

 

 

 

 

4) From the Setup menu, select the Serial port… entry.  

 

 

 

 

 

 

 

 

 

 
 

Figure 6-7: Tera Term: selecting Serial port… 

5) The Serial port configuration dialog is displayed. Configure the serial port as 

follows: 

Field Data (to enter / select) 

Port Com1 

Note: 

Change as required to match a COM port on the PC. 

Baud Rate 115200 

Parity Even 

Stop One (bits) 

Data 8 (bits) 

Table 6-5: Tera Term: Serial port configuration 

Tip: The Tera Term application can be used for many of the Eclipse system upgrade 

processes. You can save and recall the relevant com port settings in Tera Term by 

selecting the Setup / Save or Restore settings options. 

6) Connect the PC serial port to the RS232 port to the front of the Eclipse HX-PiCo 

matrix. 
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7) Power off the matrix. To access the CPU, remove the lid from the matrix.  

 

Remove power from the device first, to avoid working 

with the system while it is live. Observe all electrical 

shock hazard warning and precautions for handling 

electrostatic sensitive devices.  

 

8) Erase the old application code (firmware) from the CPU: 

a. Place the CPU in TEST mode. 

b. Set the DIP switches on the CPU as follows: 

 
Figure 6-8: Eclipse HX-PiCo dip switches in Test mode 

c. To bring the DIP switch changes into effect, power cycle or reset the matrix. 

d. To confirm that the matrix has entered Test mode, check the display screen. 

Information similar to the following should be displayed: 

 

 

Figure 6-9: Tera Term CPU test mode 

 

Note: If you do not see the data above, press the enter button on the PC. 
 

Tip: To see all the available options in test mode, press ? on your keyboard. 

To see all the current applications loaded onto the CPU, press i. 

e. On your PC keyboard, press number 1. To start the erasure of Flash 

memory, press Enter (or Return). Select y and Enter to confirm. 
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Note: It takes approximately 1 minute to erase Flash. 

f. When the Flash has been erased, press number 2 on your keyboard. To start 

the erasure of NVRAM, press Enter (or Return). When the NVRAM erase is 

complete, power off the PiCo. 

9) Download the new secondary bootloader code to the CPU, using Tera Term: 

a. Place the erased CPU in serial download mode. Set the DIP switches on the 

CPU as follows: 

 
Figure 6-10: Tera Term: DIP switches, serial download mode 

b. Power cycle or reset the Eclipse HX-PiCo to bring the DIP switch changes into 

effect. 

c. In Tera Term, open File and select Send file… Ensure that the BINARY 

option box is selected.  

 
Figure 6-11: Tera Term: Send file… 

d. In the Select file dialog, select the file to download, navigate to the CPU 

secondary bootloader code (firmware) *.fwr file: 
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i. Go to Software USB > SOFTWARE - EHX.xxx > Eclipse HX-PiCo > 

xxxxxx – Secondary Bootloader (where xxxxxx represents the 

part number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with 

version information. (Example secondary bootloader version number - 

x.y.72.z) 

ii. Select the*.fwr file and click OK / Open. Ensure that the correct file 

name is displayed in the dialog. 

Note: Confirm that the matrix resets and restarts correctly. 

Note: It may take up to 1 minute for the matrix to write the new 

secondary bootloader code in Flash before it reboots and the OK 

LED starts to flash with a narrow 1Hz pulse 

e. Set the DIP switches to normal running mode (watchdogs enabled): 

 
Figure 6-12: DIP switches set to normal running mode (watchdogs enabled) 

f. Power cycle the Eclipse HX-PiCo so the DIP switch changes come into effect. 

Note: If the download fails the matrix OK LED displays a long flash/ off rate. Tera Term does not 

indicate a failure onscreen and continues to download.  

In this case, re-erase the matrix by placing the SW1 and SW2 into Test mode and repeating 

the steps that follow. Check your cabling.  

6.4.4 Upgrading the Eclipse HX-PiCo main application code using 

EHX with Ethernet 

Before you upgrade the Eclipse HX-PiCo card main application code, check that: 

• The PC can successfully connect to the matrix with an Ethernet connection by 

viewing the Event Log (Diagnostics > Event Log) in EHX. 
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To upgrade Eclipse HX-PiCo main application code using EHX with an Ethernet connection: 

1) Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet 

connector 

- 

LAN cable for the PC-to-

Eclipse HX PiCo connection 

For direct connections, use Ethernet crossover 

cable. If the connection passes through an 

Ethernet switch on its way to the PC / matrix, 

use straight CAT5 cable. 

 

EHX installation EHX must be configured and operational. 

 

An EHX configuration file 

(*.ccn or *.hxn file format) 

The configuration file must have an appropriate 

IP address set. 

 

The appropriate *.fwr data 

file for the Eclipse HX-PiCo 

You can find the *.fwr data file on the software 

USB at: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-PiCo > 

xxxxxx – Application Code (where xxxxxx 

represents the product number). 

Example version number – x.y.3.0 
Table 6-6: Required equipment 

2) Start EHX. Select Tools > Matrix Connection. 

3) In the Matrix Connection dialog, select the Ethernet communications option. 

4) Connect the PC with the Eclipse HX-PiCo, using the LAN port on the rear of the 

matrix. 

5) Do one of the following: 

• If you are running EHX in Client-Server mode, select File > Import project. 

Navigate to the configuration (*.ccn) file and click Open to import the file. 

• If you are running EHX in Client-Only mode, select File > Open. Navigate to the 

configuration (*.ccn) and open the file. 

Note: EHX can open *.ccn format files as well as its own *.hxn format 

configuration files. 
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6) In EHX, select System > Layout. In the work area, right click the Eclipse HX-PiCo. 

7) From the menu, select Firmware > Update Firmware. 

 
Figure 6-13: Upgrading main application code: Matrix firmware update 

8) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again. 

9) In the next dialog, click Browse and navigate to the required *.fwr file for the 

Eclipse HX-PiCo main application: 

a. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - EHX.xxx > 

Eclipse HX-PiCo > xxxxxx – Application Code (where xxxxxx represents 

the part number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information. 

b. Select the*.fwr file and click OK / Open. Ensure that the correct file name is 

displayed in the dialog. Example version number – x.y.3.0 

10) Click Next. Confirm that the correct file has been selected, and click Next again to 

start the firmware update. The update will take approximately 2 minutes. 

Tip: While the update is in progress, check that the LED on the front of the Eclipse 

HX-PiCo is flashing rapidly. Rapid flashes indicate communication with the PC. 

Note: If you are upgrading from v5.2.5 to Eclipse HX v14, the download 

dialog does not automatically finish. This is due to a messaging 

change between the two system architectures. Instead, close the 

dialog (which will continue to indicate Verifying) when the Eclipse 

HX-PiCo reboots (see Step 10). 
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11) When the update is completed, click Finish in the Firmware Update wizard. The 

Eclipse HX-PiCo reboots. The CPU is reset. 

Note: The OK LED double flashes to indicate that valid application code is 

present, but that there is no configuration in the cards. Download a 

configuration file (*.hxn or *.ccn format), using EHX. 

6.4.5 Upgrading the Eclipse HX-PiCo main application code using 

EHX with serial link 

You can upgrade the Eclipse HX-PiCo main application code using EHX with a serial link, 

whether or not there is a valid configuration (map) on the matrix. With EHX, it is possible to 

perform the initial upgrade using a serial connection, then move to an Ethernet connection 

for future configuration downloads and upgrades, once an IP address has been configured. 

Note: Before you use this procedure, check that the matrix event log can connect serially to an  

Eclipse HX-PiCo with a configuration. 

To upgrade the main application code with EHX, using a serial link: 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, you 

must connect the cable before starting EHX to 

enable EHX to detect the USB port as a COM 

port.   

RS232 serial cable  Use an RS232 cable with DB9 to 3.5mm jack 

connectors (a CellCom / FreeSpeak / FreeSpeak 

II (FSBP) registration cable (PD4007Z)). 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn) 

The configuration file must have the 

appropriate IP address set (not necessary for 

serial upgrade). 

The appropriate *.fwr data 

file for the Eclipse HX-PiCo 

main application 

You can find the *.fwr data file on the software 

USB at: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-PiCo > 

xxxxxx – Application Code (where xxxxxx 

represents the part number). 

Example version number – x.y.3.0 
Table 6-7: Required equipment 

2) Start EHX. Select Tools > Matrix connection. 
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3) In the Matrix connection dialog, select the serial communications option. 

4) Select the correct COM port then click OK. 

5) Connect the PC to the serial port on the front of the device, using an RS232 cable 

with DB9 to 3.5mm jack connectors (CellCom / FreeSpeak / FreeSpeak II (FSBP) 

registration cable (PD4007Z)). 

 

Do one of the following: 

• If you are running EHX in Client-Server mode, select File > Import 

project. Navigate to the configuration (*.ccn) file and click Open to import 

the file. 

• If you are running EHX in Client-Only mode, select File > Open. Navigate 

to the configuration (*.ccn) and open the file. 

Note: EHX can open *.ccn format files as well as its own *.hxn format 

configuration files. 

6) In EHX, select System > Layout. In the work area, right click the matrix. 

7) From the menu, select Firmware > Update Firmware. 

 
Figure 6-14: Upgrading main application code: Matrix firmware update 

8) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again. 

9) In the next dialog, click Browse and navigate to the required *.fwr file for the 

Eclipse HX-PiCo  application: 
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a. Go to Software USB > SOFTWARE - EHX.xxx > Eclipse HX-PiCo > 

xxxxxx – Application Code (where xxxxxx represents the part number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information. Example version number – x.y.3.0 

b. Select the*.fwr file and click OK / Open. Ensure that the correct file name is 

displayed in the dialog. 

10) Click Next. Confirm that the correct file has been selected, and click Next again to 

start the firmware update. The upgrade will take approximately 2 minutes. 

Tip: While the update is in progress, the LED on the front of the CPU card will flash 

rapidly. Rapid flashes indicate communication with the PC.  

Note: If you are upgrading from v5.2.5 to Eclipse HX v14, the download 

dialog does not automatically finish. This is due to a messaging 

change between the two system architectures. Instead, close the 

dialog (which will continue to indicate Verifying) when the Eclipse 

HX-PiCo reboots (see Step 11). 

 

11) When the update is completed, click Finish in the Firmware Update wizard. The 

Eclipse HX-PiCo reboots.  

If the upgrade fails 

If the upgrade fails, check the cabling and repeat the procedure. If the procedure still fails, 

use Tera Term to upgrade the Eclipse HX-PiCo firmware (see below). 

If there was no previous configuration loaded in the matrix, download a basic configuration 

file to the Eclipse HX-PiCo matrix using EHX. Make any further configuration changes over 

the Ethernet LAN. 

6.5 Upgrading the Eclipse HX-PiCo MVX code  

The Eclipse HX-PiCo has two MVX cards (or sections) on the same PCB, both of which 

require upgrading. 

If you are upgrading from ECS v5.2.5, Clear-Com recommends upgrading the Eclipse HX-

PiCo with the combined MVX boot and application code file (*.mot), using the Renesas 

Flash Development Tool (FDT). 

If you are upgrading an existing Eclipse HX installation, you can upgrade: 

• The MVX application code separately (*.fwc), using EHX. 

• The MVX boot code separately (*.mot), using the Renesas FDT method. 
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• The MVX boot and application code simultaneously, using the Renesas FDT method 

and the combined MVX boot and application code file (*.mot). 

MVX code Renesas FDT 

method 

EHX method 

MVX boot code (*.mot)  - 

 

MVX application code 

(.fwc) 

- 

 
 

Combined MVX boot and 

application code (*mot) 
 

 

- 

Table 6-8: Upgrading the Eclipse HX-PiCo MVX code 

Note: Because of small differences in PCB layout, it may not be possible to complete the upgrade 

of the MVX application code on a small number of Eclipse HX-PiCo units, using EHX. If the 

upgrade fails, you can still upgrade the MVX application code using Renesas FDT (which is 

suitable for all Eclipse HX-PiCo units). 

6.5.1 Upgrading the Eclipse HX-PiCo MVX application code 

 with EHX 

Note: To upgrade the Eclipse HX-PiCo MVX application code with EHX, your system must already 

be running a version of Eclipse HX. 

Recommendation 

Clear-Com recommends that you monitor the MVX application code upgrade using the Event 

Log in EHX. The upgrade process is complete when the Event Log reports the Eclipse HX-

PiCo’s MVXs are absent and then present again. To check that the upgrade has been 

successful, run a firmware report. 

If the upgrade is unsuccessful, use the Renesas FDT to upgrade the MVX code  

(see 6.5.2 Upgrading the Eclipse HX-PiCo MVX boot and/or app code using the 

Renesas FDT). 

To upgrade the Eclipse HX-PiCo MVX application code using EHX: 

1) Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet 

connector 

 

- 
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Serial cable or Ethernet 

cable for the PC to matrix 

connection 

 

- 

EHX installation 

 

EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn format) 

 

The configuration file must have an appropriate 

IP address set. 

The appropriate *.fwc 

format file for the Eclipse 

HX-PiCo MVX cards / 

sections 

You can find the Eclipse HX-PiCo MVX 

application code (*.fwc) file on the software 

USB: 

Drivers USB > ECLIPSE DRIVERS > 

ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > 

xxxxxx-MVX Application 

 
Table 6-9: Required equipment 

2) Start EHX on the PC. 

3) Connect the PC to the matrix using either Ethernet or a serial communications 

port. 

4) Open the EHX configuration map within EHX. Select System > Layout. 

5) Right click the matrix and then select Firmware> Update Firmware. 

6) The Update Firmware wizard dialog is displayed. Click Next. 

In the Select Hardware Type screen, ensure that the Card radio button is 

selected.  

 
Figure 6-15: Select Hardware Type 
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7) In the next dialog, click Browse and navigate to the required *.fwc file for the 

Eclipse HX-PiCo  application: 

8) Go to Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx – 

MVX Application (where xxxxxx represents the part number). 

9) The folder contains the *.fwc file and a Read Me file (*.txt) with version 

information. 

10) Select the*.fwc file and click OK / Open. Ensure that the correct file name is 

displayed in the dialog. 

11) Click Next and confirm that the details displayed are correct. 

12) Click Next and confirm that the download commences. 

13) When the download has completed, click Finish to close the update firmware wizard. 

Note: Because of small differences in PCB layout, it may not be possible to complete the upgrade 

of the MVX application code on a small number of Eclipse HX-PiCo units, using EHX. If the 

upgrade fails, you can still upgrade the MVX application code using Renesas FDT (which is 

suitable for all Eclipse HX-PiCo units). 

6.5.2 Upgrading the Eclipse HX-PiCo MVX boot and/or app code 

using the Renesas FDT 

 

To upgrade certain components within the Eclipse HX-PiCo matrix, 

the lid must be removed. 

 

Remove power from the devices first, to avoid working with the 

system while it is live. Observe all electrical shock hazard warning 

and precautions for handling electrostatic sensitive devices  

 

You can use the Renesas FDT to upgrade: 

• The MVX boot code file separately (*.mot). 
 

• The MVX boot code and MVX application code simultaneously, using the combined MVX boot 
and application code file (*.mot). 
 

Tip:  For more information about installing and configuring the Renesas FDT, see 

Appendix E: Hitachi Renesas Flash Development Tool. 

To upgrade the Eclipse HX-PiCo MVX code (MVX boot code or combined MVX boot and 

application code): 

1) Ensure that you have the following equipment: 
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Required equipment Description / comments 

PC with a serial port 

connection or USB-to-

serial port adaptor 

If you are using a USB-to-serial port adaptor, 

download the latest drivers. 

Renesas Flash 

Development Toolkit 3.4 

Basic (FDT) 

 

The Renesas FDT must be installed and 

configured. You can find the Renesas FDT 

application on both of the Eclipse HX v14 upgrade 

media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > RenesasFDT 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > RenesasFDT  

MVX-A16 serial upgrade 

cable (Clear-Com part 

CAB-MVX-48Z) 

For an image of this cable, see 

Figure 28: MVX-A16 Serial upgrade cable. 

The appropriate MVX code 

file  

 

(*.fwc format for the 

separate MVX boot file, 

*.mot format for the 

combined MVX boot and 

application code file ) 

You can find the Eclipse HX-PiCo MVX code files 

on the Eclipse Drivers USB: 

Drivers USB > ECLIPSE DRIVERS > PiCo-

HX_PiCo_E-32 > xxxxxx-MVX Boot 

Drivers USB > ECLIPSE DRIVERS > PiCo-

HX_PiCo_E-32 > xxxxxx-MVX Combined 

Boot & App 

Where xxxxxx represents the product number. 
Table 6-10: Required equipment 

2) Install the Renesas Flash Development Toolkit 3.4 Basic (FDT). Accept the default 

install settings. 

3) Start the Renesas Flash Development Toolkit 3.4 (FDT) from Programs, selecting 

the basic Startup option. 

4) Access the configuration (settings) dialogs, by selecting Options > New 

Settings...  Configure the FDT, as shown in the table below: 

Settings dialog / 

option 

Setting to enter 

 

Select Device 

 

H8S/2318F 

Select Port COM1 (Change to match a COM port present on the PC) 
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Settings dialog / 

option 

Setting to enter 

CPU Frequency 20.0000 Mhz 

Connection Boot mode 

Recommended Speed 38400 (Deselect the Use-Default option) 

Protection Automatic 

Messaging Advanced 

User Area Selected (Checked)  

Table 6-11: FDT settings 

Note:  

The first time the FDT is run, the settings dialogs are displayed by default. After the 

FDT has been configured, the settings dialogs are no longer shown by default.  

Tip:  For more information about installing and configuring the Renesas FDT, see 

 Appendix E: Hitachi Renesas Flash Development Tool. 

 

5) In the Download window, click Options and ensure that: 

• Auto-Disconnect is selected (checked). 

• Download File Area has User Area selected (checked). 

• The Download File radio button is selected. 

6) Select ‘…’ for the User area and select the appropriate MVX code file from the 

Eclipse HX v14 software USB. According to your requirements, select one of the 

following: 

• Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx-MVX 

Boot 

 

Where xxxxxx represents the product number. The folder contains the 

*.mot file and a Read Me file (*.txt) with version information. 

• Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx-MVX 

Combined Boot & App 

Where xxxxxx represents the product number. The folder contains the 

*.mot file and a Read Me file (*.txt) with version information. 

7) Upgrade / program the first of the two H8 devices: 
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a. Connect the MVX serial cable (CAB-MVX-48Z) between the COM port on the PC 

and J9 (H8FP1) on the MVX card. See PiCo card layout. 

Note:  

The MVX connection is polarized to ensure correct connection. 

b. On the MVX card, ensure that jumper H8 Boot1 (JP8) is made. 

c. Select Program Flash from the Flash Development Toolkit (FDT) program. 

d. Confirm that FDT reports the image has been written successfully. 

e. Remove the serial cable. 

f. Remove jumper JP8. 

For the location of connectors, jumpers and reset switch positions on the Eclipse HX-

PiCo, see Figure 6-16: Eclipse HX-PiCo main board. 

Note: If the MVX card fails to upgrade, press the Reset button, located near the J9 (H8FP1) 

connector and select Program Flash from the FDT again. 

If you are using a USB-to-serial adaptor, the adaptor may have to be unplugged and 

re-plugged to enable the upgrade to start on some computers. If you are running the 

EHX application, ensure that EHX is configured for Ethernet and not serial 

connection. 

8) Upgrade / program the second of the two H8 devices: 

a. Connect the MVX serial cable (CAB-MVX-48Z) between the COM port on the PC 

and J11 (H8FP2) on the MVX card. 

Note: The MVX connection is polarized to ensure correct connection. 

b. On the MVX card, ensure that jumper H8 Boot2 (JP10) is made. 

c. Select Program Flash from the Flash Development Toolkit (FDT) program.  

d. Confirm that FDT reports the image has been written successfully. 

e. Remove the serial cable. 

f. Remove jumper JP10. 

For the location of connectors, jumpers and reset switch positions on the Eclipse HX-

PiCo, see Figure 6-16: Eclipse HX-PiCo main board. 

Note: If the MVX card fails to upgrade, press the Reset button, located 

near the H8FP1 (JP11) connector and select Program Flash from 

the FDT again.  

If you are using a USB-to-serial adaptor, the adaptor may have to be unplugged and re-

plugged to enable the upgrade to start on some computers. If you are running the EHX 

application, ensure that EHX is configured for Ethernet and not serial connection. 
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Figure 6-16: Eclipse HX-PiCo main board 

6.6 Checking the Eclipse HX-PiCo app code and MVX 

code versions 

You can check both the Eclipse HX-PiCo application code and MVX code versions by going to 

EHX> Matrix Event Log > Matrix Overview. 

You can also use the Firmware report tool in EHX to confirm code versions. To use the 

Firmware report tool: 

1) Go to EHX> System> Layout. 

2) Right click the matrix icon. 

3) Select Firmware > Firmware report. 

To check the Eclipse PiCo MVX code version only using Tera Term: 

1) Install Tera Term. Tera Term is available to install from both of the Eclipse HX 14 

upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > Teraterm 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 

 

2) Open Tera Term and select the following port settings: 

Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 

Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow control none 
Table 6-12: Tera Term port settings 

3) Open the Eclipse HX-PiCo lid. 

  

 

Remove power from the devices first, to avoid working with the 

system while it is live. Observe all electrical shock hazard warning 

and precautions for handling electrostatic sensitive devices  
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4) There are two three-pin connectors (H8DBG1 and H8DBG2), one for each of the 

two MVX cards / sections. Connect the MVX serial cable (CAB-MVX-48Z) to one of the 

connectors. See PiCo card layout. 

Note: Take care not to confuse these two three-pin connectors with the identical (but differently 

labeled) three-pin connectors which are used to upload new application code. 

 

5) Run Tera Term. If necessary, press Enter on your keyboard or the MVX reset 

switch a few times. The version information is displayed in the Tera Term window. 

Note: Reports the MVX application code version only. 

6) Repeat the procedure with the second MVX card / section. 

6.7 Upgrading the Eclipse HX-PiCo CPLD and FPGA code 

with Xilinx tools 

To upgrade either the Eclipse HX-PiCo U1 CPLD code or FPGA code with Xilinx tools: 

1) Ensure that the latest version of the Xilinx programming tools has been installed.  

Tip: For more information about installing Xilinx programming tools, see Appendix 

J:Xilinx tools. 

Connect the USB connector of the download cable (Xilinx HW-USB-II-G or Digilent 6003-

410-011) to the USB port of the PC. 

2) If you are upgrading the FPGA code, connect the 14way IDC header to CON12.  

3) If you are upgrading the U1 CPLD code, connect the 14way IDC header to 

CON25.  (the Xilinx chain for the Pico CPLD is one chain) 

Tip: For the location of CON12 and CON25, see Figure 6-16: Eclipse HX-PiCo 

main board. 

4) Power up the Eclipse HX-PiCo and start the iMPACT programming tool. 

5) In Load Project, select Cancel. 

6) In Flows, double click Boundary Scan. Right click the main window and select 

Initialise Chain / Ctrl+ I: 
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Figure 6-17: Example iMPACT Boundary Scan 

7) If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given. 

The full chain should show two devices, as shown in the example figure below. 
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Figure 6-18: Example Xilinx chip chain 

 

8) The Assign New Configuration File dialog asks you to select the code for the first 

device in the chain or to bypass that device.  

In this example procedure, the first device will be bypassed and either the U1 CPLD 

or FPGA code will be assigned to the second device. 

 

• For the first device, press Bypass. 
 

• For the second device, select the appropriate code file (either the U1 CPLD code or 
FPGA code file). The U1 CPLD and FPGA code files are available from the Drivers USB: 
 

• Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx – E32 
Glue Logic CPLD (U1). 
 

• Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx – Eclipse 
32 FPGA Code. 
 

Reminder: 

If you are upgrading the FPGA code, the 14way IDC header must be connected to 

CON12. If you are upgrading the U1 CPLD code, the 14way IDC header must be 

connected to CON25. See Step 3. 
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9) A summary dialog is presented. For all devices, ensure that the Erase Before 

Programming and Verify flags are set. Click OK. 

 

 
 

Figure 6-19: Example Xilinx device programming properties 

10) Right click the second device and select Programming.  

 

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the main 

window. 

11) Power down the PiCo. 

 

6.8 Download a test configuration into the Eclipse HX-

PiCo using EHX 

After you have upgraded your Eclipse HX-PiCo, Clear-Com recommends downloading a  

test configuration to the matrix. Downloading a configuration will enable you to make any 

further configuration changes you require using EHX over an Ethernet or serial connection. 

For more information, see your EHX User Guide. 
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6.9 Forcing the Eclipse HX-PiCo to the factory default 

IP address 

 
In rare situations, the CPU card may not be able to find a valid IP address for the Ethernet 

port. To address this issue, force the matrix to the factory default IP address 

(169.254.0.100) by using the Eclipse HX-PiCo menu system to enable DHCP. 

For more information about using the Eclipse HX-PiCo menu system, see the Eclipse HX-

PiCo User Guide. 

Alternatively, you can reset the Eclipse HX-PiCo to the factory default IP address with the 

internal reset switches. 

To force the Eclipse HX-PiCo to the factory default IP address using the internal switches: 

1. Set your PC Ethernet IP address to DCHP mode. Directly connect the PC to the 

matrix using an Ethernet crossover cable. 

 

2. To gain access to the internal reset switches, remove the lid of the Eclipse HX-PiCo.  

 

 

The device is live (powered). Observe all electrical shock hazard 

warning and precautions for handling electrostatic sensitive devices.  

 

 

 
Figure 6-20: Eclipse HX-PiCo: resetting to the factory default IP 

address 
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3. To reset the IP address, press and hold the two rightmost switches simultaneously 

(the IP Reset switch and the Full Reset switch), then press and release RESET on 

the front of the matrix. 

4. Once the OK LED starts to flash, release both internal buttons. 

 

5. Replace the Eclipse HX-PiCo lid. 
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7 Upgrading the MVX-A16 card  

This chapter describes how to upgrade the MVX-A16 analog port card, which is fitted to the 

Eclipse HX-Median, Eclipse HX-Omega and Eclipse HX-Delta matrices.  

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

 

7.1 Identifying MK I and MK II MVX-A16 cards 

You can identify MK I and MK II cards visually. 

The MK 1 MVX-A16 card is green. – see Figure 7-2: MVX-A16 MK I card: J1, CON8 and 

CON12 

The MK2 MVX-A16 card is blue. – see Figure 7-3: MVX-A16 MK II card: J1, CON8 and 

CON12 

Both cards are upgraded with the same code except for the FPGA – see 7.4 Upgrading the 

MVX-A16 MK I or MK II card FPGA with Xilinx tools 

7.2 Upgrading the MVX-A16 MK I or MK II boot and/or 

app code 

If you are upgrading from ECS v5.2.5, Clear-Com recommends upgrading the MVX-A16 card 

with the combined MVX boot and application code file (*.mot), using the Renesas Flash 

Development Tool (FDT). 

If you are upgrading an existing Eclipse HX installation, you can upgrade: 

• The MVX application code separately (*.fwc), using EHX. 
 

• The MVX boot code separately (*.mot), using the Renesas FDT method. 
 

• The MVX boot and application code simultaneously, using the Renesas FDT method and the 
combined MVX boot and application code file (*.mot). 
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MVX code Renesas FDT method EHX method 

MVX boot code 

(*.mot) 
 - 

 

MVX application code 

(.fwc) 

- 

 
 

Combined MVX boot 

and application code 

(*mot) 

 

 

- 

Table 7-1: Upgrading the Eclipse HX-PiCo MVX code 

7.2.1 Upgrading the MVX-A16 card app code using EHX 

You can upgrade the MVX-A16 application code (*.fwc) using EHX and an Eclipse HX 

matrix. For Ethernet connections, an EHX configuration is required with the correct IP 

address configured. The application code is available from the Eclipse HX v14 software USB.  

Place the H8 application code in a location that EHX can access. When these files are 

downloaded to the matrix, all the MVX-A16 cards that have been fitted to the matrix will be 

upgraded. 

To upgrade MVX-A16 H8 application code using EHX: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet 

connector 

- 

Serial cable or Ethernet 

cable for the PC to matrix 

connection. 

- 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn) 

The configuration file must have an appropriate 

IP address set. 

The appropriate *.fwc 

format file for the MVX-A16 

card 

You can find the *.fwc file on the software 

USB: 

Drivers USB > ECLIPSE DRIVERS > 

Omega-Median-Delta > xxxxxx-MVX 

Application (where xxxxxx represents the 

product number).  
Table 7-2: Required equipment 
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2. Start EHX on the PC. 

3. Connect the PC to the matrix using either Ethernet or a serial communications port. 

4. Open the EHX configuration map within EHX. Select System > Layout. 

5. Right click the matrix and then select Firmware> Update Firmware. 

6. The Update Firmware wizard dialog is displayed. Click Next. 

In the Select Hardware Type screen, ensure that the Card radio button is 

selected. 

 

 
Figure 7-1: Select Hardware Type 

7. In the next dialog, click Browse and navigate to the required *.fwc file for the MVX-

A16 card  application: 

a. Go to Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > 

xxxxxx – MVX Application (where xxxxxx represents the part number). 

The folder contains the *.fwc file and a Read Me file (*.txt) with version 

information. 

b. Select the*.fwc file and click OK / Open.  

8. Click Next and confirm that the details displayed are correct. 

9. Click Next and confirm that the download commences. 

10. When the download has completed, click Finish to close the update firmware wizard. 

 

Note: The MVX-A16 card status light flashes green while the upgrade is in process (LED on to off 

ratio: 1:4 at 0.5Hz). When the upgrade is complete, the status light is lit green at a steady 

heartbeat (LED on to off ratio: 1:1 at 1Hz). 

11. Ensure that the MVX-A16 cards reset once the download is complete. Reset should 

take approximately 1 minute. 

7.2.2 Upgrading the MVX-A16 boot and app code using the 

Renesas FDT 

 

 

Remove power from the devices first, to avoid working with the 

system while it is live. Observe all electrical shock hazard warning 

and precautions for handling electrostatic sensitive devices  
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You can use the Renesas FDT to upgrade: 

• The MVX boot code file separately (*.mot). 
 

• The MVX boot code and MVX application code simultaneously, using the combined MVX boot 
and application code file (*.mot). 
 

Tip:  For more information about installing and configuring the Renesas FDT, see 

Appendix E: Hitachi Renesas Flash Development Tool. 

To upgrade the MVX code (MVX boot code or combined MVX boot and application code) for 

the MVX-A16 card: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with a serial port 

connection or USB-to-

serial port adaptor 

If you are using a USB-to-serial port adaptor, 

download the latest drivers. 

Renesas Flash 

Development Toolkit 3.4 

Basic (FDT) 

 

The Renesas FDT must be installed and 

configured. You can find the Renesas FDT 

application on both of the Eclipse HX v14 upgrade 

media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > RenesasFDT 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > RenesasFDT  

MVX-A16 serial upgrade 

cable (Clear-Com part 

CAB-MVX-48Z) 

For an image of this cable, see 

Figure 28: MVX-A16 Serial upgrade cable. 

 

The appropriate MVX code 

file (*.fwc format for the 

separate MVX boot file, 

*.mot format for the 

combined MVX boot and 

application code file ) 

You can find the Eclipse HX-PiCo MVX code files 

on the Eclipse drivers USB: 

Drivers USB > ECLIPSE DRIVERS > Omega-

Median-Delta > xxxxxx-MVX Boot 

Drivers USB > ECLIPSE DRIVERS > Omega-

Median-Delta > xxxxxx-MVX Combined Boot 

& Application 

Where xxxxxx represents the product number. 
Table 7-3: Required equipment 

2. Install the Renesas Flash Development Toolkit 3.4 Basic (FDT). Accept the default 

install settings. 
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3. Start the Renesas Flash Development Toolkit 3.4 (FDT) from Programs, selecting 

the basic Startup option. 

4. Access the configuration (settings) dialogs, by selecting Options > New Settings...  

Configure the FDT, as shown in the table below: 

 

Settings dialog / 

option 

Setting to enter 

 

Select Device 

 

H8S/2318F 

Select Port COM1 (Change to match a COM port present on the PC) 

CPU Frequency 20.0000 Mhz 

Connection Boot mode 

Recommended Speed 38400 (Deselect the Use-Default option) 

Protection Automatic 

Messaging Advanced 

User Area Selected (Checked)  

             Table 7-4: FDT settings 

Note: The first time the FDT is run, the settings dialogs are displayed by default. After the FDT has 

been configured, the settings dialogs are no longer shown by default.  

Tip:  For more information about installing and configuring the Renesas FDT, see 

Appendix E: Hitachi Renesas Flash Development Tool. 

5. In the Download window, click Options and ensure that: 

• Auto-Disconnect is selected (checked). 

• Download File Area has User Area selected (checked). 

• The Download File radio button is selected. 

6. Select ‘…’ for the User area and select the appropriate MVX code file from the 

Eclipse HX v14 software USB. According to your requirements, select either: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx-

MVX Boot 

Where xxxxxx represents the product number. The folder contains the 

*.mot file and a Read Me file (*.txt) with version information. 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx-

MVX Combined Boot & Application 
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Where xxxxxx represents the product number. The folder contains the 

*.mot file and a Read Me file (*.txt) with version information. 

7. Upgrade / program the device: 

a. Connect the MVX serial cable (CAB-MVX-48Z) between the COM port on the PC 

and CON8 on the MVX-A16 card. 

Note: The MVX connection is polarized to ensure correct connection. 

b. On the MVX card, ensure that jumper JP1 is made. Insert the MVX card into 

the frame and verify that all LEDs are now on. 

c.  

d. Select Program Flash from the Flash Development Toolkit (FDT) program. 

e. Confirm that FDT reports the image has been written successfully. 

f. Remove the serial cable. 

g. Remove jumper JP1. 

Tip: For the location of connectors and jumpers on the MVX-A16 MK I card, see 

 Figure 7-2: MVX-A16 MK I card: J1, CON8 and CON12 

Tip: For the location of connectors and jumpers on the MVX-A16 MK II card, see 

 Figure 7-3: MVX-A16 MK II card: J1, CON8 and CON12 

8. Repeat for Step 7 for all other MVX-A16 cards in the system. 

Important note: 

If the MVX card fails to upgrade, press the Reset button on the front of the card, 

and select Program Flash from the FDT again. 

If you are using a USB-to-serial adaptor, the adaptor may have to be unplugged and 

re-plugged to enable the upgrade to start on some computers. If you are running the 

EHX application, ensure that EHX is configured for Ethernet and not serial 

connection. 
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Figure 7-2: MVX-A16 MK I card: J1, CON8 and CON12 

CON8 J1 CON12
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CON8 CON12

 

Figure 7-3: MVX-A16 MK II card: J1, CON8 and CON12 

 

7.3 Checking the MVX-A16 MK I or MK II boot and 

application code version 

You can check the MVX-A16 boot and application code versions by going to EHX> Matrix 

Event Log > Matrix Overview. 

You can also use the Firmware report tool in EHX to confirm the application code version. To 

use the Firmware report tool: 

 

1. Go to EHX> System> Layout. 

2. Right click the matrix icon. 

3. Select Firmware > Firmware report. 

To check the firmware version using Tera Term: 

1. Install Tera Term. Tera Term is available to install from both of the Eclipse HX 14 

upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > Teraterm 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 
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2. Open Tera Term and select the following port settings: 

 

 

Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 

Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow control none 
Table 7-5: Tera Term port settings 

3. Remove the MVX-A16 card to be checked from the Eclipse HX-Median / Eclipse HX-

Omega / Eclipse HX-Delta matrix.  

4. Connect the MVX serial cable (CAB-MVX-48Z) to the CON8 connector on the MVX-A16 

card and to the PC (see Figure 7-2: MVX-A16 MK I card: J1, CON8 and CON12).  

5. Reset (re-seat) the MVX-A16 card back in the Eclipse HX-Median / Eclipse HX-Omega 

/ Eclipse HX-Delta matrix. 

The MVX-A16 firmware version is the first line of the information received on Tera 

Term. 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA 

with Xilinx tools 

7.4.1 Upgrading the MVX-A16 MK1 

Note: Some very early MVX (MKI) cards may exhibit the following errors when upgrading 

the FPGA device: 

Programming failed or  

The idcode read from the device does not match the idcode in the bsdl File. 

There are two possible solutions 

a) USB cable speed : Adjust the USB cable speed, Output > Cable Setup and 

setting the TCK Speed/Baud to 1.5Mhz 

Always try this solution first for either failure mode  

b) Modify the Device ID bsdl file 

In the Xilinx installation directory, change the expected IDCODE from .bsd file.  
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To do this:  

12) Search for xc18v04.bsd in Xilinx installation directory.  

13) Change Part Number from 0101000000110110 to 0101000000100110 in the 

file. 

14) Save the file, then close and open impact. After doing this the prom is 

accessible from impact. 

Example File location: C:\Xilinx\14.5\LabTools\LabTools\xc18v00\data 

You can use the Firmware report tool in EHX to confirm the firmware version of H8 

application and FPGA code. The Firmware report tool does not provide firmware 

version information for DSP code.  

To use the Firmware report tool: 

15) Open EHX and go to System > Layout. 

16) Right click the matrix icon. 

17) Select Firmware > Firmware report. 

To upgrade the MVX FPGA with Xilinx tools: 

Note: If you experience issues while upgrading the FPGA using Xilinx tools, refer to the following 

Solution Finder article: MVX-A16 MKII/MKIII Xilinx iMPACT FPGA upgrade failure - ".cfi does 

not exist" 

1. Ensure that a compatible version of the Xilinx programming tools is installed. 
Tip:  For more information about installing the Xilinx programming tools, see 
 Appendix J:Xilinx tools. 

2. Connect the USB connector of the download cable (Xilinx HW-USB-II-G or Digilent 6003-

410-011) to the USB port of the PC. 

3. Connect the 14way IDC header to CON12 (see Figure 7-2: MVX-A16 MK I card: 

J1, CON). 

4. Power up the MVX-A16 card and start the iMPACT programming tool. 

5. In Load Project, select Cancel. 

6. In Flows, double click Boundary Scan. Right click the main window and select 

 Initialize Chain / Ctrl+ I: 

https://clear-com.atlassian.net/wiki/spaces/SF/overview
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Figure 7-4: Example iMPACT Boundary Scan 

7. If the cable is connected correctly, the application will connect and a Xilinx chip chain 

will be shown. If the cable is not connected correctly, a cable connection warning is 

given. The full chain should show two devices, as shown in the example figure 

below. 
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Figure 7-5: Example Xilinx chip chain 

8. The Assign New Configuration File dialog asks you to select an FPGA image for 

the first device in the chain or to bypass that device.  

In this example procedure, the first device will be bypassed and an FPGA image will 

be assigned to the second device. 

• For the first device, press Bypass. 

• For the second device, select the FPGA image (*.mcs format). The FPGA file is available 
from the Drivers USB and is dependent on whether the MVX Card is a Mark I or a Mark II   
: 

• MVX MK I (Green PCB) 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > 

xxxxxx – MVX MK I (Green PCB) FPGA  

(Where xxxxxx represents the product number). 

• MVX MK II (Blue PCB) 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > 

xxxxxx – MVX MK II (Blue PCB) FPGA  

(Where xxxxxx represents the product number). 
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Figure 7-6: Example Xilinx device programming properties 

9. Right click the second device and select Programming. 

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the main 

window. 

A summary dialog is presented. For all devices, ensure that the Erase Before 

Programming and Verify flags are set. Click OK. 

10. Power down the MVX-A16 card. 

MVX MKII FPGA in EHX v. 10 or 11 

If you experience issues while upgrading the FPGA using Xilinx tools, refer to the following 

Solution Finder article: MVX-A16 MKII/MKIII Xilinx iMPACT FPGA upgrade failure - ".cfi does 

not exist" 

The Xilinx upgrader will not work to upgrade the MVX MKII FPGA in EHX Version 10 or 11. 

Please see below for steps to fix the issue:  

https://clear-com.atlassian.net/wiki/spaces/SF/overview
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7.4.2 Upgrading the MVX-A16 MK2 

1. Ensure that a compatible version of the Xilinx programming tools is installed. 

 
Tip:  For more information about installing the Xilinx programming tools, see 
 Appendix J:Xilinx tools. 

2. Connect the USB connector of the download cable (Xilinx HW-USB-II-G or Digilent 6003-

410-011) to the USB port of the PC. 

3. Connect the 14way IDC header to CON12 (see Figure 7-2: MVX-A16 MK I card: 

J1, CON). 

4. Power up the MVX-A16 card and start the iMPACT programming tool (Ver 14) on the 

PC. 

5. Ensure that Xilink box shows GREEN led. (Orange Led means no connection) 

 

6. Select "No" 
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7. Select  

a. "Yes" if more upgrade is to be performed later on. 

b. "No" if this is a one off upgrade 

8. Cancel the following pop up when seen 

 

9. Double click on "Boundary Scan" on the right of the window. 
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10. In the Boundary Scan window, right click in the display and select "Initialise Chain" 

11. When asked whether to "Continue and assign configuration file(s)?" 

a. Select "No" 

12. "Cancel" the next pop up window. 

13. On the device shown on the diagram, right click on the "SPI/BPI" on top of the 

device. 

14. Select "Add SPI/BPI....." 
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15. A message, "Add PROM File" appears. Select where the .mcs file needed, and click 

Open 

16. A message "Select Attached SPI/BPI” appears. On the first drop down list on the 

right, select S25FL032P from the list, click OK. 
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17. Right click on the SPI/BPI device, it should show GREEN with the word "FLASH". 

Select Program 

18. A message "Device Programming Properties" appears. Select Device1(Attached 

Flash, S25FL032P), then click OK. 

 

19. A message "Executing command....."  appears to show the progress. 

20. On successful upgrade a message "Program Succeeded" appears. 
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21. Power down the MVX-A16 card and remove the Xilinx programming tool. 
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8 Upgrading E-FIB cards 

This chapter describes how to upgrade the E-FIB fiber cards, which are fitted to the Eclipse 

HX-Median, Eclipse HX-Omega and Eclipse HX-Delta matrices.  

Note: This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 

 3Quick reference: Upgrading to Eclipse HX. 

8.1 Upgrading E-FIB card FPGA with Xilinx tools 

If the E-FIB card FPGAs are going to be upgraded in an Eclipse HX-Median / Eclipse HX-

Omega / Eclipse HX-Delta matrix, take one of the following measures: 

• Fit the E-FIB cards to a slot which is not configured for it. 
 

• Manually reset the E-FIB card for the duration of the upgrade operation. 
 

• Remove both CPU cards from the Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta 
matrix for the duration of the upgrade. 
 

If you do not take one of the above measures then the upgrade may fail. 

To upgrade the Xilinx FPGAs (front card and rear card) on an E-FIB card: 

1. Ensure that the latest versions of the Xilinx programming tools have been installed. 

 
Tip: For more information about installing Xilinx programming tools, see 
Appendix J:Xilinx tools. 

2. Connect the USB connector of the download cable (Xilinx HW-USB-II-G or Digilent 6003-

410-011) to the USB port of the PC. 

3. Connect the 14way IDC header to: 

 

• CON8 on the front card, if you are programming both cards simultaneously or just the 
front card. 
 

• CON5 of the rear card if you are only programming the rear card. 
 

Note: The front and rear cards can be upgraded (programmed) either individually or together. If 

only the front card is being programmed, fit LK9 to the front card. 

4. Power up the UUT and start the iMPACT programming tool. 

5. In Load Project, select Cancel. 

6. In Flows, double click Boundary Scan. Right click the main window and select 

 Initialise Chain / Ctrl+ I: 
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Figure 8-1: Example iMPACT Boundary Scan 

7. If the cable is connected correctly, the application will connect and a Xilinx chip chain 

will be shown. If the cable is not connected correctly, a cable connection warning is 

given.  

If only one of the cards (the front or the rear) is being upgraded, only the first two or 

last two devices in the above chain are displayed. 

Note: The Assign New Configuration File dialog is also displayed. However, ignore this dialog 

until you have checked the chain. 

Tip: If the programming tool fails initially to recognize the adaptor or the FPGA 

chain, you can sometimes solve this issue by: 

• Pressing the reset switches by the FPGA. 

• Setting a slower cable speed. 

8. The Assign New Configuration File dialog asks you to select an FPGA image for 

the first device in the chain or to bypass that device.  

In this example procedure: 

a. Bypass the first and third devices. In the Assign New Configuration File 

dialog, press Bypass for each device. 

b. Provide the second and fourth devices (the FPGA Flashes) with images. In the 

Assign New Configuration File dialog, select the FPGA image for the 

second device, the router FPGA Flash.  

 

Go to Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > 

xxxxxx-Fibre Router (front) FPGA (where xxxxxx represents the product 

number). 
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The folder contains the FPGA file (*.mcs format) and a Read Me file (*.txt), which 
contains version information. 

 

c. Select the FPGA image for the fourth device, the networking FPGA Flash. 

 
Go to Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx-Fibre 
Networking (rear) FPGA  
(where xxxxxx represents the product number). 
 
The folder contains the FPGA file (*.mcs format) and a Read Me file (*.txt), which 
contains version information. 

9. A summary dialog is presented. For the FPGA Flash device(s), ensure that the Erase 

Before Programming and Verify flags are set. Click OK. 

 

 

 
 
 
 
 
 
 
 
 
 
 
 

                    

Figure 8-2: Example Xilinx device programming properties 

10. The upgrade (programming) starts, and takes approximately 2 minutes to complete. 

When the upgrade is complete, the Program Succeeded message is displayed in 

the main window. 

11. Ensure that a compatible version of the Xilinx programming tools.. 

12. Remove the Xilinx programmer, and update any other E-FIB cards in the matrix. 

13. Reseat the E-FIB cards and check that the card’s front LEDs show no errors. 
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9 Upgrading E-QUE cards 

The following chapter describes how to upgrade E-QUE cards (both MK1 and MK2).  

Note: This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 3 Quick reference: 

Upgrading to Eclipse HX. 

9.1 Identifying MK1 and MK2 E-QUE cards 

To identify the E-QUE card as a MK1 or a MK2 card, run a firmware report in EHX. To use 

the Firmware report tool: 

a. Go to EHX> System> Layout . 

b. Right click the matrix icon. 

c. Select Firmware > Firmware report. 

You can also identify MK 1 and MK 2 cards visually. 

The MK 1 E-QUE card is green. It also features a large chip in the upper right hand corner 

of the PCB (as it is installed in the matrix): 

 

Figure 9-1: MK 1 E-QUE card detail 

The MK2 E-QUE card is blue. The large chip no longer forms part of the PCB: 

 

 

 

 

 

Figure 9-2: MK 2 E-QUE card detail 
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9.2 Upgrading the E-QUE card (MK1 and MK2) via EHX 

You can now upgrade the IVC/LMC64/EQue cards via EHX and an integrated TFTP server. 

Previously a card upgrade would have to be started via the serial port and performed on 

each card individually. EHX can now host the required files and push the upgrade to all valid 

cards. 

The following conditions apply: 

• You must have an IP connection with a valid, unique IP address on each 

IVC/LMC64/EQue card. 

• Make sure that there is no TFTP server already running on the EHX PC. 

• Make sure that the PC’s firewall allows TFTP traffic 

• Make sure that you do not remove the card or interrupt its power supply during the 

upgrade. Otherwise, you might have to connect the card via a serial port and 

perform the upgrade via the existing method. There is also no way to inform the user 

of the progress of the upgrade. The only way to gain information about the card’s 

state is to look at the event log and firmware report. 

The upgrade can be triggered in one of two ways. Either via the Apply Firmware dialog in 

the tools menu or via the Apply firmware wizard to upgrade the cards in an individual 

Matrix. In both cases the users are displayed the following two warning messages: 
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Note: Do not download any map changes during the upgrade process. 

 

Progress will be reported in the Event Log. Do not reset the matrix until the update is 

complete. 

9.3 Upgrading the E-QUE card (MK1) via serial cable 

and third-party TFTP tools 

You must upgrade the E-QUE card (MK1) in the following order: 

1. E-QUE card application code (using the procedure described in this section). 

Note: An MVX upgrade cable is required. The procedure also requires an 

Ethernet connection between the E-QUE card and the PC. If the 

card and the PC are not connected to the network, they can be 

connected directly using a crossover Ethernet cable.  

2. E-QUE card FPGA code (see 9.5 Upgrading the E-QUE card (MK1 and MK2) FPGA with 
Xilinx tools). 

Note: Requires specialized equipment. For more information about 

installing and using Xilinx programming tools, see Appendix 

J:Xilinx tools. 

3. E-QUE card (MK1) Boot PROM (if required) (see 9.6 Upgrading the E-QUE card (MK1) boot 
ROM). 
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Figure 9-3: E-QUE upgrade 

To upgrade the application code of the E-QUE card (MK1): 

1. Ensure that you have the following equipment:  

 

Required equipment Description / comments 

Tera Term software Tera Term must be configured and operational. 

You can find the Tera Term application on both of 

the Eclipse HX 14 upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 

 

TFTP Server software - 

MVX Serial cable (CAB-

MVX-48Z) 

See Figure 9-4: MVX-A16 serial cable (CAB-

MVX-48Z) 

Ethernet crossover cable - 

Small reset tool  For example, a bent paper clip 
Table 9-1: Required equipment 

MVX cable connected to the 

E-QUE front card. 

Ethernet Crossover cable from PC LAN port 

>  

E-QUE rear card LAN connector.  
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Figure 9-4: MVX-A16 serial cable (CAB-MVX-48Z) 

2. Install Tera-Term. Third party software is available from either of the Eclipse HX 14 

upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > Teraterm 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 

Tip: For more information about installing Tera Term, see Appendix G: Tera Term  

3. Create a directory on your PC called c:\tftp. 

4. Navigate to either of the following folders: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > EQue TFTP Server App 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > EQue TFTP Server App 
 

          Open the folder. Copy tftpserv.exe into the c:\tftp directory. 

Note: 

Any TFTP server can be used as long as it points to the C:\TFTP folder. 
5. Navigate to the following folder on the software USB: 
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• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx- E-Que application 
MK-I & MK-II (where xxxxxx represents the product number) 
 

Open the folder. Copy the E-QUE software file (*.image format file) into the c:\tftp directory. 
 

6. From the same folder, copy the Tera Term macro file combined_eque_upgrade.ttl. 
 

7. Start Tera Term. Open the Setup menu and select Serial Port…. 
 

 
 

Figure 9-5: Tera Term: selecting Serial Port 

8. In the Serial port configuration dialog, enter the following settings: 
 

Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 

Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow control none 

Transmit delay 0 msec/char. If the E-QUE card fails to load correctly, change 

this value to 50ms. 
Table 9-2: Tera Term port settings 

9. Set the IP address of your PC to a fixed / static address (any IP address of your choice is 
suitable). 

10. Navigate to the c:\tftp directory. To open the TFTP Server command window, double click the 
application tftpsrv.exe. 
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Figure 9-6: TFTP Server Window 

Note:  
The TFTP application can only access files in the same folder as the TFTP application. The E-
QUE firmware file must be in the same directory as the tftpsrv.exe program. 
 

11. Connect the MVX serial cable (CAB-MVX-48Z) between the PC serial port and the E-QUE card 
CON-200. 
 
Reinsert the E-QUE card into the rack.  

 
Figure 9-7: E-QUE MK1 card serial connector 
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12. If it is not already powered up, power up the Eclipse HX-Median / Eclipse HX-Omega / Eclipse 
HX-Delta matrix.  
 

13. Ensure that the E-QUE card and the PC are both connected to the Ethernet network in some 
way, or are connected using a crossover Ethernet cable. 
 
The LAN connector on the E-QUE card is the highest RJ-45 socket on the back panel. When the 
E-QUE card is connected to the PC or to the network, check that the LAN LEDs (the yellow and 
green lights at the bottom of the card) are flashing occasionally, indicating a network connection.  

14. In Tera Term, select Control > Macro and then navigate to the c:\tftp directory. Open 
combined_eque_upgrade.ttl and follow the macro instructions. 
 
Note: 

The macro should reset and re-boot the E-QUE card automatically. However, if it does not, you 
may have to reset the E-QUE card using the reset button on the front. The reboot should be seen 
on the serial console. This reset is essential, as it permits Tera Term to interrupt the boot 
process. 

15. The Macro will detect the card as an MKI. You will be prompted to verify the card has a green 
PCB by the macro. If the card is Blue, it is a MKII. 
 

16. Enter the following information to enable the download:  
 

a. Enter an IP address for the E-QUE card. This address must be in the same range as 
your PC IP address (for example, 192.168.42.5). 

 
b.  Enter your PC IP address (for example,192.168.42.1) 

 
c. Enter the name of the E-QUE card firmware file. This will be the *.IMAGE file copied 

in step 5. 
 

17. The application code downloads to the E-QUE card. When the download is complete, the 
E-QUE card reboots. 
 
Note:  
If when downloading file, T T T T is displayed on the Tera Term serial screen, this indicates a 
problem downloading the file.  Check the network connection and the IP addresses that were 
entered. Also check that the filename has no file extension. 
 
Tip: On the Tera Term screen towards the end of the boot sequence messages there will be a 
status message that shows a date stamp and version string. Check this string to verify the 
firmware version. 

9.4 Upgrading the E-QUE card (MK2) via serial cable 

and third-party TFTP tools 

You must upgrade the E-QUE card (MK 2) in the following order: 

1. E-QUE card application code (using the procedure described in this section). 
 
Note: 
An MVX upgrade cable is required. The procedure also requires an Ethernet connection between 
the E-QUE card and the PC. If the card and the PC are not connected to the network, they can be 
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connected directly using a crossover Ethernet cable.  
 

2. E-QUE card FPGA code (see 9.5 Upgrading the E-QUE card (MK1 and MK2) FPGA with 
Xilinx tools). 
 
Note: 
Requires specialized equipment. For more information about installing and using Xilinx 
programming tools, see Appendix J:Xilinx tools. 
 

3. E-QUE card (MK2) Boot PROM (if required) (see 9.7 Upgrading the E-QUE card (MK2) boot 
ROM). 

 

 

 

 

 

 

 

 

 

Figure 9-8: E-QUE upgrade 

 

To upgrade the firmware file / application code of the E-QUE card (MK2): 

1. Ensure that you have the following equipment:  

 

Required equipment Description / comments 

Tera Term software Tera Term (version 4.3 or later) must be 

configured and operational. You can find the Tera 

Term application on both of the Eclipse HX 14 

upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 

 

TFTP Server software - 

MVX cable connected to the 

E-QUE front card. 

Ethernet Crossover cable from PC LAN port 

>  

E-QUE rear card LAN connector.  
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MVX Serial cable (CAB-

MVX-48Z) 

See Figure 9-4: MVX-A16 serial cable (CAB-

MVX-48Z) 

Ethernet crossover cable - 

Small reset tool  For example, a bent paper clip 
Table 9-3: Required equipment 

 

 
 

 
Figure 9-9: MVX-A16 serial cable (CAB-MVX-48Z) 

2. Install Tera-Term. Third party software is available from either of the Eclipse HX 14 upgrade 

media: 
 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > Teraterm 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 
 

Tip: For more information about installing Tera Term, see Appendix G: Tera Term  
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3. Create a directory on your PC called c:\tftp. 
 

4. Navigate to either of the following folders: 
 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > EQue TFTP Server App 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > EQue TFTP Server App 

5. Open the folder. Copy tftpserv.exe into the c:\tftp directory. 
Note: 

Any TFTP server can be used as long as it points to the C:\TFTP folder. 

5. Navigate to the following folder on the software USB: 

 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx - E-Que application 
MK-I & MK-II (where xxxxxx represents the product number) 
 

Open the folder. Copy the E-QUE firmware file (*.image format file) into the c:\tftp directory. 
 

Tip: The folder also contains a Read Me file (*.txt), which includes the procedure for 

upgrading the E-QUE firmware file. 

 
6. From the same folder, copy the Tera Term macro file combined_eque_upgrade.ttl to the c:\tftp 

directory. 
 

7. Start Tera Term. Open the Setup menu and select Serial Port…. 
 

 
 

Figure 9-10: Tera Term: selecting Serial Port 

8. In the Serial port configuration dialog, enter the following settings: 
 

Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 
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Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow control none 

Transmit delay 0 msec/char. If the E-QUE card fails to load correctly, change 

this value to 50ms. 
Table 9-4: Tera Term port settings 

9. Set the IP address of your PC to a fixed / static address (any IP address of your choice is 
suitable). 
 

10. Navigate to the c:\tftp directory. To open the TFTP Server command window, double click the 
application tftpsrv.exe. 
 

 
 

Figure 9-11: TFTP Server Window 

Note:  
The TFTP application can only access files in the same folder as the TFTP application. The E-
QUE firmware file must be in the same directory as the tftpsrv.exe program. 
 

11. Connect the MVX serial cable (CAB-MVX-48Z) between the PC serial port and the E-QUE card 
(MK2) CON-2200. 
 
Reinsert the E-QUE card (MK2) into the rack:  
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Figure 9-12: E-QUE card (MK2) serial connector 

12. Power up the Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix (if not already 
powered up).  
 

13. Ensure that the E-QUE card (MK2) and the PC are either: 
 

• Connected to your Ethernet network. 
 

• Directly connected using a crossover Ethernet cable. 
 
The LAN connector on the E-QUE card is the highest RJ-45 socket on the back panel. When the 
E-QUE card is connected to the PC or to the network, check that the LAN LEDs (the yellow and 
green lights at the bottom of the card) are flashing occasionally, indicating a network connection. 

14. In Tera Term, select Control > Macro and then navigate to the c:\tftp directory. Open 
combined_eque_upgrade.ttl and follow the macro instructions. 
 
Note: 

The macro should reset and re-boot the E-QUE card automatically. However, if it does not, you 
may have to reset the E-QUE card using the reset button on the front. The reboot should be seen 
on the serial console. This reset is essential, as it permits Tera Term to interrupt the boot 
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process. 
 

15. If the reset is successful, the following dialog is displayed:  
 

 
 

Figure 9-13: E-QUE (MK2) successful reset dialog 

To continue, click OK. 
 
 
Note:  
If the reset and reboot is not successful, the following error message is displayed: 
 

 
 

Figure 9-14: E-QUE (MK2) reset error message 

If you receive this message, you are advised to repeat the procedure from Step 6. 
 

16. The boot countdown appears again on the serial console. Tera Term recognizes that the card has 
rebooted and you are asked to enter the following information to enable the download:  
 

a. Enter an IP address for the E-QUE card. This address must be in the same range as 
your PC IP address (for example, 192.168.42.5). 

 
b.  Enter your PC IP address (for example,192.168.42.1). 

 
c. Enter the file name of the E-QUE card application code (firmware) (for example, 

eque_release_image-3.16.5.0). 
 

d. Enter the Gateway IP address or accept the default (10.50.16.1). 
 

e. Enter the Subnet Mask or accept the default (255.255.255.0). 
 

The application code downloads to the E-QUE card (MK2). When the download is complete, the 
E-QUE card (MK2) reboots. 
 
Note:  
If when downloading file, T T T T is displayed on the Tera Term serial screen, this indicates a 
problem downloading the file.  Check the network connection and the IP addresses that were 
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entered.  
 

17. If the download is successful, the following dialog is displayed by Tera Term: 
 

 
Figure 9-15: Successful download dialog 

To exit the macro, click OK. 
 
Note: 

If the download was not successful, the following error dialog is displayed by Tera Term: 
 

 
Figure 9-16: Failed download dialog 

If you receive this message, you are advised to repeat the procedure from Step 6. 
 

9.5 Upgrading the E-QUE card (MK1 and MK2) FPGA 

with Xilinx tools 

Note: Upgrading the E-QUE card FPGA using Xilinx tools requires specialized equipment. For more 

information about the Xilinx programming tools, see Appendix J:Xilinx tools. 

To upgrade the E-QUE card FPGA code with Xilinx tools: 

1. Ensure that the latest versions of the Xilinx programming tools have been installed. 

2. Connect the USB connector of the download cable (Xilinx HW-USB-II-G or Digilent 6003-

410-011) to the USB port of the PC. 

3. Connect the 14way IDC header to CON3100. 

4. Insert the E-Que card into the matrix and start the iMPACT programming tool. 

5. In Load Project, select Cancel. 

6. In Flows, double click Boundary Scan. Right click the main window and select 

Initialize Chain / Ctrl+ I: 
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Figure 9-17: iMPACT Boundary Scan 

 

7. If the cable is connected correctly, the application will connect and a Xilinx chip chain 

will be shown. If the cable is not connected correctly, a cable connection warning is 

given.  

 
Figure 9-18: Example Xilinx chip chain 
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8. The Assign New Configuration File dialog asks you to select an FPGA image for 

the first device in the chain or to bypass that device.  

In this example procedure, the first device will be bypassed and an FPGA image will 

be assigned to the second device. 

• For the first device, press Bypass. 

• For the second device, select the FPGA image (*.mcs) from the Drivers USB: 
 
Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx – EQUE FPGA  

(where xxxxxx represents the product number). 

A summary dialog is presented. Ensure that the Erase Before Programming and 

Verify flags are set. Click OK. 

 

 

 
 

Figure 9-19: Example Xilinx device programming properties 

9. Right click the second device and select Programming. 

 

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the main 

window. 

10. Remove the Xilinx programming tool and carefully re-insert the E-Que card into the 

matrix. 

9.6 Upgrading the E-QUE card (MK1) boot ROM 
 

Only upgrade the E-QUE (MK1) boot ROM after the main E-QUE application code has been 

upgraded.  
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Note: 

The procedure below is for E-QUE (MK1) cards only. To upgrade the PROM of an E-QUE card 

(MK2), see 9.7 Upgrading the E-QUE card (MK2) boot ROM. 

To upgrade the E-QUE card (MK1) boot PROM: 

1. Ensure that you have the required equipment: 

 

• 2 MBit PROM device (ST M27W201 or equivalent). 
 

• PROM programming unit and PROM programming software appropriate for that unit. 
 

• Appropriate ‘S’ record file. To find the file, go to: 
Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx – E-Que MKI 
(Green PCB) Boot ROM (where xxxxxx represents the part number). 
. 
The folder contains the *.s record file and a Read Me file (*.txt), with version information. 

2. Ensure that the PROM device to be programmed is empty. 

3. Program the PROM device with the appropriate file, according to the instructions for 

the PROM programmer being used. 

Note: 

The load address for the S record is 0xFFF00000. 

Confirm that the checksum of the programmed device matches that detailed in the 

Eclipse HX Release Notes. 

4. Remove the existing PROM device from the configuration card. 

Insert the newly programmed PROM device taking care to ensure the correct polarity 

of the device. 

 

 

Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 

 

9.7 Upgrading the E-QUE card (MK2) boot ROM 
Only upgrade the E-QUE (MK2) boot ROM after the main E-QUE application code has been 

upgraded.  

Note: The procedure below is for E-QUE (MK2) cards only. To upgrade the PROM of an E-QUE card 

(MK2), see 9.6 Upgrading the E-QUE card (MK1) boot ROM. 

To upgrade the E-QUE (MK2) boot PROM: 

1. Ensure that you have the following equipment:  

 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 204 of 315   

 

 

 

 

Required equipment Description / comments 

Tera Term software Tera Term must be configured and operational. 

You can find the Tera Term application on both of 

the Eclipse HX 14 upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 

 

TFTP Server software - 

MVX Serial cable (CAB-

MVX-48Z) 

See Figure 9-4: MVX-A16 serial cable (CAB-

MVX-48Z) 

Ethernet crossover cable - 

Small reset tool  For example, a bent paper clip 
Table 9-5: Required equipment 

2. Install Tera Term. 

Tip: For more information about installing Tera Term, see Appendix G: Tera Term  

3. Create a directory on your PC called c:\tftp. 
4. Navigate to either of the following folders: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > EQue TFTP Server App 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > EQue TFTP Server App 
 

             Open the folder. Copy tftpserv.exe into the c:\tftp directory. 

Note: Any TFTP server can be used as long as it points to the C:\TFTP 

folder. 

5. Navigate to Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx – E-Que 
MKII (Blue PCB) Boot ROM  

(where xxxxxx represents the product number). 

Open the folder. Copy the E-QUE (MK2) boot ROM file into the c:\tftp directory. 
 

6. From the same folder, copy the Tera Term macro file EQ2_uboot_upgrade.ttl to the c:\tftp 
directory. 

7. Start Tera Term. Open the Setup menu and select Serial Port…. 
 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 205 of 315   

 

 

 

 

 
Figure 9-20: Tera Term: selecting Serial Port 

8. In the Serial port configuration dialog, enter the following settings: 

Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 

Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow control none 

Transmit delay 0 msec/char. If the E-QUE card fails to load correctly, change 

this value to 50ms. 
Table 9-6: Tera Term port settings 

9. Set the IP address of your PC to a fixed / static address (any IP address of your choice is 
suitable). 

10. Navigate to the c:\tftp directory. To open the TFTP Server command window, double click the 
application tftpsrv.exe. 
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Figure 9-21: TFTP Server Window 

Note:  
The TFTP application can only access files in the same folder as the TFTP application. The E-
QUE MK2 boot ROM file must be in the same directory as the tftpsrv.exe program. 
 

11. Connect the MVX serial cable (CAB-MVX-48Z) between the PC serial port and the E-QUE card 
(MK2) serial connector (CON-2200): 
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Figure 9-22: E-QUE card (MK2) serial connector 

12. Reinsert the E-QUE card (MK2) into the rack. 
 

13. Power up the Eclipse HX-Median / Eclipse HX-Omega matrix / Eclipse HX-Delta matrix (if it is not 
already powered up).  
 

14. Ensure that the E-QUE card (MK2) and the PC are either: 
 

• Connected to your Ethernet network. 
 

• Directly connected using a crossover Ethernet cable. 
 
The LAN connector on the E-QUE card is the highest RJ-45 socket on the back panel. When the 
E-QUE (MK2) card is connected to the PC or to the network, check that the LAN LEDs (the 
yellow and green lights at the bottom of the card) are flashing occasionally, indicating a network 
connection. 

15. In Tera Term, select Control > Macro and then navigate to the c:\tftp directory. Open 
EQ2_uboot_upgrade.ttl and follow the macro instructions. 
 
Note: 
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The macro should reset and re-boot the E-QUE card (MK2) automatically. However, if it does not, 
you may have to reset the E-QUE card (MK2) using the reset button on the front. The reboot 
should be seen on the serial console. This reset is essential, as it permits Tera Term to interrupt 
the boot process. 
 

16. If the reset is successful, the following dialog is displayed:  
 

 
 

Figure 9-23: E-QUE (MK2) successful reset dialog 

To continue, click OK. 

 

Note:  
If the reset and reboot is not successful, the following error message is displayed: 
 

 
 

Figure 9-24: E-QUE (MK2) reset error message 

If you receive this message, you are advised to repeat the procedure from Step 6. 
 

17. The boot countdown appears again on the serial console. Tera Term recognizes that the card has 
rebooted and you are asked to enter the following information to enable the download:  
 

a. Enter an IP address for the E-QUE card. This address must be in the same range as 
your PC IP address (for example, 192.168.42.5). 

 
b.  Enter your PC IP address (for example,192.168.42.1). 

 
c. Enter the file name of the E-QUE card application code (firmware) (for example, 

eque_release_image-3.16.5.0). 
 

d. Enter the Gateway IP address or accept the default (10.50.16.1). 
 

e. Enter the Subnet Mask or accept the default (255.255.255.0). 
 

The application code downloads to the E-QUE card (MK2). When the download is complete, the 
E-QUE card (MK2) reboots. 
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Note:  
If when downloading file, T T T T is displayed on the Tera Term serial screen, this indicates a 
problem downloading the file.  Check the network connection and the IP addresses that were 
entered.  
 

17. If the download is successful, the following dialog is displayed by Tera Term: 
 

 
        Figure 9-25: Successful download dialog 

To exit the macro, click OK. 
 
Note: 

If the download was not successful, the following error dialog is displayed by Tera Term: 
 

 
            Figure 9-26: Failed download dialog 

If you receive this message, you are advised to repeat the procedure from Step 6. 
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10 Upgrading IVC-32 and LMC-64 cards 

To upgrade IVC-32 and LMC-64 cards, follow the same upgrade procedures for E-QUE cards 

(MK1), as described in 9 Upgrading E-QUE cards.  

At EHX v14, the application code for all 3 cards (E-QUE, IVC-32 and LMC-64 cards) is the 

same. 

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 3 Quick reference: 

Upgrading to Eclipse HX. 

10.1 Identifying MK1 and MK2 IVC-32 / LMC-64 cards 

To find out if the IVC-32 / LMC-64 card is either a MK 1 or a MK 2 card, run a firmware 

report in EHX. The firmware report identifies the card as either a MK 1 or a MK 2 card. 

To use the Firmware report tool: 

a. Go to EHX> System> Layout . 

 

b. Right click the matrix icon. 

 

c. Select Firmware > Firmware report. 

You can also identify MK1 and MK2 cards visually. 

The MK1 IVC-32/LMC-64 card is green. It features a large chip in the upper right hand 

corner of the PCB (as it is installed in the matrix): 

 

Figure 10-1: IVC-32/LMC-64 MK1 card detail 

The MK2 IVC-32/LMC-64 card is blue. If you look at the upper right hand corner of the 

card, the large chip no longer forms part of the PCB: 
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Figure 10-2: IVC-32/LMC-64 MK2 card detail 
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11 Upgrading E-MADI64 cards 

This chapter describes how to upgrade MK1 E-MADI64 cards. The following E-MADI64 code 

can be upgraded: 

• The boot code file (*.mot), which is upgraded using the Renesas Flash Development Toolkit 3.4 
Basic (FDT). 
 

• The application code and DSP code files (*.fwc), which are upgraded using EHX. 
  

• The FPGA code, which is upgraded using either EHX or Xilinx iMPACT programming software.  
 

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

11.1 Identifying MK1 and MK2 E-MADI64 cards 

Note: this chapter only describes how to update MK1 E-MADI64 cards. 

To identify the E-MADI64 card as a MK1 or a MK2 card, run a firmware report in EHX. To 

use the Firmware report tool: 

a. Go to EHX> System> Layout . 

b. Right click the matrix icon. 

c. Select Firmware > Firmware report. 

You can also identify MK 1 and MK 2 cards visually. 
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The MK 1 E-MADI64 card is blue or green: 

 

Figure 11-1: MK 1 E-MADI64 card detail 

The MK2 E-QUE card is blue: 

 

Figure 11-2: MK 2 E-MADI64 card detail 
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11.2 Upgrading the E-MADI64 boot code 

To upgrade the E-MADI64 card H8 boot code: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with a serial port 

connection or USB-to-serial 

port adaptor 

If you are using a USB-to-serial port adaptor, 

download the latest drivers. 

Renesas Flash 

Development Toolkit 3.4 

Basic (FDT) 

 

The Renesas FDT must be installed and 

configured. The Renesas FDT application is 

available from both Eclipse HX v14 upgrade 

media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > RenesasFDT 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > RenesasFDT 

 

MVX-A16 serial upgrade 

cable (Clear-Com part 

CAB-MVX-48Z) 

For an image of this cable, see 

Figure 28: MVX-A16 Serial upgrade cable. 

 

The E-MADI64 card H8 

boot code file (*.mot): 

 

The E-MADI64 card boot code file (*.mot) is 

available from the following folder: 

 

Drivers USB > ECLIPSE DRIVERS > Omega-

Median-Delta > xxxxxx – E-MADI Boot  

(Where xxxxxx represents the product number). 
Table 11-1: Required equipment 

 

2. Install the Renesas Flash Development Toolkit (FDT), which is available from either 

of the Eclipse HX v14 upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > 

RenesasFDT 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > 

RenesasFDT 

Accept the default install settings. 

3. Start the Renesas Flash Development Toolkit (FDT) from Programs, selecting the 

basic Startup option. 
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4. Access the configuration (settings) dialogs, by selecting Options > New Settings...  

Configure the FDT, as shown in the table below: 

 

Settings dialog / 

option 

Setting to enter 

 

Select Device 

 

H8S/2318F 

Select Port COM1 (Change to match a COM port present on the PC) 

CPU Frequency 25.0 Mhz 

Connection Boot mode 

Recommended Speed 38400 (Deselect the Use-Default option) 

Protection Automatic 

Messaging Advanced 

User Area Selected (Checked)  

Readback verification Yes 

Table 11-2: FDT settings 

Note:  

The first time the FDT is run, the settings dialogs are displayed by default. After the 

FDT has been configured, the settings dialogs are no longer shown by default.   

 

5. In the Download window, click Options and ensure that: 

 

• Auto-Disconnect is selected (checked). 

• The Download File radio button is selected. 

 

6. Select ‘…’ for the User area and select the appropriate *.mot format file for the E-

MADI64 H8 boot code. 

 

The EMADI64 boot code file is available from the Drivers USB: 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx-E-MADI 

Boot  

(where xxxxxx represents the product number). 

 

7. On the E-MADI64 card to be updated, ensure that jumper J1000 is made. 
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Figure 11-3: E-MADI64 PCB (upper right hand corner) 

 

8. Connect the MVX serial cable (CAB-MVX-48Z) between the COM port on the PC and the 

CON1001 on the E-MADI64 card to be updated. 

 

See Figure 11-3: E-MADI64 PCB (upper right hand corner) above. 

 

Note:  

The E-MADI64 connection is polarized to ensure a correct connection. 

 

9. Insert the E-MADI64 card into the Eclipse HX-Median / Eclipse HX-Omega / Eclipse 

HX-Delta matrix (having ensured that the matrix is powered on). 

 

10. Select Program Flash from the FDT. Confirm that FDT reports the image has been 

written successfully. 

 

Important note: 

If the E-MADI64 card fails to upgrade, reset (re-seat) the E-MADI64 card and select 

Program Flash from the FDT again. 

 

If you are using a USB-to-serial adaptor, the adaptor may have to be unplugged and 

re-plugged to enable the upgrade to start on some computers. If you are running the 

EHX application, ensure that EHX is configured for Ethernet and not serial 

connection. When the upgrade is complete, you can also do the following: 
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1. Remove the E-MADI64 card from the matrix. 

2. Remove the MVX serial cable (CAB-MVX-48Z). 

3. Remove jumper J1000. 

4. Repeat steps 7 through 11 for each remaining E-MADI64 card. 

11.3 Upgrading the E-MADI64 application, DSP and 

FPGA code using EHX 

You can upgrade the E-MADI64 application, DSP and FPGA code using EHX and an Eclipse 

matrix. If you are using an Ethernet connection, an EHX configuration map is required with 

the correct IP address configured. 

Note: 

With E-MADI64, you can upgrade the FPGA code in exactly the same way as the application 

and DSP code. 

*.fwc format files are used in the download of the E-MADI64 application code, the DSP 

code, and the FPGA code. The Drivers USB contains the E-MADI64 application and DSP 

code: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > E-MADI Application 
 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > E-MADI DSP 
 

The Drivers USB contains the E-MADI64 FPGA code: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > E-MADI FPGA 
 

Place the application, DSP and FPGA code files in a location that EHX can access. When 

these files are downloaded to the matrix, all the E-MADI64 cards that have been fitted to 

the matrix will be upgraded. 

Note – Once the firmware is downloaded from EHX to the CPU card it can take between 45 – 

60 minutes to transmit this image to the MADI cards (depending on the number of cards 

that are inserted and therefore receiving the image in parallel). Please use the matrix event 

log of the matrix frame to monitor the percentage complete state of the image 

transmission. Allow the card to automatically reboot at the end of upgrade as the image has 

to be copied to permanent storage on the card after it has been received. 

Tip: For help with selecting the other procedures you require for upgrading to Eclipse HX 

v14, see the quick reference procedures tables in 2  Selecting Upgrade Procedures. 
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To upgrade E-MADI64 H8, DSP or FPGA code using EHX: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet or 

serial communications 

port 

- 

EHX software EHX must be installed and configured. 

Ethernet or serial cable for 

the PC-to-matrix 

connection 

- 

H8 application code, DSP 

and FPGA code files 

The appropriate application code, DSP code and 

FPGA code files (*.fwc format) are available from 

the Eclipse HX v14 upgrade media: 

 

• Drivers USB > ECLIPSE DRIVERS > Omega-
Median-Delta > E-MADI Application 

 

• Drivers USB > ECLIPSE DRIVERS > Omega-
Median-Delta > E-MADI DSP 

 

• Drivers USB > ECLIPSE DRIVERS > Omega-
Median-Delta > E-MADI FPGA. 

 

Table 11-3: Required equipment 

2. Start EHX on the PC. 

 

3. Connect the PC to the matrix using either Ethernet or a serial communications port. 

 

4. Open the EHX configuration map within EHX. 

 

5. Select System > Layout. 

 

6. Right click the matrix and then select Firmware> Update Firmware. 

The Update Firmware wizard dialog is displayed. Click Next. 

 

In the Select Hardware Type screen, ensure that the Card radio button is 

selected. 
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Figure 11-4: Select Hardware Type 

7. Click Next and then browse to the E-MADI64 code file (application, DSP or FPGA 

code files (*.fwc)). 

 

Tip: See Step 1 for the location of the .fwc files on the Eclipse HX v14 USB. 

 

8. Click Next and confirm that the details displayed are correct. 

 

9. Click Next and confirm that the download commences. 

 
Note: 

The E-MADI64 card status light flashes green while the upgrade is in process (LED 

on to off ratio: 1:4 at 0.5Hz). When the upgrade is complete, the status light is lit 

green at a steady heartbeat (LED on to off ratio: 1:1 at 1 Hz). 

 

10. When the download has completed, click Finish to close the update firmware wizard. 

 

11. Ensure that the E-MADI64 cards reset once the download is complete. All the cards 

are upgraded at the same time. 

 

Code Approx. reset time 

Application 1 minute 

DSP 3 minutes 

FPGA 18 minutes 

Table 11-4: Approximate reset times per system 

12. Confirm the updated firmware version by opening EHX and going to  

Matrix event log > Matrix overview. 

 

Note: 

You can also use the Firmware report tool in EHX to confirm the firmware version for 

the H8 boot code (see the previous procedure), H8 application code and FPGA. 

However, the Firmware report tool does not provide firmware version information for 

DSP code.  
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To use the Firmware report tool: 

 

a. Open EHX and go to System > Layout. 

 

b. Right click the matrix icon. 

 

c. Select Firmware > Firmware report. 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool 

set 
Note: 

Upgrading the E-QUE card FPGA using Xilinx tools requires specialized equipment. For more 

information about the Xilinx programming tools, see Appendix J:Xilinx tools. 

Note: 

Ensure that the Xilinx tool set is Version 11 or later. 

To upgrade the Xilinx FPGAs on an E-MADI64 card: 

1. Ensure that the latest versions of the Xilinx programming tools have been installed. 

 
Tip: For more information about installing Xilinx programming tools, see 
Appendix J:Xilinx tools. 
 

2. Obtain the latest version of the Xilinx device firmware from the Drivers USB: 

 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx - E-MADI 

FPGA > xxxxxx.mcs and xxxxxx.cfi 

Where xxxxxxx represents the product / file number. 

Note: 

When upgrading the E-MADI64 FPGA, both the *.mcs and *.cfi file are required. The 

*.cfi and *.mcs file are available from the same location. The user does not have to 

do anything else, as the tools find the files. 

 

3. Connect the USB connector of the download cable (Xilinx HW-USB-II-G or Digilent 6003-

410-011) to the USB port of the PC. 

 

4. Connect the 14way IDC header to CON4000. 

 

5. Power up the UUT and start the iMPACT programming tool. 
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6. In Automatically create and save a project, select No. 

 

7. In Load Project, select Cancel. 

8. In Flows, double click Boundary Scan. Right click the main window and select 

 Initialise Chain / Ctrl+ I: 

 
Figure 11-5: Example iMPACT Boundary Scan 

9. If the cable is connected correctly, the application will connect and a Xilinx chip chain 

will be shown. If the cable is not connected correctly, a cable connection warning is 

given.  
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Figure 11-6: Example Xilinx chip chain 

10. In the Auto Assign Configuration Files Query dialog, select Yes. 

11. The Assign New Configuration File dialog asks you to select an FPGA image for 

the first device in the chain or to bypass that device. 

 

In this example procedure, the first device will be bypassed and an FPGA image will 

be assigned to the second device. 

 

• For the first device, press Bypass. 
 

• For the second device, select the FPGA image: 
 
Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx - E-MADI FPGA 
> xxxxxx.mcs and xxxxxx.cfi 
 
Where xxxxxx represents the product / file number. 

Note: 

When upgrading the E-MADI64 FPGA, both the *.mcs and *.cfi file are required. The 

*.cfi and *.mcs file are available from the same location. The user does not have to 

do anything else, as the tools find the files. 

 

12. A summary dialog is presented. For the selected device, ensure that the Erase the 

Entire Device and Verify flags are set. Click OK. 
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Figure 11-7: Example Xilinx device programming properties 

13. In Impact Processes, double click program. 

The upgrade (programming) starts, and takes approximately 2 minutes to complete. 

When the upgrade is complete, the Program Succeeded message is displayed in 

the main window. 

14. Remove the Xilinx programmer from the E-MADI card and carefully re-insert the card 

into the matrix. 
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12 Upgrading E-DANTE64-HX cards 

Upgrades for your E-DANTE64-HX card are available for both EHX and Dante firmware and 

are available from your Clear-Com representative. 

The upgrade process for each of the two modules on the card (EHX and Dante) is different. 

The two processes are outlined below.  

Note: When upgrading your E-Dante64 card, only use the Clear-Com supplied upgrade files for 

both  

(A: EHX) ClearCom - App, Boot, DSP, FPGA:  xxxxxx.FWC files  

(B: Dante) ClearCom [Brooklyn]: xxxxxx.dnt file.  

To check if your firmware is up to date, open the Firmware Report in 

EHX: 

1) In the EHX software, navigate to the Layout tab. 

2) Right click on the required matrix and select Firmware/Firmware Report. 

 

12.1.1 Upgrade EHX E-DANTE64 firmware 

1) In the EHX software, navigate to the Layout tab.  

2) Right click on the matrix to be upgraded and select Firmware > Update 

Firmware > Card.  
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3) Navigate to where the E-Dante64 upgrade file is stored and click to upload.  

 

There are 4 possible upgrade file types. 

Upgrade file type Approximate upgrade time/notes 

App.FWC 2 min. This is the most common file to 

upgrade and is usually labeled 

‘Clearcom’. 

Boot.FWC 1 min. 

DSP.FWC 3 min. Reset card on front panel after 

upgrade. 

FPGA.FWC 16 mins. 

 

While the E-DANTE64 card is being upgraded with EHX firmware, the active light (green) on 

the front of the device will flash at double its usual speed and the error light (red) will show. 

The card is ready for use when the error light is off and the status light has returned to a 

steady 1Hz pulse.  

 

 

Note: The upgrade process for an E-DANTE64 card is the same as a MADI card. If you need more 

detailed information, see 11 Upgrading E-MADI64 cards). 
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12.1.2 Upgrade Dante firmware 
Before updating the Dante component of your E-DANTE64 card, you must first download the 

Dante Firmware Update Manager from the Audinate website.  

Open the Dante Firmware Update Manager and follow the instructions on the screen.  

The Dante firmware upgrade file (usually labeled ‘Brooklyn’) has a .dnt extension.  

 

Note: Disable any firewalls before upgrading the E-Dante combined Brooklyn file via Dante 

Firmware Update Manager.  

Note: When upgrading firmware for the Dante component, the status light on the front of the E-

Dante64 card will not change.  

Note: An upgrade guide for the *.dnt file is available at https://dev.audinate.com/GA/firmware-

update-manager/userguide/latest/AUD-MAN-Firmware_Update_Manager-v2.7.pdf. The E-

Dante card may need to be reset after a successful update. 

12.1.3 E-Dante Combined Boot and App Firmware Upgrade 

Note: The image is for a MK1 Madi/Dante. New cards have different positions for the 

switch/jumpers. 

Dip switch setting: 

Designator Number Function Mechanical Description 

SW2.1-4 Spare Dipswitch 

SW2.5 ON - Place H8 in standby 

OFF-Normal 

Dipswitch 

SW2.6 If SW2.6 is switched OFF 

ON-Boot firmware update 

OFF-Normal 

Dipswitch 

https://dev.audinate.com/GA/firmware-update-manager/userguide/latest/AUD-MAN-Firmware_Update_Manager-v2.7.pdf
https://dev.audinate.com/GA/firmware-update-manager/userguide/latest/AUD-MAN-Firmware_Update_Manager-v2.7.pdf
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SW1 Front panel mounted 

recessed pushbutton – 

Hard reset 

Pushbutton 

 

1. Enable SW2.6 to ON. 

2. Setup the FDT download setting: 

FDT Settings 

Settings dialog / option Setting to enter 

Select Device H8S/2318F 

Select Port COM1 (change to match a COM port 

present on the PC) 

CPU Frequency 25.) Mhz 

Connection Boot mode 

Recommended Speed 38400 (deselect the Use-Default option) 

Protection Automatic 

Messaging Advanced 

User Area Selected (checked) 

Readback verification Yes 

 

Note: The first time the FDT is run, the settings dialogs are displayed by default. After the FDT has 

been configured, the settings dialogs are no longer shown by default.  

3. In the Download window, click Options and ensure that: 

• Auto-Disconnect is selected (checked) 

• The Download File radio button is selected 

Select ‘…’ for the User area and select the appropriate *.mot format file for the E-Dante64 

• H8 boot code or 

• H8 + App combined file.  
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13 Upgrading E-IPA-HX cards 

The Admin LAN port of the E-IPA card must be on the same subnet as the PC hosting the 

EHX software.  

 

If you are upgrading you E-IPA card and the current E-IPA version is the version 12.0 

version (3.100.63.0) (or later) then please use the .ccf file (example E-IPA firmware version 

x.y.63.z.ccf) from the upgrade media. If the system release is earlier than v12.0 then 

please use the .tar.gz firmware file (example E-IPA firmware version x.y.63.z.tar.gz) 

The single upgrade file contains the main application, kernel and FPGA files. 

Note: When performing software updates, start the update and do NOT touch the IPA until update 

is completed. Set a timer for 10-20 minutes to ensure enough time is allowed for the 

update. 

Note: The upgrade process from the PC to the EIPA card takes about 2.5 mins however depending 

on what sub-system on the EIPA card requires upgrading the whole process for the card 

may take up to five minutes. 
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If there is an interruption to the power supply of the E-IPA-HX card during the upgrade, the 

card will go into recovery mode. The table below shows the stages that occur during 

recovery mode. 

State\ LED 16 32 48 64 EXT1 EXT2 EXT3 EXT4 E1 1 

& 2 

Erasing flash 

(~ 10 

minutes) 

        

 

 

Writing 

preloader, u-

boot and 

DTB 

( < 1 

minute) 

        

 

 

Writing 

zImage 

( < 1 

minute) 

         

 

Writing 

FPGA image 

( 1 minute) 

         

 

Fetching 

rootfs 

(~ 10 

seconds) 

         

 

Writing 

rootfs 

( < 5 

minutes) 

         

 

All done!          
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Check the firmware report to make sure that the upgrade has completed successfully. 

 

Important note: Upgrading to EHX v14 

The release of EHX13 brings enhancements and additional features, including N+1 and 

network redundancy. With these additions comes an increase in the demands on the 

hardware, in particular the E-IPA card. Before upgrading to EHX13, and to optimize system 

performance, it is a requirement to ensure that any E-IPA card is hardware version 4.00 or 

later. Upgrading to EHX13 on an older hardware version of the E-IPA card will have a 

negative effect on system stability. Older cards can be updated by Clear-Com or our 

authorised service centres.  

Please contact Clear-Com at Support@clearcom.com for information and to discuss the 

update of existing hardware. 

Place in the subject line of the email: E-IPA card upgrade to EHX V13.  

You can check what version of hardware you have in the E-IPA card CCM: 

 

To access the CCM, input the E-IPA card IP address into the URL field of a PC attached to 

the same network as the card.  

 

mailto:Support@clearcom.com
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14 Upgrading panels 

This chapter describes how to upgrade the i-Station and V-Series user panels supported by 

Eclipse HX. 

Supported panels may be upgraded using an installed and configured copy of EHX and an 

active Eclipse HX matrix.  

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

14.1 Upgrading panels using EHX 

In all cases, panels should initially be upgraded using EHX. Manual programming of panels 

should only be attempted if the EHX download repeatedly fails. 

For V-Series Iris/IrisX panels, upgrade using EHX is only possible if the panel is connected 

to the matrix using AoIP. Otherwise, you must upgrade the panel by USB (see 14.2 

Upgrading V-Series Iris/IrisX panels by USB). 

The download of a panel application requires an *.fwp format file, which is located on the 

software USB. This must be placed in a location that is accessible by the installed EHX 

application. 

Note:  
The Eclipse HX v14 contains all the firmware files required for upgrading a panel.  

 

The download of a panel application requires: 

• An operational Eclipse HX matrix with the panels connected and powered. 
 

• A suitable EHX configuration (with the correct IP address configured, if an Ethernet connection is 
used). 
 

Once the *.fwp format file is downloaded to the Eclipse HX matrix, all panels of the same 

type will be upgraded at the same time through an automatic download from the matrix to 

the panel. 

Each panel type requires a different *.fwp format file, but the Eclipse HX matrix determines 

the panel type before attempting any download. It is therefore not necessary to disconnect 

panels of a different type to prevent an accidental download. 
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To upgrade panel application code using EHX: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet or 

serial communications 

port 

- 

EHX software EHX must be installed and configured. 

EHX configuration file / 

map 

- 

Ethernet or serial cable for 

the PC-to-matrix 

connection 

- 

Appropriate *.fwp format 

panel application 

The appropriate *.fwp format panel code is 

available from the Drivers USB: 

 

Drivers USB > ECLIPSE DRIVERS > Panel 

Software > <Panel type> 

 

Table 14-1: Required equipment 

2. Start EHX on the PC. 

 

3. Connect the PC to the matrix using either Ethernet or serial communications port. 

 

4. Open the EHX configuration map within EHX. 

 

5. Select System > Layout. 

 

6. Right click the matrix and then select Firmware> Update Firmware.  

 

7. The update firmware wizard dialogue is displayed. Click Next and ensure that the 

Panel radio button is selected. 

 

In Options: 

• Selecting Automatic mode forces panels to upgrade automatically. 

 

• Selecting Panel Prompt mode means that each panel user will be asked to 

accept / decline the panel upgrade. 

8. Click Next and then browse to the appropriate *.fwp file: 

 

Drivers USB > ECLIPSE DRIVERS > Panel Software > <Panel type> 
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9. Click Next and confirm that the details displayed are correct. 

 

10. Click Next and confirm that the download commences. 

 

11. When the download has completed, click Finish to close the update firmware wizard. 

 

12. Ensure that the matrix commences downloading to connected panels of the required 

type. If automatic download does not commence, power cycle the panel(s) being 

upgraded. 

 

13. Ensure that the panels reset once the download is complete. 

 

14. Confirm the updated firmware version using either: 

 

• The  EHX firmware report tool: 

 

- Go to EHX > System > layout. 

 

- Right click the matrix icon. 

 

- Select Firmware > Firmware report. 

 

• The local menu on the panel (display panels only). 

14.1.1 Locating Panel *.fwp files on the software USB 

Panel type *.fwp file 

i-Station (i-Series) Drivers USB > ECLIPSE DRIVERS > Panel_Software > i-

Station > xxxxxx-i-Station App (where xxxxxx represents 

the product number) 

 

Note:  

Clear-Com recommends that you upgrade Expansion panels 

first before upgrading the main i-Station.  

E-Station Drivers USB > ECLIPSE DRIVERS > Panel Software > E-

Station > xxxxxx-E-Station App (where xxxxxx represents 

the product number). 

Note:  

Clear-Com recommends that you upgrade Expansion panels 

first before upgrading the main E-station. 

V-Series Drivers USB > ECLIPSE DRIVERS > Panel Software > V-

Series > Main Board > xxxxxx-Panel Application  
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(where xxxxxx represents the product number). 

V-Series Iris/IrisX panels …\V-Series 

Iris\Main_Board\xxxxxx – panel application. 

 

V-Series Display 

Module 

The Display Module upgrade files (*.fwp format) are available 

from the Drivers USB: 

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-
Series > Display_Module > xxxxxx-Display PIC Boot Loader 
 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-
Series > Display_Module > xxxxxx-Display PIC Application 
Code 

 

Where xxxxxx represents a product number. 

 

V-Series Iris/IrisX 

panels 

EHX upgrade only via AES67 connected panels. Iris/IrisX panels 

connected via MCX or IVC require upgrade using USB memory 

stick 

 
Table 14-2: Locating Panel *.fwp files 

Tip: For help with selecting the other procedures you require for upgrading to Eclipse HX 

v14, see the quick reference procedures tables in 2 Selecting Upgrade Procedures. 

14.1.2 V-Series upgrades 

You cannot upgrade any other panels during a V-Series panel upgrade.  

The size of the V-Series firmware means that it cannot be stored in the flash memory of the 

matrix during the upload, and has to be retained in the upload buffer. If an attempt is made 

to upgrade another panel while the V-Series panel is being upgraded, the V-Series firmware 

upload will be overwritten. 

Clear-Com also recommends that you do not download any configurations during the V-

Series panel upgrade. An Apply Changes download from EHX will break a V-Series panel 

upgrade (the download partially resets the configuration for each panel and this makes the 

rack "forget" that it is upgrading the panel).  

Note: upgrading Iris/IrisX panels - check the FPGA status first – see procedure outlined in section 

14.2 Upgrading V-Series Iris panels by USB 

14.2 Upgrading V-Series Iris/IrisX panels by USB 

Note: This section only applies to the V-Series Iris/IrisX panels connected by analogue MVX or 

IVC-IP. It does not apply to any other V-Series or I-Series panel. 
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Note: When performing software updates, start the update and do NOT touch the panel until 

update is completed. Set a timer for 10 minutes to ensure enough time is allowed for the 

update. 

Note: If the panel is connected by AoIP, you must upgrade V-Series Iris/IrisX panels using the EHX 

configuration software. See 14.1 Upgrading panels using EHX. 

Note: Upgrading Iris/IrisX panels (v.3 / v.5, upgrading to v5.43 or v. 6.15) - check the FPGA 

status first  

When upgrading Iris panels please observe the following steps:  

o Before attempting an upgrade, pin reset or power cycle the panel(s) and 

wait to make sure the FGPA/QSPI are both available. 

o Use the EHX firmware report (or CCM) to check the FPGA/QSPI are both 

available.  

If the FPGA / QSPI is unavailable – do not upgrade the panel  

Upgrade Process: 

1) Rename the .tar.gz file to IRIS.gz and place it in the root file of your USB stick 

(models running newer firmware will also recognize a .ccf file). 

2) Insert the USB into the connector on either the front or the back of the device and 

follow the panel menu as usual. 

3) Make sure the Iris/IrisX panel is either not connected to the matrix (panel needs to 

be off line) OR in the local menu screen. 

Note: Only connect a single USB device to the panel during the upgrade. 

14.3 Upgrading panel application code manually  
The application code for most panels can be upgraded manually either by re-programming 

the PROM or by directly connecting the panel to a PC. Before attempting any upgrade, 

ensure that anti-static precautions are taken, as Eclipse HX devices are sensitive to static 

discharges. 

 

Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 

 
Tip: For help with selecting the other procedures you require for upgrading to Eclipse HX 

v14 see the quick reference procedures tables in 2 Selecting Upgrade Procedures. 

Cabling for i-Station upgrades 
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14.3.1 Manually upgrading i-Station & E-Station panel application 
code 
 

Before you manually upgrade the application code for i-Station & E-Station panels, ensure 

that you have the following equipment: 

• An i-Station serial interconnect lead. 

 

• RS232/RS422 adaptor (see Figure 14-1: Example converter cable). 

 

• An installed Tera Term application. 

  

• A paperclip or small flat blade screwdriver to access maintenance button on 

the rear of the i-Station panel.  

 

Tera Term uses a special file with the updated i-Station or E-station application code, 

instead of an *.fwp file. The file has an *.s19 file extension and the specific files can be 

found on the software USB: 

• Software USB > SOFTWARE - EHX.xxx > Panel Software > i-Station > xxxxxx-i-Station App 
 

• Software USB > SOFTWARE - EHX.xxx > Panel Software > E-Station > xxxxxx-E-Station 
App 
 
Where xxxxxx represents the product number. 

The convertor cable connects from a serial port on the PC, routes through an RS-232 to 

RS-422 adapter and connects to the expansion out RJ-45 port and the i-Station or the 

expansion in RJ-45 port of the E-Station using separate CAT5 cables. 

 

Figure 14-1: Example converter cable 

Figure 14-2 shows an example wiring scheme for serial programming an i-Station panel: 
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Figure 14-2: Example wiring scheme for i-Station serial programming 

Figure 14-3 shows an alternative cabling scheme that does not require the use of the RS-

422 converter module:  

 

 

Figure 14-3: Alternate example wiring scheme for i-Station serial programming 

Note: 

The cabling scheme shown supports i-Station panels. To use with an E-station simply 

reverse the TX and RX connections at the Sub-D 9-pin F connector. 

 

Tip:  An i-Station or E-station with either no firmware installed or corrupted firmware may 

be repaired through an upgrade (the station will display Display Module Test, Press All 

 

 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 238 of 315   

 

 

 

 

Buttons 3X). 

 

To manually upgrade the i-Station panel application code:  

1. Install Tera Term. Third party software is available from either of the Eclipse HX 14 upgrade 

media: 
 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > Teraterm 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 
 

Tip: For more information about installing Tera Term, see Appendix G: Tera Term  

2. Connect the converter cable to the expansion out RJ-45 port (J1) on the i-Station 

undergoing the upgrade. 

If the cable has separate i-Station and E-station CAT5 cables, the i-Station CAT5 

cable is used for the connection to J1 on the i-Station. Connect the other end of the 

cable to the serial port of the PC running the Tera Term software. 

 
Note: 
The i-Station panel must not be powered while the cable is connected. 
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Figure 14-4: i-Station manual upgrade 

3. Start Tera Term. 

 

Configure Tera Term for the appropriate COM port on the PC, as shown in the 

following figure. 

 

Select the Serial radio button and then the correct COM port setting for the PC from 

the Port drop-down menu. Click OK. 

 

 

 

 

 

 

Figure 14-5: Tera Term: COM port setting 

4. From the Tera Term main screen select Setup > Serial port….  

 

The serial port setup screen should now be visible. Configure Tera Term with the 

following settings:  

 

Field Setting 

Baud 19200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow Control None 

Table 14-3: Serial port setup screen settings 
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Note: 

Do not configure (ignore) the Transmit delay settings. 

 

Click OK. 

 

5. Power up the i-Station panel into maintenance mode by first holding in the recessed 

button found on the rear panel during a simultaneous AC power up. 

 

The reset button must be held in until all front panel keys turn bright red and the 

front panel display modules show the message Display Module Test’, Press All 

Buttons 3x. 

 

Tip:  If the recessed button cannot easily be accessed, use a bent paper clip or small 

flat blade screwdriver to press the button in. 

 

 

 

 

 

 

 

 

 

Figure 14-6: Module display message 
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6. The following Tera-Term boot up message is displayed.  

 
Note: 

Do not proceed until you see the boot up message. If you do not see the boot up 

message, check your wiring connections and software settings. Repeat steps 1 – 6 

 

 

 

 

 

 

 

 

 

 

Figure 14-7: Boot up message 

7. Press the 1 key on the PC keyboard. Press Enter to access the Checksums and 

Versions information on the i-Station panel. 

 

The boot code version and application code versions are displayed on the Tera-Term 

screen. 

 
Note: 
Do not proceed until the version information is displayed, as shown below.  
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Figure 14-8: Version and application code (firmware) versions 

8. Before loading the new application code (*.s19 format file), you must erase the 

Flash ROM on the i-Station panel. 

 

Press in the 2 key on the PC keyboard and press Enter. 

 

A message is displayed indicating Flash Erasing – Please wait. . After the Flash 

ROM is erased, a message is displayed asking you to Download S-record file now. 

 

 

 

 

 

 

 

 

 

Figure 14-9: Erasing Flash ROM 

9. In File, select the Send File. You are prompted to browse for the i-Station *.s19 

file: 

 

Drivers USB > ECLIPSE DRIVERS > Panel Software > i-Station > xxxxxx-i-

Station App 

 

10. Select the i-Station *.s19 file. Select Open to start the *.s19 file download process 

to the Flash ROM of the i-Station panel.  

 

Note: 

The download process takes several minutes to complete.  

 

11.  When the download process is complete, Tera-Term will display the message on the 

PC Download Success! 

 

Exit Tera Term and reboot the i-Station panel to leave maintenance / update mode. 

Press 9 on the PC keyboard and then Enter. 

 

The i-Station panel begins its reset process. 

 
Note: 
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When the reset process is underway, the display modules briefly display the updated 

firmware version. If the i-Station is re-connected to an Eclipse HX matrix with a valid 

configuration press keypad button 9 to access the updated firmware/rack code 

version.  

 

 

Figure 14-10: Example version display 

Note:  

If the manual upgrade fails repeat the above procedure. It can be necessary to attempt the 

manual process up to 3-5 times before the application is installed. 

14.3.2 Upgrading the i-Station panel firmware using EHX 

 

Caution: Central upgrade from EHX is not supported on all I-

Stations, when upgrading I-Stations with the serial number 45PC0001 

or above you must contact your Clear-Com sales representative first. 

Caution: When a firmware upgrade to an i-Station has started, wait 

for it to complete on all panels before doing any other changes to the 

matrix.  

1) Download the i-Station firmware upgrade to the Eclipse / Eclipse HX 

matrix from ECS / EHX. 

2) Provided that the Panel Prompt option is set, the i-Station panel displays the 

following message: 

UPGRD TO VER nnnnn YES NO 

 

Each word corresponds to a key on the panel, and  nnnnn represents the firmware 

upgrade number.  

Note: The i-Station panel keys flash, indicating that an upgrade is 

available. 

Note: The prompt is displayed provided that the i-Station panel is online. 
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3) To decline the upgrade, the i-Station user presses the NO key (right-hand 

flashing). The i-Station panel returns to its normal display. If the upgrade is 

declined it will not be offered again until a black reset (reset and clear all memory) 

is performed on the matrix. 

To accept the upgrade, the i-Station user: 

a. Presses the YES key (left-hand flashing). The i-Station panel displays the 

following: 

  ARE YOU SURE nnnnn YES NO. 

 

Each word corresponds to a key on the panel, and  nnnnn represents the 

firmware upgrade number.  

b. If the user selects the NO key, the upgrade is cancelled and will not be 

offered again until a black reset (reset and clear all memory) is performed on 

the matrix. 

If the user selects the YES key, the firmware upgrade is applied to the i-

Station panel. 

14.3.3 Manually upgrading E-Station application code 

The procedure for upgrading the E-station application code is very similar to the procedure 

for upgrading the i-Station panel application code (see 14.3.1 Manually upgrading i-

Station & E-Station panel application code). 

To manually upgrade the E-Station: 

1. Connect the converter cable to the expansion in RJ-45 port (J1) on the E-station 

undergoing the upgrade.  

If the cable has separate i-Station and E-station CAT5 cables, the E-station CAT5 

cable lead is used for the connection to J1 on the E-station. Connect the other end 

of the cable to the serial port of the PC running the Tera-Term software.  

 
Note: 

The E-Station must not be powered while the cable is connected. 

 

 

 

 

Figure 14-11: E-Station manual upgrade 
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2. Start Tera Term. 

 

Configure Tera Term for the appropriate COM port on the PC, as shown in the 

following figure.  Select the Serial radio button and then the correct COM port 

setting for the PC from the Port drop-down menu. Click OK. 

 

 

Figure 14-12: Tera Term: COM port setting 

3. From the Tera Term main screen select Setup > Serial port….  

 

The serial port setup screen should now be visible. Select the following settings to 

configure Tera Term for updating the E-station: 

 

Field Setting 

Baud 19200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow Control None 

Table 14-4: Serial port setup screen settings 

Note: 

Do not configure (ignore) the Transmit delay settings. 

 

Click OK. 

 

4. Power up the E-station into maintenance mode by first holding in the recessed 

button found on the rear panel during a simultaneous AC power up. 

 

The reset button must be held in until all front panel keys turn bright red and the 

front panel display modules show the message Display Module Test, Press All 

Buttons 3x.  
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If the recessed button cannot easily be accessed, use a bent paper clip or small flat 

blade screwdriver to press the button in. 

The following Tera Term boot up message is displayed.  

 

Figure 14-13: Module display message 

Note: 

Do not proceed until you see the boot up message. If you do not see the boot up 

message, check your wiring connections and software settings. Repeat steps 1 – 6.  

 

 

 

 

 

 

 

 

 

 

 

Figure 14-14: Tera Term boot up message 

5. Before loading the new application code (*.s19 format file), you must erase the 

Flash ROM on the E-station. 

 

Press in the 2 key on the PC keyboard and press Enter, a message is displayed 

indicating Flash Erasing – Please wait.  
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After the Flash ROM is erased, a message is displayed asking you to Download S-

record file now. 

 

 

Figure 14-15: Erasing Flash ROM 

6. In File, select the Send File. This prompts the user to browse for the correct E-

Station *.s19 file for download to the unit undergoing the firmware upgrade: 

 

Drivers USB > ECLIPSE DRIVERS > Panel Software > E-Station > xxxxxx-E-Station App 
 
Where xxxxxx represents the product number. 
 

7. When you have selected the E-Station *.s19 file, select Open to start the s19 file 

download process to the E-station Flash ROM.  

 
Note: 
The download process take several minutes to complete. 

 

8.  When the download process is complete Tera-Term will display the message on the 

PC Download Success! 

 

Exit Tera Term and reboot the E-station out of maintenance / update mode. 

 

Press 9 on the PC keyboard and then Enter. The E-station begins its reset process. 

 
Note: 

When the reset process is underway, the display modules briefly display the updated 

firmware version. If the E-station is re-connected to an Eclipse matrix with a valid 

configuration press keypad button 9 to access the updated firmware/rack code 

version.  
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Figure 14-16: Example version display 

 
Tip: For help with selecting the other procedures you require for upgrading to EHX V5.2.5, 

see the quick reference procedures tables in 2  Selecting Upgrade Procedures. 

14.4 Manually upgrading V-Series panels 
 

Before attempting to upgrade V-Series panels, ensure that anti-static precautions are taken, 

as the Eclipse HX items are sensitive to static discharges. 

 

Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 

 

V-Series panels can be manually upgraded using a PC directly connected to the panel. 

Before manually upgrading a V-Series Panel, ensure you have the following equipment: 

• An Ethernet crossover cable. 

  

• A PC with an installed and running TFTP server (there is a TFTP server application 

on the EHX USB), or any TFTP server as long as it points to the C:\TFTP folder. 

 

 

Figure 14-17: PC LAN port connected directly to V-Series Panel Ethernet port 

The following components of the V-Series panel can be upgraded either by EHX or directly  
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Component Description Upgrade path 

U-Boot This is the very first software which runs when 

the panel starts. It initializes hardware and 

then starts the kernel running. 

Direct only 

Kernel The micro-Linux kernel binary. Direct only 

Kernel Root File 

system 

The file system containing all the files used 

and required by the kernel (servers, utilities, 

and so on). 

Direct only 

Application Files The Clear-com software which actually runs in 

the panel and is used by the system to 

operate the panel. 

Direct or EHX 

Display module Boot 

loader 

Each bank of six displays forms a single 

module. This module is a discrete hardware 

component and like the panel itself, has its 

software, which runs when the module is 

started, which in turn initializes the module 

and starts the display module application. 

EHX only 

 

Display Module 

Application 

The software which actually operates the 

module, which the panel communicates with 

to get the displays to perform. 

EHX only 

 

Table 14-5: Upgradeable V-Series components  

Direct manual upgrades are described in this section.  

Note: 

EHX upgrades operate in the same way as all EHX based panel upgrades See 14.1 

Upgrading panels using EHX. 

To manually upgrade a V-Series panel: 

1. Unpack and install the TFTPUtil application.  

 

Tip:  For more information about installing the TFTPUtil application on either 32 bit 

or 64 bit computers, see Appendix F:TFTPUtil. 

 

2. When the TFTPUtil GUI program has been installed, you can find the program at  

Start > Programs> TFTPUtil > TFTPUtil GUI. 

 

Run TFTPUtil. 

 

3. Open My Computer and navigate to your C: drive. Create a new directory called 

C:\TFTP.  
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4. In the C:\TFTP directory: 

 

a.  Create another directory called Release. 

 

b. Copy the following file from the Drivers USB to the C:\TFTP\Release 

directory: 

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series > 

Main_Board > xxxxxx- Panel UBOOT TFTP Image > u-boot.ldr 

 

Where xxxxxx represents a product number. 

 

c. Copy the following files from the software USB to the C:\TFTP\Release 

directory: 

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series > 

Main_Board > xxxxxx- Root File System > rootfs.cramfs  

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series > 

Main_Board > xxxxxx- Panel Kernel > vmImage 

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series > 

Main_Board > xxxxxx -  Panel Application > sbin.jffs2 

 

Where xxxxxx represents a product number. 

 

The C:\TFTP > Release directory appears similar to the following: 

 

 

Figure 14-18: C:\TFTP > Release directory 

5. From the Start menu of your PC: 

 

a. Select Settings > Network and Dial-up Connections.  
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b. Double click Local Area Connection and click Properties. 

 

c. In the This connection uses the following items box, select Internet 

Protocol (TCP/IP) and select Properties. 

 

Tip: Make a note of all information in this window in case of later problems 

with networking. 

 

d. Select the Use the following IP address radio button and enter 

172.16.5.50 into the IP address line. Set the Subnet mask to 255.255.0.0. 

 
Note:  

It is advisable to switch off any wireless Wi-Fi connections that maybe 

running on your PC when doing this upgrade. 

 

6. Start the TFTP server application. 

 

7. Click the options icon (spanner) to display the options window. Check that the 

C:\TFTP\ folder is set as the path.  

 

Figure 14-19: TFTPUtil Options 

 

8. Select the icon with two blue cogs on the left hand side of the window. Check the 

settings as below. 
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Figure 14-20: TFTPUtil settings 

9. If a firewall is running it may request permission for the program to have access 

when the TFTP server is run for the first time.  Click Yes. Click OK and OK again. 

 

10.  Check that your PC IP address is correctly displayed on the main header of the TFTP 

application:  

 

 
Figure 14-21: Checking the PC IP address 

11. Connect an Ethernet cross-over cable from the PC to the Ethernet port at the back of 

the V-series panel and disconnect the cable that connects to the matrix. 

 

Your PC is now ready to act as a file server to a V-series panel and the panel is now 

ready to be told which files to upload. 

 

12. To upgrade the V-Series U-Boot Loader: 

 

a. Press and hold down both the MAIN and AUX knobs on the V-Series Panel 

while applying a reset.  
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The reset may be applied by either power cycling the panel or poking a paper 

clip into the reset hole between the H/S and MENU buttons. 

 

b. The 4 function button LEDs (Mic On, H/S, Shift and Menu) will flash. Press 

and release the H/S button then press and release the Shift button to trigger 

the U-Boot code upload. 

 
Note: 

As the upload proceeds, the AUX and MAIN lights on the panel will gradually 

change from green to amber and then red. This process may take a few 

minutes. 

 

c. When the upload is complete, the panel will reset itself, completing the 

procedure.  After the panel has reset the display will either go blank or 

display the versions. 

 

13. To upgrade the V-Series Kernel, Root File System and Application files: 

 

a. Press and hold down both the AUX and MAIN knobs whilst applying a reset. 

 

The reset may be applied by either power cycling the panel or poking a paper 

clip into the reset hole between the H/S and MENU buttons. 

b. The 4 function button LEDs (Mic On, H/S, Shift and Menu) will flash. Press 

and release the Shift button to trigger the Kernel, Root File System and 

Application files upload. 

 
Note: 

As the upload proceeds, the AUX and MAIN lights on the panel will gradually 

change from green to amber and then red. This process may take a few 

minutes. 

 

c. When the upload is complete, the panel will reset itself, completing the 

procedure.  

 

Wait until the panel completely resets itself and displays the offline status 

screen before powering down the panel (example shown below). 
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Figure 14-22: Panel after update reset 

Notes:  

After the V-Series panel has been upgraded using the TFTP server some of the level 

settings may be disabled. IP settings will also be lost. To restore the level and IP 

settings, download a map from EHX using the Clear Matrix Data option. 

 

14.4.1 Upgrading the V-Series Display Module 

The only upgradeable component in a V-Series expansion panel is the Display Module. 

When the parent V-series panel has its Display Module updated, the updates are 

automatically propagated to the expansion panels. 

However, this only occurs if the expansion panel is plugged in at the time the parent panel 

is upgraded. Expansion panels connected afterwards are not upgraded. 

The Display Module upgrade is only performed using EHX. The required files (*.fwp format) 

are available from the Drivers USB: 

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series > Display_Module > 
xxxxxx-Display PIC Boot Loader 
 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series > Display_Module > 
xxxxxx-Display PIC Application Code 

 

Where xxxxxx represents a product number. 

 

For more information, see 14.1.1 Locating Panel *.fwp files on the software USB. 
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15 Upgrading the TEL-14 module 

This chapter describes how to upgrade the TEL-14 module, including how to: 

 

• Replace the TEL-14 processor. 

 

• Re-fit TEL-14 modules. 

  

• Update TEL-14 firmware. 

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

15.1 Upgrading the TEL-14 hardware 

To upgrade the TEL-14 hardware, you require the following equipment: 

 

• The old Tel-14 card 

 

• The replacement TEL-14 processor module. 

 

• Flash Magic Software. Third party software is available from either of the 

Eclipse HX 14 upgrade media: 

 

Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > 

FlashMagic 

 

Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > FlashMagic 

 

Tip: For more information about installing Flash Magic, see 

 Appendix H: Flash Magic. 

 

• TEL-14 application software. The TEL-14 application software (*.HEX format 

file) is available from the software USB:  

 

Drivers USB > ECLIPSE DRIVERS > Other_Software >xxxxxx-TEL-14 

Application 

 

Where xxxxxx represents the product number. 

To upgrade the TEL-14 hardware: 

 

1. Remove the four screws securing the front panel and remove the front panel. 

 

2. Remove the three screws securing the PCB without the backplane connector and 

open the two cards up. It is not necessary to disconnect the two cards. 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 256 of 315   

 

 

 

 

3. Remove the original processor (IC20) from its socket. 

 

 

Figure 15-1: original IC20 in position 

4. Replace the old processor with the new processor module, ensuring that it is 

correctly positioned. 

 

Tip: The blue serial connector should be farthest away from the front panel. 
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Figure 15-2: replacement processor module in position 

15.2 Upgrading the TEL-14 firmware 

To upgrade the TEL-14 firmware: 

1. Ensure that you have the following equipment: 

Required equipment Description / comments 

MVX-A16 serial upgrade 

cable (Clear-Com part 

CAB-MVX-48Z) 

See: 

Figure 28: MVX-A16 Serial upgrade cable. 

 

Flash Magic 
Third party software is available from either of the 

Eclipse HX 14 upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > FlashMagic 

 

• Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > FlashMagic 

 

Tip: For more information about installing Flash 

Magic, see Appendix H: Flash Magic. 

*.HEX file to upload 
TEL-14 application software. The TEL-14 

application software (*.HEX format file) is 

available from the software USB: 

• Drivers USB > ECLIPSE DRIVERS > 

Other_Software >xxxxxx-TEL-14 

Application 

 

Where xxxxxx represents the product number. 

 

Table 15-1: Required equipment 

2. Connect the PC to the Serial Programming port of the TEL-14 processor card, as 

shown in the following figure. 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 258 of 315   

 

 

 

 

 

Figure 15-3: Processor module with serial cable attached 

Note:  
For correct connector orientation, the wires must exit the plug on the top side as 

shown. 

3. Power up the TEL-14. 

 

4. Start Flash Magic. Configure the following settings for the 5 purple numbered 

boxes in the Flash Magic dialog: 

 

Box Setting(s) to enter 

1 The COM port to which you are connected. 

Baud Rate: 2400 

Device: 89LPC935 

Oscillator Frequency:  3.5795 MHz 

2 Select Erase blocks used by Hex File 

3 Enter the name of the file (710756Z .hex) to be loaded, or use 

Browse to locate the file. 

4 Ensure all boxes are clear 

 

5 Do not press Start. 

Table 15-2: FlashMagic settings 
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Figure 15-4: FlashMagic configuration dialog 

5. In the menu options along the top of the Flash Magic dialog, select ISP (second 

option from the left). 

 

From the drop-down menu, select Start Bootloader. 

  

 

Figure 15-5: Start Bootloader dialog 
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6. Ensure that Send Break Condition is checked, then press Start Bootloader.  

 

7. The configuration dialog is re-displayed after a few seconds. In box 5, press Start. 

 

Note: 
The status bar along the bottom displays Programming device, and the progress 

bar displays the state of the operation. 

 

After about 20 seconds, Finished is displayed in the status bar. The device has now 

been reprogrammed. Power cycle the TEL-14 to activate the new firmware. 
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16 Upgrading the AES-6 module 

This chapter describes how to upgrade the application code of the AES-6 interface module. 

Before attempting any upgrade of the AES-6 card, ensure that anti static precautions are 

taken, as the Eclipse HX devices are sensitive to static discharges. 

 

 

Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 
Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 3 Quick reference: 

Upgrading to Eclipse HX. 

To upgrade the AES-6 application code: 

1. Ensure you have the following equipment: 

Required equipment Description / comments 

PC with a serial port  A USB-to-serial adapter is usually acceptable. 

CellCom / FreeSpeak 

/ FreeSpeak II 

(FSBP) registration 

cable 

PD4007Z, DB-9 to 3.5mm jack. 

The appropriate AES-

6 application code file  

(*.mot file) 

The AES-6 application code (*.mot format file) is 

available from the software USB: 

Drivers USB > ECLIPSE DRIVERS > 

Other_Software > xxxxxx - AES-6 Application  

(where xxxxxx represents the product number) 

Hitachi Renesas Flash 

Development Toolkit 

(FDT) 

 

Third party software is available from either of the 

Eclipse HX 14 upgrade media: 

 

• Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Hitachi_FDT 

 

• Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Hitachi_FDT 

 

Tip: For more information about installing the Hitachi 

Renesas FDT, see Appendix E:Hitachi Renesas 
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Flash Development Tool. 

 
Table 16-1: Required equipment 

2. Fit the AES-6 card to either the IMF-3 interface frame or Eclipse HX-Median Matrix. If there 

is a jumper on J6, move the jumper to J3.Reset or power-cycle the card so the 

jumper change takes effect. 

 

3. Connect the serial cable to the front of the AES-6.  

 

4. Run Flash Development Toolkit BASIC (FDT). Configure the FDT (Options > New 

Settings) as follows: 

 

FDT field Setting 

Select Device H8S/2318F 

Select Port COM1 (change to match COM port present on the PC) 

CPU Frequency 25.0000 MHz 

Connection BOOT mode 

Recommended Speed Deselect Use Default and set to 9600 

Protection Automatic 

Messaging Advanced 

User data Selected (Checked) 

Table 16-2: FDT settings  

5. Navigate to the AES-6 application code (*.mot format file) on the software USB: 

 

Drivers USB > ECLIPSE DRIVERS > Other_Software > xxxxxx - AES-6 

Application 

 

Where xxxxxx represents the product number). 

 

6. Select Program Flash and download the AES-6 application code (*.mot format 

file).  

 

7. When the download is complete, move the jumper on J3 back to J6. Reset or power-

cycle the card.  

Note: 

If an FPGA image is present, the card will now run normally. If an FPGA image is not 

present, you will be prompted for an FPGA image. See 3.33.1 Upgrading AES-6 

FPGA. 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 263 of 315   

 

 

 

 

16.1 Upgrading AES-6 FPGA 

 

 

Before attempting any upgrade of the AES-6 card, ensure that anti static precautions are 

taken, as the Eclipse items are sensitive to static discharges. 

 

Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 

 
Tip: For help with selecting the other procedures you require for upgrading to EHX V5.2.5, 

see the quick reference procedures tables in 2  Selecting Upgrade Procedures. 

To upgrade the AES-6 FPGA: 

1. Ensure you have the following equipment: 

 

Required equipment Description / comments 

PC with a serial port  A USB-to-serial adapter is usually acceptable. 

 

CellCom / FreeSpeak / 

FreeSpeak II (FSBP) 

registration cable 

 

PD4007Z, DB-9 to 3.5mm jack. 

The appropriate AES-6 

FPGA code file 

The AES-6 FPGA code is available from the Drivers 

USB: 

Drivers USB > ECLIPSE DRIVERS > 

Other_Software > xxxxxx - AES-6 FPGA  

(where xxxxxx represents the product number) 

 

Tera Term terminal 

software 

Third party software is available from either of 

the Eclipse HX 14 upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 
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Tip: For more information about installing Tera 

Term, see Appendix G: Tera Term  

 
Table 16-3: Required equipment 

 
2. Fit the AES-6 card to a parent unit. 

 

3. Run TeraTerm. Configure the serial settings to the following: 

Serial setting Setting 

Baud rate 57600 

Parity None 

Data Bits 8 

Stop Bits 1 

Flow Control None 

Table 16-4: Tera Term serial settings 

4. Reset or power-cycle the module.  

 

5. At this point, the procedure varies depending on whether or not an FPGA image is 

already present.  

 

If there is an FPGA image present: 

 

a. After the reset, the following output will be shown in the TeraTerm window: 
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Figure 16-1: AES-6 FPGA upgrade using Tera Term 

Type testmode into the Tera Term window and press Enter (return). The 

card enters test mode and displays the following menu: 

 

Figure 16-2: AES-6 main menu 

b. Select option 6, Download FPGA Image. 
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c. You are prompted to delete the old FPGA image. Press Y. 
Note:  

Key entry is case sensitive, so Y must be a capital. 

The card deletes the old image and then prompts you for a new FPGA image: 

d. In Tera Term, select Send File and select the FPGA image, which is located 

on the Drivers USB: 

 

• Drivers USB > ECLIPSE DRIVERS > Other_Software > xxxxxx - AES-6 FPGA  

(where xxxxxx represents the product number). 

 

Note: 

During the download the six yellow LEDs illuminate in a circulating anti-

clockwise direction. 

 

e. When the download is complete, the six yellow LEDs should be off and the 

following text should be displayed in TeraTerm: 

 

Figure 16-3: FPGA HEX file load 

f. Reset the card to complete the upgrade. 

If the FPGA image is not present: 

a. After the reset, the following output will be shown in the TeraTerm window: 
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Figure 16-4: AES-6 FPGA HEX file load 

The card is ready to load the FPGA image. In Tera Term, select Send File and 

select the FPGA image, which is located on the Drivers USB:  

 

• Drivers USB > ECLIPSE DRIVERS > Other_Software > xxxxxx - AES-6 FPGA  

(where xxxxxx represents the product number). 

 

b. During the download the six yellow LEDs illuminate in a circulating anti-

clockwise direction. When the download is complete, the following text should 

be displayed in TeraTerm: 

 

 

 

 

 

 

 

 

 

Figure 16-5: FPGA upgrade completed 

c. Reset the card to complete the upgrade. 
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17 Upgrading FreeSpeak II™ wireless systems 

This chapter describes how to upgrade FreeSpeak II beltpacks and transceivers supported 

by Eclipse HX. 

 

Supported FreeSpeak II beltpacks and transceivers may be upgraded using an installed and 

configured copy of EHX and an active Eclipse HX matrix, or via a USB connection from 

within EHX.  

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software and 

hardware devices. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

Note: When performing software updates, start the update and do NOT touch the IP transceiver 

until update is completed. Set a timer for 10-20 minutes to ensure enough time is allowed 

for the update. 

17.1 Upgrading FreeSpeak II Beltpacks and transceivers 

centrally using EHX 

There is currently a limitation that applies to upgrading FreeSpeak II beltpacks Over The Air 

(OTA) using EHX. It applies to specific firmware versions. Refer to the table below for more 

information.  

Start beltpack 

firmware 

New beltpack 

firmware 

Transceiver type Result 

V 1.09 or earlier V 2.14 or later E1 Upgrades successfully 

V 1.09 or earlier V 2.14 or later IPT Upgrade fails during the 

verification stage of the 

beltpack. 

V 2.14 or later V 2.14 or later E1 Upgrades successfully 

V 2.14 or later V 2.14 or later IP Upgrades successfully 

 

There is no limitation for upgrading using USB. 

FreeSpeak II beltpacks and transceivers can be upgraded centrally via EHX in a similar 

fashion to upgrading panel software. This allows multiple beltpacks or transceivers to be 

upgraded simultaneously. 

The download of a FreeSpeak II application requires an *.fww format file, which is located 

on the drivers USB. This must be placed in a location that is accessible by the installed EHX 

application. 
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Note:  
The Eclipse HX v14 contains all the firmware files required for upgrading a FreeSpeak II 

beltpack or transceiver.  

 

The download of a beltpack application requires: 

• An operational Eclipse HX matrix with the beltpacks registered, connected and powered. 
 

• A suitable EHX configuration (with the correct IP address configured, if an Ethernet connection is 
used). 
 

Once the beltpack *.fww format file is downloaded to the Eclipse HX matrix, all beltpacks 

of the same type will be upgraded at the same time through an automatic download from 

the matrix to the beltpack. The beltpack *.fww file will be stored so that if any beltpack 

subsequently connects to the matrix, an upgrade can still be performed. 

The download of a transceiver application requires: 

• An operational Eclipse HX matrix with the transceivers configured, connected and powered. 
 

• A suitable EHX configuration (with the correct IP address configured, if an Ethernet connection is 
used). 
 

Once the transceiver *.fww format file is downloaded to the Eclipse HX matrix, all 

transceivers of the same type will be upgraded at the same time through an automatic 

download from the matrix to the transceiver.  

 

To upgrade FreeSpeak II beltpack or transceiver application code using EHX: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet or 

serial communications 

port 

- 

EHX software EHX must be installed and configured. 

EHX configuration file / 

map 

- 

Ethernet or serial cable for 

the PC-to-matrix 

connection 

- 

Appropriate *.fww format 

application 

The appropriate *.fww format beltpack and 

transceiver code is available from the software 

USB 

Table 45: Required equipment 
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2. Start EHX on the PC. 

 

3. Connect the PC to the matrix using either Ethernet or serial communications port. 

 

4. Open the EHX configuration map within EHX. 

 

5. Select System > Layout. 

 

6. Right click the matrix and then select Firmware> Update Firmware.  

7) The update firmware wizard dialogue is displayed. Click Next and ensure that the 

Wireless radio button is selected. The Wireless radio button will only be availableif 

you have an E-Que FSII-TA transceiver or E-Que FSII-TA Splitter card configured in 

your matrix configuration. 

 

 

 

 

In Options: 

• Selecting Automatic mode forces beltpacks or transceivers to upgrade 

automatically. 

 

• Selecting Prompted mode means that each beltpack user will be asked to 

accept / decline the beltpack upgrade. If you select this option when 

upgrading a transceiver, the matrix will function as in Automatic mode. 

 

8. Click Next and then browse to the appropriate *.fww file. 

 

9. Click Next and confirm that the details displayed are correct. 

 

10. Click Next and confirm that the download commences. 

 

11. When the download has completed, click Finish to close the update firmware wizard. 
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12. The matrix will transmit the *.fww file to the transceivers – this process takes 

approximately 9-10 minutes. The progress of transmitting the *.fww file to the 

transceivers can be tracked using the Event Log from EHX. 

 

13. Once the file has been transmitted, if the *.fww file contains transceiver code, the 

transceivers will update themselves and restart. 

 

14. If the *.fww file contains beltpack code, the file will be transmitted to the beltpacks, 

which will indicate their progress. Upon completion of the upgrade, the beltpacks will 

restart. 

 

15. Confirm the updated firmware version using either: 

 

• The  EHX firmware report tool: 

 

- Go to EHX > System > layout. 

 

- Right click the matrix icon. 

 

- Select Firmware > Firmware report. 

 

• The local menu on the beltpack. 

17.2 Upgrading FreeSpeak II beltpacks and non-IP 

transceivers via USB 

FreeSpeak II beltpacks and transceivers can be upgraded via a micro USB cable connected 

directly to the device. This allows direct upgrading of a single device without the need to be 

connected to an active matrix. 

The download of a FreeSpeak II application requires an *.fws format file, which is located 

on the software USB. This must be placed in a location that is accessible by the installed 

EHX application. 

Note:  
The Eclipse HX v14 contains all the firmware files required for upgrading a FreeSpeak II 

beltpack or transceiver.  

 

The download of a beltpack application requires: 

• A powered beltpack connected to a PC via a USB connection 
 

• A copy of EHX installed with the appropriate USB drivers (part of a standard EHX installation) 
 

 

To upgrade FreeSpeak II beltpack or transceiver application code via USB using EHX: 
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1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an USB port - 

EHX software EHX must be installed and configured. 

USB to Micro USB cable - 

Appropriate *.fws format 

application 

The appropriate *.fws format beltpack and 

transceiver code is available from the software 

USB 

       Table 46: Required equipment 

 

2. Start EHX on the PC. 

 

3. Connect the FreeSpeak II beltpack or transceiver to the PC using either a micro USB 

cable. 

 

4. Select Tools->Apply Wireless Firmware Via USB from the EHX menu. 

 

5. The Update Wireless Firmware Via USB Dialog will now appear. 

 

6. Click Browse and then browse to the appropriate *.fws file. 

 

7. Click Update Firmware to begin the update process. 

 

8. A bar will indicate the progress of the upgrade process. It may take 10-20 seconds to 

initially connect to the device and begin the upgrade. 

 

9. When the upgrade has completed, EHX will display a message box indicating whether 

the upgrade has been successful. The beltpack or transceiver device should restart 

itself. 

 

10. Confirm the updated firmware version using either: 

 

• The local menu on the beltpack. 

• The  EHX firmware report tool: 

 

- Connect the device to the matrix and allow it to connect. 

 

- Go to EHX > System > layout. 

 

- Right click the matrix icon. 

 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 273 of 315   

 

 

 

 

- Select Firmware > Firmware report. 

 

17.3 Upgrading the FS II IP Transceiver firmware 

You can upgrade the IP transceiver firmware by: 

• Upgrading from the matrix (the file extension for the upgrade firmware is .fww) 

•  Using a USB connection (the file extension for the upgrade firmware is .fws) 

17.3.1 Upgrading from the matrix 

1) Right-click on the Frame in the Layout window, and then select Firmware > 

Update Firmware. The Update Firmware Wizard appears. 

2) Select Next. The following screen appears: 

 

Note: For IPT Transcievers, the Auto/Promoted radio button is always set to Auto. 

3) Select the Wireless radio button. 

4) Select Next, and then browse to the upgrade file (.tar.gz) and select Open. The 

upgrade file is loaded to the transceiver, and the transceiver restarts. You can track 

the status of the download in the EHX Event Log. 

17.3.2 Upgrading by USB connection 

Place the *tar.gz upgrade image onto a USB stick in a folder named firmware_upgrade 

located in the root of the USB FAT32 file system. 

Note: Make sure that there is only one upgrade image in the folder. If not, the incorrect image 

might be upgraded. 

The upgrade will begin automatically when you insert the USB stick. 
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Note: Both status LEDs will flash light blue once per second for 5 seconds on successful detection 

of the upgrade file. Both status LEDs will light solid red if there is an error duing the 

upgrade. 
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18 Upgrading FreeSpeak Edge 

This chapter describes how to upgrade FreeSpeak Edge beltpacks and transceivers 

supported by Eclipse HX. 

18.1 Upgrading FreeSpeak Edge transceivers 

You can upgrade the transceiver firmware by: 

• Upgrading from the matrix (the file extension for the upgrade firmware is .ccf) 

• Using a USB connection (the file extension for the upgrade firmware is .ccf) 

Note: When performing software updates, start the update and do NOT touch the IP transceiver 

until update is completed. Set a timer for 10-20 minutes to ensure enough time is allowed 

for the update. 

18.1.1 Upgrading from the matrix 

1) Right-click on the Frame in the Layout window, and then select Firmware > 

Update Firmware. The Update Firmware Wizard appears. 

2) Select Next. The following screen appears: 

 

Note: For the Edge transceivers, the Auto/Promoted radio button is 

always set to Auto. 

3) Select the Wireless radio button. 

4) Select Next, and then browse to the upgrade file (.ccf) and select Open. The 

upgrade file is loaded to the transceiver, and the transceiver restarts. 

You can track the status of the download in the EHX Event Log. 
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18.1.2 Upgrading by USB connection 

Place the *.ccf upgrade image onto a USB stick in a folder named firmware_upgrade located 

in the root of the USB FAT32 file system. 

Note: Make sure that there is only one upgrade image in the folder. If not, the incorrect image 

might be upgraded. 

The upgrade will begin automatically when you insert the USB stick. 

Note: Both status LEDs will flash light blue once per second for 5 seconds on successful detection 

of the upgrade file. Both status LEDs will light solid red if there is an error during the 

upgrade. When upgrade is complete, both status LEDs will flash green. 

18.2 Upgrading FreeSpeak Edge beltpacks 

You can upgrade the FreeSpeak II beltpack firmware by: 

• Using a USB connection (the upgrade file for USB has a .ccu extension). 

• Using an Over The Air upgrade. 

18.2.1 Upgrading by USB connection 

1) Connect the beltpack to a USB port on the computer running the EHX software. 

2) Select Tools > Apply Wireless Firmware Via USB. 

3) Browse to the location of the upgrade file, and then select Update Firmware. The 

upgrade file for USB has a .ccu extension. 

The upgrade file is downloaded to the beltpack or transceiver. 

Note: FreeSpeak Edge beltpacks must be upgraded individually. 

18.2.2 Upgrading beltpack firmware by Over The Air Upgrade 

You must first upgrade the transceivers before upgrading the beltpacks. 

When enable OTA registration on the beltpack is on, upgrade is disabled. Upgrade is re-

enabled when registration is finished. 

FreeSpeak Edge beltpacks must be upgraded one by one. 

For OTA upgrade, the beltpack must be within 15- 20 meters (50 to 66 feet) of the 

transceiver. 

1) Right-click on the Frame in the Layout window, and then select Firmware > 

Update Firmware. The Update Firmware Wizard appears. 

2) Select Next. The following screen appears 
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3) Select the Wireless radio button. Select the Automatic option.  

4) Select Next, and then browse to the upgrade file (.ccu) and select Open.  The 

upgrade file is downloaded to the connected beltpack. 

Upgrade status is  shown on the beltpack display and also in the EHX Event Log. 
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19 Upgrading 2X10 Touch 20-Key Panel 

To upgrade the 2x10 Touch panel, you will need the following equipment: 

• 2x10 Touch Panel to be upgraded 

• EHX with a valid configuration 

To upgrade the 2x10 panel: 

1) Ensure the panel is connected to the Matrix 

2) On the 2x10 Touch panel, select the Mode Button and tap Menu 

3) Select Diagnostics from the available options 

4) Select Upgrade  

Note: If this is not visible then the map has not been sent down 

5) The version displayed is the one to upgrade to. Select Yes to perform the upgrade 

The firmware will begin upgrading and will restart once completed. 
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Appendix A: CPU card layout 

 

 

Figure 19-1: Eclipse HX-Median / Eclipse HX-Omega / Eclipse 

HX-Delta CPU card layout 
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Appendix B: CPU card DIP switches 

 

 

 

Test mode settings for CPU card DIP switches 

 

 

Serial download settings for CPU card DIP switches 
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Normal running (watchdog enabled) settings for CPU card DIP switches 
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Appendix C: PiCo card layout 
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Appendix D: Eclipse HX-PiCo CPU DIP 

switches 

 

 

 

 

 

 

 

 

 

Figure 19-2: Test mode settings for Eclipse HX-PiCo DIP switches 

 

 

 

Figure 19-3: Serial download settings for Eclipse HX-PiCo DIP switches 
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Figure 19-4: Normal running (watchdog enabled) settings for Eclipse HX-PiCo DIP switches 
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Appendix E: Hitachi Renesas Flash 

Development Tool 

To install and configure the Hitachi Renesas Flash Development Tool (FDT): 

1.  Navigate to the installation file on the Eclipse installation USB: 

 

USB\3rd_Party_Software\Hitachi_FDT\fdt3_04.exe 

Double click to install. 

 

Note:  

Later versions can be downloaded from 
http://www.renesas.com/products/tools/flash_prom_programming/fdt/download_search_results.jsp# 

 

 

2. When the installation file is run, the installer displays a series of setup screens to 

configure the installation. 

 

 

Figure 19-5: Initial install screen 

Click Next. 

http://www.renesas.com/products/tools/flash_prom_programming/fdt/download_search_results.jsp
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3. Select the required language (International English, Asia (Japanese), Asia 

(English)).  

 

 
 

 

Figure 19-6: Language selection 

Click Next. 

4. Click Yes to accept the license conditions. The installer then displays the Select 

Components screen: 
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Figure 19-7: Select Components 

Note: 

It may be advisable to uncheck the Microsoft System Files checkbox as the versions 

of system files in the installation may be older than those currently on the system. If 

these files are required then the software can be uninstalled and then reinstalled 

with the system files.   

 

Click Next. 

5. The Additional Information (Application) screen is displayed. Leave the default 

options selected unless this causes an issue for other installed software. 
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Figure 19-8: Additional Information (Application) 

Click Next. 

 

6. The Kernels screen (Part 1) is displayed. Leave as is, unless you want to reduce the 

amount of disk space used by reducing the number of kernels installed. 

 

Figure 19-9: Kernels 1 
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Click Next. 

 

7. The Kernels screen (Part 2) is displayed. Leave as is, unless you want to reduce the 

amount of disk space used by reducing the number of kernels installed. 

 

 

Figure 19-10: Kernels 2 

Click Next. 

8. The Select Destination Directory screen is displayed. The default installation 

directory is usually recommended. 
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Figure 19-11: Select Destination 

Click Next. 

9. The Select Start Menu Group screen is displayed. The default menu can be used or 

the programmer can be added to the Clear-Com menu.  
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Figure 19-12: Select Start Menu Group 

Click Next. 

10. The Ready to Install screen is displayed. Click Install. The files will be installed in 

the selected directory.  

 

Figure 19-13: Ready to install 

 

11.  When the installation is complete a completion screen is displayed: 
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Figure 19-14: Installation completed 

To exit the installer, click Finish.
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Appendix F: TFTPUtil 

To install the TFTPUtil tool: 

1.  Navigate to the installation file on the Eclipse installation USB. 

 

USB\3rd_Party_Software\V-Panel TFTO Server 

App\TFTPUtil_GUI_Version_1.3.0_Installer.exe 

 

2. When the installation file is run, the installer will display a series of setup screens to 

configure the installation. The first screen is the License Agreement. Click I Agree. 

 

 

Figure 19-15: License Agreement 

 

3. The TFTPUtil Components screen is displayed. Accept the defaults and click Next. 



Eclipse HX | Upgrade Guide 

PUB-00276 Revision: A 

Page 294 of 315   

 

 

 

 

 
Figure 19-16: Components 

4. The Installation Folder destination screen is displayed. Accept the default 

destination folder unless it clashes with other system setups.  Click Install. 

 

 

Figure 19-17: Installation Folder destination screen 

5. When the installation is completed, click Close to exit the installer. If the defaults 

were accepted the TFTPUtil server can be run from Programs under TFTPUtil. 

TFTPUtil on Vista and Windows 7 PCs 
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The TFTP Util TFTP server has been known to fail on Vista or Windows 7 PCs. In this case, 

you use any TFTP server that is known to work on your PC.  

 

The TFTP servers below are known to operate on Vista or Windows 7 PCs. Install the server 

and point the server to the C:\TFTP folder as described above. 

Win Agents TFTP server  

The server is available from either of the Eclipse HX v14 upgrade media: 

Software USB \3rd_Party_Software > V-Panel TFTP Server App > tftpserver-

setup.exe 

Drivers USB \3rd_Party_Software > V-Panel TFTP Server App > tftpserver-

setup.exe  

Alternatively, it can be downloaded from http://tftp-server.com. 

SolarWinds TFTP server  

http://www.solarwinds.com/products/freetools/free_tftp_server.aspx 

tftp32 server 

http://tftpd32.jounin.net/tftpd32_download.html 

  
 
Note:  
Select the 32 or 64 bit installer. 
 

http://tftp-server.com/
http://www.solarwinds.com/products/freetools/free_tftp_server.aspx
http://tftpd32.jounin.net/tftpd32_download.html
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Appendix G: Tera Term 

To install Tera Term: 

1.  Navigate to the installation file on the Eclipse installation USB: 

 

USB\3rd_Party_Software\Teraterm 

Use the latest supplied xx.exe file. 

2. Open the file with WinZip and execute Setup.exe to start the Tera Term installation. 

The language options screen will be displayed. 

 

 
Figure 19-18: Language selection 

Select the required language mode and click Continue.  

 

3. You are asked to close any old versions of Tera Term that are running. Close any old 

versions and click Continue. 

 

4. The Destination Path screen is displayed. Enter the required installation directory 

name if it is different to the default.  It is recommended that the default is used. 

Click Continue. 
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Figure 19-19: Destination Path 

The Installation complete screen is displayed. To exit the installer, click OK. 

 

 

Figure 19-20: Installation complete 

 

TIP: The Tera Term application is used for many of the Eclipse system upgrade 

processes. You can save and recall the relevant com port settings by selecting the 

Setup / Save or restore settings options.
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Appendix H: Flash Magic 

To install Flash Magic: 

1.  Navigate to the installation file on the Eclipse installation USB. 

 

USB\3rd_Party_Software\FlashMagic\FlashMagic.exe 

 

2. Execute the file to start the installation. The Flash Magic Setup Wizard welcome 

screen is displayed. Click Next. 

 

 
Figure 19-21: Welcome screen (installer) 

3. The License Agreement screen is displayed. Accept the agreement and click Next. 

 

4. The Select Destination Location screen is displayed. Select the destination folder 

for FlashMagic (normally the default is accepted). Click Next. 
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Figure 19-22: Select Destination Location 

 

5. The Select Start Menu Folder is displayed. Select the Start menu folder for Flash 

Magic; (normally the default is accepted). Click Next. 

 
Figure 19-23: Select Start Menu Folder 

 

6. The Select Additional Tasks screen is displayed. Select Create a Desktop icon 

and / or Quick Launch icon, if desired. Click Next. 
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Figure 19-24: Select Additional Tasks 

 

7. The Ready to Install screen is displayed. Click Install.  

 

 

 
Figure 19-25: Ready to Install 

 

8. When the installation is complete, the completion screen is displayed. 
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Figure 19-26 Completion screen 

Click Finish to exit the installer. 
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Appendix I: i-Station converter cable wiring 

and rear panel layouts 

 

 

Figure 19-27: Converter cable wiring example for i-Station serial programming 
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    Figure 19-28: i-Station rear panel layout 

 

 

 

Figure 19-29: E-Station rear panel layout 

 

RESET BUTTON 

RESET BUTTON 
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Appendix J: Xilinx tools 

Xilinx programming tools are used to upgrade FPGA and CLPD code. For more information 

about using this specialized equipment, contact your Clear-Com technical support 

representative.  

The following cards and matrices can be upgraded using Xilinx tools: 

• CPU card (CPLD). 
 

• MVX-A16 (FPGA). 
 

• E-QUE / IVC-32 / LMC-64 (FPGA). 
 

• E-FIB (FPGA). 
 

• E-MADI64 (FPGA). 
 
Note: 

The E-MADI64 FPGA can also be upgraded using EHX. For more information, see 

 11.3 Upgrading the E-MADI64 application, DSP and FPGA code using EHX. 
 

• Eclipse HX-PiCo matrix (FPGA). 

 

To program the Flash PROM, you require a PC or laptop with the Xilinx iMPACT 

programming software and a Xilinx Download Cable (such as Xilinx HW-USB-II-G or 

Digilent 6003-410-011) is required.  

The Xilinx programming tool, Xilinx iMPACT, may be obtained by downloading ISE 

WebPACK™ from:  

https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/vivado-design-
tools/archive-ise.html 

 

Note:  

You must create an account at the Xilinx website, and accept a license agreement, before 

you can download ISE WebPACK™.  

Tip: A number of Found new hardware dialogs will display when the programming device 

is plugged into the USB port of the PC or laptop. Clear-Com recommends installing the 

software (which also installs the necessary drivers) before you plug in the device, to reduce 

the number of dialogs.  

 

https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/vivado-design-tools/archive-ise.html
https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/vivado-design-tools/archive-ise.html
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Appendix K: Clear-Com®End User Software 

License 

 

IMPORTANT: CAREFULLY READ THE FOLLOWING BEFORE USING THIS SOFTWARE.  

USING THE SOFTWARE INDICATES YOUR ACKNOWLEDGMENT THAT YOU HAVE 

READ THE FOLLOWING AND AGREE TO ITS TERMS.   

IF YOU DO NOT AGREE, RETURN THE SOFTWARE COMPLETE TO CLEAR-COM OR 

YOUR CLEAR-COM REPRESENTATIVE AND CANCEL THE INSTALLATION. 

THIS IS YOUR PROOF THAT YOU HAVE A VALID LICENSE.  PLEASE TREAT IT AS 

VALUABLE PROPERTY. 

HME CLEAR-COM LIMITED OR CLEAR-COM LLC., as the case may be (hereinafter 

referred to as “CLEAR-COM”), offers you this storage media containing a computer 

program and files (the “SOFTWARE”) and offers to grant to you a non-exclusive  

and non-transferable License to use the Software on the following terms.  Any new 

revision or update of the Software provided by CLEAR-COM to Customer under this 

License shall be governed by the terms and conditions of this License. 

SOFTWARE LICENSE AGREEMENT 

END USER LICENSE AGREEMENT 

 

PLEASE READ THIS END USER LICENSE AGREEMENT (“Agreement”). BY DOWNLOADING OR 

INSTALLING SOFTWARE (DEFINED BELOW), OR BY USING HARDWARE (DEFINED BELOW), 

YOU AND ANY ENTITY YOU REPRESENT (“Licensee”) AGREE TO BE BOUND BY THIS 

AGREEMENT WITH CLEAR-COM LLC (“Licensor”). IF LICENSEE DOES NOT AGREE TO ALL OF 

THE TERMS OF THIS AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE 

SOFTWARE. 

This Agreement governs Licensee’s use of the Software unless the particular software is 

subject to a separate written agreement between Licensor and Licensee that is signed by 

Licensor.   

1. Definitions. 

1.1. “Authorized Modules” means those modules of the Software identified by Licensor in 

writing designated as authorized for Licensee’s use and for which Licensee has paid the 

applicable fees. 
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1.2. “Documentation” means the then-current printed, online, and/or electronic 

documentation, if any, that is provided by Licensor to Licensee describing the use of the 

Software and/or Hardware.  “Documentation” does not include any sales or marketing 

materials. 

1.3. “Effective Date” means the date that Licensee installs or otherwise uses any 

Software or Hardware, as may be updated from time to time. 

1.4. “Exclusions” is defined in Section 5.4 (Exclusions). 

1.5. “Evaluation Software” means any Software provided to Licensee for evaluation 

purposes or otherwise designated by Licensor as evaluation software, as may be provided 

by Licensor from time to time in Licensor’s sole discretion and as specified in a separate 

written agreement between Licensor and Licensee. 

1.6. “Hardware” means the hardware sold or otherwise provided by Licensor to Licensee, 

which includes embedded Software. 

1.7. “Improvements” means modifications, improvements, derivative works and the like. 

1.8. “Intellectual Property Rights” means all intellectual property and proprietary rights 

throughout the world (including patents, trade secrets, copyrights and trademarks). 

1.9. “Machine Data” means the data that is generated by any Hardware or Software in 

connection with Licensee’s use of any Hardware. 

1.10. “Personal Data” means any information relating to an identified or identifiable natural 

person. 

1.11. “Software” means the software provided by Licensor for which Licensor references 

this Agreement (including software identified in Licensor’s order form or quotation that 

references this Agreement and any updates Licensor provides to Licensee to such software 

for use in connection with it). 

1.12. “Software Warranty” is defined in Section 5.1 (Software Warranty). 

1.13. “Software Warranty Period” is defined in Section 5.1 (Software Warranty). 

1.14. “Third Party Software” is defined in Section 2.7 (Third Party Software). 

1.15. “Use Limitations” means the limitations on use of the Software provided by Licensor 

in writing on its website or in connection with Licensee’s order and/or receipt of the 

Software (including in connection with download and/or as provided in connection with the 

order form provided by Licensor).  Use Limitations includes, but is not limited to, “node-

locked” Software licensed with respect to a specific or otherwise identifiable Hardware 

device and not to any other hardware device whatsoever, whether similar or dissimilar and 
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prohibited from any transfer or assignment whatsoever without the prior written consent of 

Licensor. 

2. License Grant and Intellectual Property Rights. 

2.1. License.  As of the Effective Date, subject to the terms and conditions of this 

Agreement (including payment and Section 2.3 (License Restrictions)) and irrespective of 

whether Hardware is sold to or rented by Licensee, Licensor grants Licensee a non-

exclusive, non-transferable, non-assignable, non-sublicensable and limited license, only in 

object code form, to (a) the number of copies of Software, whether downloaded or installed 

Software or embedded on a component or system of Hardware, purchased by Licensee and 

(b) use such Software in accordance with the Documentation and Use Limitations solely for 

Licensee’s internal business purposes.  For the avoidance of doubt and notwithstanding 

anything to the contrary in this Agreement or anywhere else, Software is licensed not sold, 

and the license to Software is only the express, written license agreement for such software 

provided by Licensor to Licensee. 

2.2. Evaluation License.  All terms and provisions of this Agreement shall apply to 

Evaluation Software, subject to the following modifications: (a) the license of Section 2.1 

(License) shall be limited to Licensee’s evaluation of the Evaluation Software only; (b) 

Licensor shall have the right at any time in its sole discretion to terminate this Agreement 

and any license to Evaluation Software upon written notice to Licensee; and (c) the 

provision of Section 5 (Limited Warranty) shall not apply with respect to any Evaluation 

Software and all Evaluation Software is provided “as is” without any warranties whatsoever, 

express or implied. 

2.3. License Restrictions.  The licenses under Section 2 (License Grant and Intellectual 

Property Rights) are conditioned on Licensee’s compliance with, and Licensee agrees to, the 

following:  (a) Licensee shall not use the Software outside of the scope of the license 

granted hereunder; (b) Licensee shall not sublicense, distribute, disclose, market, rent, 

lease or transfer the Software, the Documentation or any portion thereof to any third party 

(including through any remote access, interactive, Internet-based, service bureau or other 

on line service); (c) Licensee shall not remove or cause to be removed from any copies of 

the Software, the Documentation or any portion thereof any copyright, licensed trademark, 

patent or other proprietary notices thereon; (d) Licensee shall not modify, alter, adapt, 

translate, reverse-engineer, decompile, disassemble or attempt to discover the source code, 

underlying ideas, algorithms, file formats or programming interfaces of the Software, the 

Documentation or any portion thereof; (v) Licensee shall not export or re-export the 

Software, either directly or indirectly, without Licensor’s prior written consent or in violation 

of the laws of the United States or other jurisdiction; and (vi) Licensee shall not use any 

aspects of the Software other than the Authorized Modules, and without limiting the 

foregoing, Licensee shall use the Software only in accordance with the applicable 

Documentation, license key and any Use Limitations and only within the scope for which 
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Licensee is paying the required fees.  Licensee agrees that the Software may use or contain 

a license key mechanism limiting its use, and Licensee shall not use or enable the use of the 

Software other than in accordance with the intended limitations of any license key provided 

by Licensor (in addition to any contractual limitations).  Licensee agrees that, without 

limitation, any breach of this Section 2.3 (License Restrictions) or unauthorized use of the 

Software or Documentation is a material breach of this Agreement. 

2.4. Export, Import and Government Restrictions.  Licensee is advised that the Software 

may be subject to export laws and the laws of the country where it is delivered or used.  

Licensee shall abide by all applicable export laws and regulations.  Under such laws and 

regulations, the Software may not be sold, leased or transferred to certain restricted 

countries, restricted end-users or for restricted end-uses. 

2.5. Ownership by Licensor.  Licensor retains all Intellectual Property Rights covering or 

embodied in the Software and any Improvements to any Software.    The non-public aspects 

of the Software (including any source code of the Software) are Licensor’s confidential 

information.  Licensee shall maintain the confidentiality of Licensor’s confidential information 

and not disclose such confidential information to any third party without Licensor’s prior 

written consent.  To the extent that Licensor grants Licensee use of or access to Hardware 

or Software outside of the scope of the license in Section 2.1 (License) (e.g. access to 

source code), the terms of such use or access shall be sent forth in a separate written 

addendum to this Agreement. 

2.6. License Only.  The Software is licensed, not sold, to Licensee.  This Agreement does 

not transfer any right, title, or interest in or to any such Software regardless of any use of 

the terms “purchase,” “acquire,” “sale” or similar language herein or in any agreement 

between Licensee and any third party.  

2.7. Third Party Software.  The Software may use or rely on software that is subject to 

open source or commercial license terms as identified by Licensor in writing on its website 

or connection with Licensee’s order and/or receipt of the Software (“Third Party Software”).  

Third Party Software is provided “as is” without any warranty, express, implied or 

otherwise. 

2.8. No Other Rights.  All Intellectual Property Rights of Licensor not expressly granted to 

Licensee in this Agreement are expressly reserved by Licensor.  Without limitation, Licensee 

receives no right or license, by implication, estoppel or otherwise, to any software, 

technology or Intellectual Property Rights not embodied in the Software, even if such other 

software, technology or Intellectual Property Rights are useful or necessary in connection 

with the Software. 

3. Data. 
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3.1. Ownership of Machine Data.  Licensor retains all Intellectual Property Rights covering 

or embodied in the Machine Data and any Improvements to any Machine Data.  In the event 

that Licensee acquires any rights in or to any Machine Data, Improvements thereto or 

Intellectual Property Rights covering or embodying the Machine Data or Improvements to 

the Machine Data, Licensee shall assign, and hereby assigns, all right, title and interest in 

such Improvements and Intellectual Property Rights to Licensor.  Licensor grants Licensee a 

non-exclusive, non-transferable, non-assignable, non-sublicensable, royalty-free, fully paid-

up and limited license to use such Machine Data for Licensee’s internal business purposes. 

3.2. Transfer and Access to Machine Data.  Machine Data may be transferred 

automatically or as facilitated by Licensor or Licensee’s representatives, from Hardware to 

Licensor, from time to time, and Licensee hereby acknowledges and agrees to such transfer 

of Machine Data.  To the extent that any such Machine Data cannot be automatically 

transferred to Licensor or is not otherwise not conducive for such automatic transfer, 

Licensee shall transfer such Machine Data to Licensor, whether in-person or pursuant to a 

separate network transfer protocol or procedures, at a time, location or pursuant to 

procedures mutually acceptable to Licensee and Licensor. 

3.3. Personal Data.  Information on the Personal Data collected by Licensor from 

Licensee, which may be included in Machine Data, and how Licensor treats that Personal 

Data is set out in Licensor’s privacy policy, which can be found at 

https://www.clearcom.com/privacy-policy/. 

4. Payment.  The terms of this Section 4 (Payment) shall apply to the extent that there 

are no conflicting provisions in a separate written agreement (e.g. terms of sale) between 

Licensor and Licensee. 

4.1. Payment.  All fees for the Software are due and payable in U.S. dollars by bank wire 

transfer in immediately available funds to a bank account designated by Licensor.  If not 

otherwise provided in the respective schedule or other documentation from Licensor, then 

Licensee shall pay amounts due within thirty (30) days of invoice.  

4.2. Records and Audit Rights.  Licensee shall keep and maintain books and records in 

sufficient detail to permit the verification of Licensee’s obligations hereunder.  Licensor shall 

have the right to inspect or appoint an auditor to inspect Licensee’s systems, books and 

records relevant to this Agreement and other materials as may be required to verify or 

determine Licensee’s compliance with its obligations hereunder during regular business 

hours, wherever they are normally kept by Licensee, upon not less than one (1) week’s 

prior written notice.  The cost of any such audit shall be paid for by Licensor unless material 

non-compliance is found (in which case, Licensee shall pay Licensor for the costs associated 

with the audit).   

4.3. Late Payment.  All late payments shall be subject to interest calculated at the rate of 

one and one half percent (1.5%) per month or the maximum allowable by law, whichever is 
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less.  This Section 4.3 (Late Payment) shall in no way limit any other rights or remedies that 

may otherwise be available to Licensor.  Licensee shall pay all expenses associated with 

collection (including reasonable attorneys’ fees). 

4.4. Taxes.  All stated prices, fees and other stated charges are exclusive of applicable 

sales, excise, VAT, use or similar taxes.  Licensee shall pay all such taxes, either directly or 

to Licensor, as required by applicable law or regulation.  In the event that Licensee is 

required to withhold taxes, Licensee shall provide to Licensor official receipts issued by the 

appropriate taxing authority or other evidence to establish that such taxes have been paid. 

4.5. Payment Terms.  Licensor shall have the right to require advance payment and 

require adequate assurance of payment in the event that Licensee fails to make payment 

within the time limits required hereunder or, as determined in Licensor’s sole discretion, it is 

advisable in view of Licensee’s financial condition.  The foregoing does not limit Licensor’s 

other remedies hereunder (including the right to terminate this Agreement for breach).  

5. Limited Warranty. 

5.1. Hardware Warranty.  Warranties for Hardware are set forth in a separate written 

agreement between Licensor and Licensee or as an addendum to this Agreement, as 

applicable.   

5.2. Software Warranty.  Unless otherwise set forth in a separate written agreement (e.g. 

terms of sale) between Licensor and Licensee, Licensor warrants to Licensee that, for a 

period of ninety (90) days following the delivery of the initial Software to Licensee (the 

“Software Warranty Period”), the Software will substantially conform to the Documentation 

when maintained and operated in accordance with the Documentation (“Software 

Warranty”).  Following the Software Warranty Period, Licensor may provide maintenance, 

training and support of Software as set forth in a separate written agreement between 

Licensor and Licensee or as an addendum to this Agreement, as applicable. 

5.3. Remedy.  Licensee shall provide Licensor notice during the Software Warranty Period 

identifying any non-conformity to Software Warranty and shall provide detail as requested 

by Licensor to identify the nature of the non-conformity and conditions under which it 

appears.  Licensor, at its sole option, shall use commercially reasonable efforts to repair or 

to deliver a replacement copy of the Software.  All warranty repairs by Licensor shall be 

made at Licensor’s premises, unless Licensor otherwise agrees.  Licensee’s sole remedy and 

Licensor’s sole liability with respect to any warranty regarding the Software shall be for 

Licensor to use such commercially reasonable efforts to provide the above correction during 

the Software Warranty Period. 

5.4. Exclusions.  Licensor provides no warranty for the following or any liability or claim 

arising from any of the following (collectively, “Exclusions”): (a) software and equipment of 

Licensee or any third party (including any Third Party Software); (b) directions, designs, 
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plans or specifications furnished by or on behalf of Licensee; (c) unauthorized use or use of 

the Software in violation of this Agreement or other terms with Licensor (including any 

copies of the Software not made in accordance with the terms of this Agreement and the 

limitations of the licenses granted hereunder); (d) any data provided by Licensee or third 

party; (e) any activities of Licensee or third party through the use of the Software; (f) 

modification of the Software made other than by Licensor; (g) the combination, operation or 

use by Licensee of the Software with equipment, devices or software not supplied by 

Licensor; (h) failure of Licensee to use an updated or modified Software provided by 

Licensor (including those provided to avoid error or infringement); or (i) Licensee’s use of 

the Software after termination of this Agreement. 

5.5. Warranty Disclaimer.  THE FOREGOING LIMITED WARRANTIES AND REMEDIES 

PROVIDED BY LICENSOR ARE THE SOLE AND EXCLUSIVE REMEDIES FOR ANY BREACH OF 

WARRANTY.  EXCEPT TO THE EXTENT EXPRESSLY SET FORTH ABOVE, LICENSOR 

DISCLAIMS ALL WARRANTIES, CONDITIONS, AND REPRESENTATIONS (EXPRESS OR 

IMPLIED, ORAL OR WRITTEN) WITH RESPECT TO THE SOFTWARE OR ANY SUPPORT 

RELATED THERETO (INCLUDING ANY AND ALL WARRANTIES OF MERCHANTABILITY, 

FITNESS FOR A PARTICULAR PURPOSE, NON INFRINGEMENT, NON INTERFERENCE, 

ACCURACY OF DATA, OPERATION WITHOUT INTERRUPTION OR ERROR, FREEDOM FROM 

VULNERABILITY TO INTRUSION OR ATTACK AND INTEROPERABILITY WITH ANY 

HARDWARE, SOFTWARE, SYSTEMS OR DATA NOT PROVIDED BY LICENSOR, AS WELL AS 

ANY AND ALL WARRANTIES ARISING FROM A COURSE OF DEALING, AND ALL SUCH 

WARRANTIES ARE EXCLUDED TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW. 

6. Indemnification. Licensee shall indemnify and hold harmless Licensor at Licensee’s 

expense from any action brought against Licensor to the extent that it is based on a claim 

arising out of or relating to any of the Exclusions, and Licensee shall pay any costs and 

damages finally awarded against Licensor in any such actions which are attributable to such 

claim. 

7. Limitation of Liability. 

7.1. Limitation of Liability.  LICENSOR SHALL NOT BE LIABLE FOR ANY SPECIAL, 

INDIRECT, INCIDENTAL, EXEMPLARY OR CONSEQUENTIAL DAMAGES (INCLUDING LOST 

PROFITS, BUSINESS INTERRUPTION OR LOSS OF INFORMATION) RELATING TO THIS 

AGREEMENT OR IN ANY WAY RELATED TO THIS AGREEMENT, REGARDLESS OF WHETHER 

LICENSOR WAS ADVISED OF THE POSSIBILITY OF ANY OF THE FOREGOING.  IN NO EVENT 

SHALL THE TOTAL COLLECTIVE LIABILITY OF LICENSOR FOR ALL CLAIMS HEREUNDER OR 

IN ANY WAY RELATED TO THIS AGREEMENT EXCEED AMOUNTS PAID BY LICENSEE FOR THE 

APPLICABLE SOFTWARE GIVING RISE TO THE CLAIM IN THE LAST TWELVE (12) MONTHS 

UNDER THIS AGREEMENT BEFORE THE EARLIER OF THE MAKING OF THE CLAIM OR 

TERMINATION OR END OF THE TERM OF THIS AGREEMENT. 
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7.2. Allocation of Risk.  The warranty disclaimer and limitations of liability set forth in this 

Agreement shall apply irrespective of any failure of the essential purpose of any limited 

remedy.  Licensee and Licensor each acknowledge and agree that the limitation of liability 

provisions of this Agreement reflect an informed, voluntary allocation between them of the 

risk associated with the exercise of Licensee’s rights regarding the Software and, but for 

these provisions, Licensor would not have made the Software available to Licensee under 

the terms contemplated under this Agreement.  

7.3. Applicable Law.  The warranty disclaimer and limitations of liability set forth in this 

Agreement shall not apply to the extent prohibited by law, in which case the disclaimer or 

limitation shall be modified to disclaim and/or limit in accordance with applicable law.  

Without limiting the foregoing, to the extent required by law, the foregoing limitations shall 

not apply to claims due to fraud, bodily injury or death. 

8. Term and Termination. 

8.1. Term.  Unless terminated earlier as set forth below, this Agreement shall become 

effective upon the Effective Date and shall continue for the license term stated by Licensor 

in writing on the Licensor website or in connection with Licensee’s order and/or receipt of 

the Software.   

8.2. Termination for Cause.  Without prejudice to any other right or remedy which may 

be available to it, each party may terminate this Agreement upon written notice to the other 

upon the other party’s material breach of this Agreement that is incurable or, if curable, 

remains uncured thirty (30) days after notice to the other party or, in the case of failure to 

make payment, remains uncured ten (10) days after notice to the other party.  Licensee’s 

failure to pay amounts when due hereunder shall be deemed a material breach. 

8.3. Termination for Bankruptcy.  Each party may terminate this Agreement immediately 

upon written notice to the other upon the other party (a) becoming insolvent or bankrupt; 

(b) dissolving or ceasing to conduct business in the ordinary course; (c) making an 

assignment for the benefit of its creditors; (d) commencing any insolvency, receivership, 

bankruptcy or other similar proceeding for the settlement of its debts; or (e) having 

commenced against it any insolvency, receivership, bankruptcy or other similar proceeding 

for the settlement of its debts that is not dismissed within thirty (30) days after notice of 

such proceeding.  

8.4. Return or Destruction of Software.  Within fifteen (15) days after termination of this 

Agreement, Licensee shall certify in writing to Licensor that all copies of the Software and 

Documentation in any form (including partial copies) have been destroyed or returned to 

Licensor.  

8.5. Effect of Termination.  If this Agreement is terminated for any reason, then all rights 

granted hereunder to Licensee shall terminate.  The provisions of Sections 1 (Definitions), 
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2.3 (License Restrictions), 2.4 (Export, Import and Government Restrictions), 2.5 

(Ownership by Licensor), 2.7 (Third Party Software), 3 (Data), 4 (Payment), 5.4 

(Exclusions), 5.5 (Warranty Disclaimer), 6 (Indemnification), 7 (Limitation of Liability), 8 

(Term and Termination) and 9 (Miscellaneous) shall survive any termination or expiration of 

this Agreement. 

9. Miscellaneous. 

9.1. Relationship of Parties.  The parties to this Agreement are independent contractors 

and this Agreement shall not establish any relationship of partnership, joint venture, 

employment, franchise, or agency between the parties.  Neither party shall have the power 

to bind the other or incur obligations on the other’s behalf without the other’s prior written 

consent. 

9.2. Assignment.  Licensee shall not have the right to assign, transfer or delegate this 

Agreement, in whole or in part, without Licensor’s prior written consent and any attempt 

thereto shall be null and void. 

9.3. Force Majeure.  Nonperformance of any party (other than with respect to payment 

obligations) shall be excused to the extent that performance is rendered impossible by 

strike, fire, earthquake, flood, governmental acts or orders or restrictions, failure of 

suppliers or any other reason where failure to perform is beyond the reasonable control of 

the nonperforming party.  

9.4. Federal Acquisition.  This provision applies to all acquisitions of the Software by or 

for the Federal Government, whether by any prime contractor or subcontractor (at any tier) 

and whether under any procurement contract, grant, cooperative agreement, or other 

activity by or with the Federal Government.  By accepting delivery of the Software, the 

Government agrees that the Software qualifies as “commercial items” as that term is 

defined at 48 C.F.R. 2.101 and that the software and documentation delivered by Licensor 

consists of “commercial computer software” and “commercial computer software 

documentation” as such terms are used in 48 C.F.R. 12.212. Consistent with 48 C.F.R. 

12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4, all Federal Government end users 

acquire the software and documentation with only those rights set forth herein.  The terms 

and conditions of this Agreement shall pertain to the Federal Government’s use and 

disclosure of the software, and shall supersede any conflicting contractual terms or 

conditions.  Disputes with the Federal Government shall be subject to resolution pursuant to 

the Contract Disputes Act of 1978, as amended.  If this Agreement fails to meet the 

Government’s needs or is inconsistent in any respect with Federal law, then the Federal 

Government shall return the Software, unused, to Licensor. 

9.5. Governing Law.  This Agreement shall be governed by, and construed in accordance 

with, the laws of the State of California, USA, applicable to contracts made in and fully 

performed in the State of California, USA, without reference to conflict of law or choice of 
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law principles that would cause the application of laws of any other jurisdiction.  The United 

Nations Convention on Contracts for the International Sales of Goods shall not apply to this 

Agreement.  The use of the words “include,” “includes” and “including” followed by one or 

more examples is intended to be illustrative and does not limit the scope of the description 

or term for which the examples are provided.  In any action or proceeding under which a 

party enforces its respective rights hereunder, the non-prevailing party agrees to pay all 

costs incurred by the prevailing party therein (including reasonable attorneys’ fees). 

9.6. Severability. If any provision of this Agreement or the application thereof is for any 

reason, and to any extent thereof, determined by a court of competent jurisdiction to be 

invalid or unenforceable under applicable law, then a valid provision that most closely 

matches the intent of the original shall be substituted and the remaining provisions of this 

Agreement shall be interpreted so as best to reasonably effect its original intent. 

9.7. Waiver.  The failure by either party to enforce any provision of this Agreement shall 

not constitute a waiver of future enforcement of that or any other provision. No waiver by 

either party of any such provision shall be deemed to have been made unless expressed in 

writing and signed by such party. 

9.8. Notices.  All notices required or permitted under this Agreement shall be in writing 

and delivered by courier, overnight delivery service or by certified mail and in each instance 

shall be deemed given upon receipt.  All notices shall to Licensor be sent to the addresses 

set forth below or to such other address as may be specified by Licensor on its website or 

otherwise in writing.  Licensor may provide notices to Licensee at the address provided by 

Licensee in connection with its order or otherwise as changed by Licensee by notice to 

Licensor in accordance with this clause. 

Notices to Licensor: 

 

Clear Com LLC 

2848 Whiptail Loop 

Carlsbad, CA  92010  USA 

Attention: General Counsel 

 

9.9. Effect of Purchase Orders and Other Documents.  This Agreement is intended by 

Licensor and Licensee to operate as a basic set of operating conditions regarding the license 

of the Software and related services.  Purchase orders or other documents may be used for 

convenience to identify the order information and any other terms of purchase orders are 
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hereby rejected.  Unless otherwise expressly provided herein, this Agreement shall prevail 

over any conflicting or additional terms or conditions of any purchase order or other 

document exchanged in connection with the ordering of the Software and related services.  

Any such conflicting or additional terms of Licensee are hereby deemed to be material 

alterations and notice of objection to and rejection of them is hereby given. 

9.10. Entire Agreement.  This Agreement contains the complete understanding and 

agreement of the parties and supersedes all prior or contemporaneous agreements or 

understandings, oral or written, relating to the subject matter herein.  Any modification or 

amendment of any provision of this Agreement shall be effective only if in writing and 

signed by duly authorized representatives of the parties. A facsimile or e-mail transmission 

of a signed version of this Agreement shall be legal and binding on the applicable party. 

 


